Old 01-09-2015, 07:37 AM   #526
Prodigy
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2009
Posts: 16
Default

Running 7.7.3 with ioNiNJA.1.0.Beta4.2012-10-02 , how to fix
Code:
01-09-2015 19:35:22 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
can't read "ioNJ(load_cfg_startup)": no such variable
    while executing
"if { !$ioNJ(load_cfg_startup) } {
	if {[catch {source "../scripts/ioNiNJA/ioNiNJA.cfg"} error]} {
		iputs -nobuffer $error
		return
	}

	if {[catch {s..."
    (file "..\scripts\ioNiNJA\ioNiNJA.itcl" line 4)
----
I have already setup per-readme.

Edit:
Nevermind, doh forgot to copy init.itcl.

Last edited by Prodigy; 01-09-2015 at 07:53 AM.
Prodigy is offline   Reply With Quote
Old 01-10-2015, 03:15 AM   #527
Prodigy
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2009
Posts: 16
Default

How to fix this :
Code:
01-10-2015 08:58:05 "..\scripts\ioNiNJA\plugins\ioTV.itcl" terminated abnormally
--- ErrorInfo ---
invalid command name "put_log"
    while executing
"put_log "ioNJ-ERROR: unable to open the user \"$ioNJ(MountUser)\"""
    invoked from within
"if {![info exists user] && ![info exists group]} {
        if {[userfile open $ioNJ(MountUser)] != 0} {
            put_log "ioNJ-ERROR: unable to ope..."
    (file "..\scripts\ioNiNJA\plugins\ioTV.itcl" line 8)
----
Also for every command ended with
Code:
[17:39:10] [R] 550 Command failed (script): No such file or directory.
There is no error logged.

Last edited by Prodigy; 01-10-2015 at 05:40 AM.
Prodigy is offline   Reply With Quote
Old 02-13-2015, 08:39 AM   #528
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

Henki2

TV-ARCHIVE (more sections support, and bug check will be great..its still buggy), never experienced a single bug with it. And for several sections just run more instances of it.

Auto-Unpack, not removes all files properly like .sfv, it does remove all files, but it creates a new sfv for the unpacked file.

CD/DVD Dirs (closes dir after complete, like on normal release) (keeps unpacking and filling on loop ), unpack to parent dir and use the modified version of nxtools.

Auto-Unpack zip support, never gonna happen, to much that can go wrong.

MVID Genre support or announce mvidgenre on IRC only? (like flac/mp3), it's already there I Think, forgot the bot variable though.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 02-13-2015, 08:41 AM   #529
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

Prodigy
You set it up wrong
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 02-20-2015, 07:04 PM   #530
Dahlia
Member
 
Join Date: Sep 2008
Posts: 33
Default

Hello, is there any way how to use ioninja scripts to show on irc IMDB info after 'site pre'? The only thing im looking for is to read nfo file from PREd dir after 'site pre' command and repost "IMDB:" in ioftpd.log.

Please advise me. Thank you.
Dahlia is offline   Reply With Quote
Old 02-22-2015, 04:34 PM   #531
Henkie2
Member
 
Join Date: Dec 2011
Posts: 41
Default

o_dog can i have your latest version of tv-archive? And hope u can add the genre announce of mvid, are u also going to add more? on your new version?
One more thing you also have a modified nxtools?
Henkie2 is offline   Reply With Quote
Old 02-27-2015, 01:37 PM   #532
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

Henkie2: Honestly, I don't know, the MV announce should be in there, you just ahve to check the variables. It is not 100% though, since it's extracted from nfo and not read from any metadata. That's a VERY bad way of doing it so don't want to put to much effort into it.
I think the modified NXtools is in here somewhere, I have no idea where it is though, sorry.

Dahlia: sorry, don't think there is a way to do that right now.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 06-12-2015, 07:10 PM   #533
mrmagoo
Junior Member
 
Join Date: Jun 2015
Posts: 1
Default

hello.

after genre ban in ioninja.. and delete banned dir.. getting this in systemerror.

ofcourse the dir is deleted after first file.. and the next 12 files results in errors.. but how to fix it?

Log file.

06-08-2015 00:31:19 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
missing file/directory
while executing
"vfs chattr $path 11"
(procedure "outstats" line 3)
invoked from within
"outstats $newracer $newleader $announce $announcestats $file "
(procedure "::ioNiNJA::ZipScript::ZipScript" line 347)
invoked from within
"::ioNiNJA::ZipScript::ZipScript 0 [lindex $args 1] [lindex $args 2] [lindex $args 3] "
("CHECK" arm line 1)
invoked from within
"switch -- [lind
06-08-2015 00:31:19 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
missing file/directory
while executing
"vfs chattr $path $x"
(procedure "readchattr" line 3)
invoked from within
"readchattr 9"
(procedure "::ioNiNJA::ZipScript::PRE_STOR" line 5)
invoked from within
"::ioNiNJA::ZipScript::PRE_STOR [lindex $args 2] "
("PRESTOR" arm line 1)
invoked from within
"switch -- [lindex $args 0] {
SYMCLEAN { ::ioNiNJA::symlink_clean }
RESCAN { ::ioNiNJA::ZipSc
mrmagoo is offline   Reply With Quote
Old 07-13-2015, 08:47 AM   #534
AndreyN
Junior Member
 
Join Date: Sep 2011
Posts: 29
Default Tell me what kind of error and how to fix it?

07-13-2015 19:48:59 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
missing file/directory
while executing
"vfs chattr "$path" 11"
(procedure "ZipScript::ZipScript" line 10)
invoked from within
"ZipScript::ZipScript 1 $pf $crc $vf"
(procedure "::ioNiNJA::ZipScript::rescan" line 94)
invoked from within
"::ioNiNJA::ZipScript::rescan "
("RESCAN" arm line 1)
invoked from within
"switch -- [lindex $args 0] {
SYMCLEAN { ::ioNiNJA::symlink_clean }
RESCAN {

I get here are two folders with the music, which is an error
1) [Sitename]-(32MB 2F-COMPLETE)-[Sitename]
2) [Sitename]-(32MB 2F-COMPLETE-ÿþDeep house-2010) - [Sitename]
AndreyN is offline   Reply With Quote
Old 08-04-2015, 08:46 AM   #535
SENSEi
Junior Member
 
Join Date: Aug 2011
Posts: 1
Default

!uptime gives this error:
Tcl error [ng_uptime]: expected integer but got "2484 756":twapi::Twapi_GetProcessListpid detail argument 1

Latest ioNiNJA.1.0.Beta5.rar and ioFTPD v7.7.2

what to do? where do I begin to search for a fix?
SENSEi is offline   Reply With Quote
Old 09-20-2015, 07:43 AM   #536
Henkie2
Member
 
Join Date: Dec 2011
Posts: 41
Default

Thx, fixed :P

Last edited by Henkie2; 10-15-2015 at 02:08 PM.
Henkie2 is offline   Reply With Quote
Old 10-30-2015, 05:20 PM   #537
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

What OS are you using?



Quote:
Originally Posted by SENSEi View Post
!uptime gives this error:
Tcl error [ng_uptime]: expected integer but got "2484 756":twapi::Twapi_GetProcessListpid detail argument 1

Latest ioNiNJA.1.0.Beta5.rar and ioFTPD v7.7.2

what to do? where do I begin to search for a fix?
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 10-30-2015, 05:22 PM   #538
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

mrmagoo: use dir dupe in nxtools, only way it will work. Never added the dupedir to ioNiNJA if i remember correctly.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 12-22-2015, 07:16 AM   #539
ioluver
Junior Member
 
Join Date: Aug 2014
Posts: 5
Default

How to sort by record label/publisher?
ioluver is offline   Reply With Quote
Old 12-22-2015, 11:37 AM   #540
ioluver
Junior Member
 
Join Date: Aug 2014
Posts: 5
Default

I've been getting 2 errors with ioninja:

1. when doing "site resort flac" on a folder with a number as first letter i get fatal script error. when i remove the folder, script works fine.

Code:
..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
wrong # args: should be "set varName ?newValue?"
    while executing
"set flacfiles = [lindex $flacfiles 0] "
    (procedure "::ioNiNJA::FLAC::Main" line 13)
    invoked from within
"::ioNiNJA::FLAC::Main"
    (procedure "::ioNiNJA::resort" line 56)
    invoked from within
"::ioNiNJA::resort  "
    ("RESORT" arm line 1)
    invoked from within
"switch -- [lindex $args 0] {
	SYMCLEAN  { ::ioNiNJA::symlink_clean }
	RESC
2. when doing "site rescan all" script crashed on a folder (not sure why), when i removed the folder script worked fine.

Code:
..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
list element in braces followed by "</Track_name>" instead of space
    while executing
"lindex $line 0"
    (procedure "get_flac_information" line 36)
    invoked from within
"get_flac_information $file"
    (procedure "ZipScript::ZipScript" line 87)
    invoked from within
"ZipScript::ZipScript 1 $pf $crc $vf"
    (procedure "::ioNiNJA::ZipScript::rescan" line 94)
    invoked from within
"::ioNiNJA::ZipScript::rescan
I am using beta4 of ioninja and i have not touched the ioNiNJA.itcl file.
ioluver is offline   Reply With Quote
Reply

Tags
added, fixes, replace, thread, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:32 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)