Old 07-17-2011, 07:59 AM   #16
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Default

it's reaaaaaally quiet =) any news?
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 07-17-2011, 04:00 PM   #17
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

sure, it's taking time. Added a few things and cleaning up things. Just finished rewriting the rescan.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-22-2011, 09:37 AM   #18
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

first alpha release out
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-23-2011, 02:09 PM   #19
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Talking

You da man! gonna test it asap!
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 07-23-2011, 08:34 PM   #20
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

any news? Does it work?
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-24-2011, 02:41 AM   #21
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

working okay here so far
ArtX is offline   Reply With Quote
Old 07-24-2011, 03:24 AM   #22
SRH99
Member
 
Join Date: Mar 2010
Posts: 44
Default

planing tests later today/in the evening
SRH99 is offline   Reply With Quote
Old 07-24-2011, 11:24 PM   #23
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

Been abroad on vacation, will start testing tonight and let you know if something comes up..
peep is offline   Reply With Quote
Old 07-26-2011, 08:31 AM   #24
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

bug report?
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-26-2011, 08:33 AM   #25
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

I did run into a few bumps on the road, but I didn't have much time to do the testing yesterday, so it'll have to wait until tonight.

The botchk script was missing twapi, "dZSbot warning: Invalid log line: 07-25-2011 23:54:10 IMDB:.." and missing exec lines for the commands in ioftpd.ini (rescan, utime, etc.). But I'll try and find more time tonight and see what I can come up with..

Last edited by peep; 07-26-2011 at 08:41 AM.
peep is offline   Reply With Quote
Old 07-26-2011, 08:47 AM   #26
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

Dunno what you mean by missing exec commands rescan utime etc?

twapi: yeah forgot to copy it to the lib
it's in ioNiNJA.1.0.ALPHA.1.2011-07-22\eggdrop\lib\tcl8.5\twapi
just copy that to the lib dir.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-26-2011, 03:59 PM   #27
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

Things I've encountered so far:

Info: io running as service, eggdrop started using scheduled botchk. Couldn't have io start using the local system account, the eggdrop wouldn't start. It dies to quickly for me to see the reason and it doesn't log it.

Will keep testing tomorrow. Only thing running as of now is io and ioNinja. Will set up nxTools next.

------------ from the partyline (newdir not announced)


[22:37] dZSbot debug: Received event: NEWDIR (log: 0).
[22:37] dZSbot error: Unhandled error, please report to developers:
unable to find window "ioFTPD::MessageWindow": The operation completed successfully.
while executing
"ioftpd user get $msgWindow $user"
(procedure "get_tagline" line 2)
invoked from within
"get_tagline [lindex $line 1]"
(procedure "readlog" line 66)
invoked from within
"readlog"
[22:37] dZSbot debug: Received event: NFO (log: 0).
[22:37] dZSbot debug: Announce skipped, "NFO" is disabled.


[22:37] dZSbot debug: Received event: DELDIR (log: 0).
[22:37] dZSbot error: Unhandled error, please report to developers:
unable to find window "ioFTPD::MessageWindow": The operation completed successfully.
while executing
"ioftpd user get $msgWindow $user"
(procedure "get_tagline" line 2)
invoked from within
"get_tagline [lindex $line 1]"
(procedure "readlog" line 66)
invoked from within
"readlog"

-------------- from SystemError.log

07-26-2011 21:26:32 "../scripts/ioninja/plugins/ioTV.itcl" terminated abnormally
--- ErrorInfo ---
can't read "ep": no such variable
while executing
"screw_octal $ep"
(procedure "::ioNiNJA::ioTVDB::TV_MKD" line 119)
invoked from within
"::ioNiNJA::ioTVDB::TV_MKD"
invoked from within
"if {![info exists pwd]} {
set pwd [file dirname [lindex $args 2]]
set path [file dirname [lindex $args 0]]
set args [lrange $args 1 end]
::ioNiNJ..."
(file "../scripts/ioninja/plugins/ioTV.itcl" line 848)
peep is offline   Reply With Quote
Old 07-26-2011, 04:04 PM   #28
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

I need to know whats going on, pasteing logs doesn't tell me much unless i can recreate the problem.

The ioftpd:messagewindow's errors means the bot is not running under the same account as ioftpd or that it can't find the ioFTPD::MessageWindow, meaning you renamed it in ioftpd.ini

eggdrop has it's own logging system: eggdrop\logs
check int here why it doesn't start under system account, that should work.

As for the tvep thing, I can't really say, and it's not a high up on the todo list. Plugins comes last.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-26-2011, 08:19 PM   #29
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

New Release out with bugfixes, read first post for link and update instructions.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-27-2011, 03:41 AM   #30
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

That's partly the reason why I previously asked if there's another place to post bug reports. This forumeasily get's cluttered when you want to post a complete report.

Both io and eggdrop was running on the same account (the eggdrop was started by io through scheduled botchk as I said), and the window names were the same (checked it a second time just before I hit submit on the post). Haven't seen those errors in the partyline during my brief test with the latest version tho.

Your latest patch got rid of the newdir events that I was talking about and you also fixed my earlier note regarding the missing lines in io.ini (regarding rescan, invite, etc.)

If I leave lock_ignore_flags (in ioNinja.cfg) empty, as in "", trying to delete a folder marked as complete gives the following errors:

[R] DELE xxx.xxx.xxx-xxx.sfv
[R] 500 'DELE': Command failed. (pre-cmd-event script)

SystemError.log:
07-27-2011 10:28:25 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
invalid bareword "lock_ignore_flags"
in expression "...ags) $flags] || ioNJ(lock_ignore_flags) == "" ";
should be "$lock_ignore_flags" or "{lock_ignore_flags}" or "lock_ignore_flags(...)" or ...
(parsing expression "![regexp $ioNJ(lock_ig...")
invoked from within
"if {![regexp $ioNJ(lock_ignore_flags) $flags] || ioNJ(lock_ignore_flags) == "" } {
set ioerror 2
set message "550 $ioNJ(zipscript_header)\n550...


EDIT: It didn't matter even if I added a couple of flags e.g. "1|M", still gives the same error.

Last edited by peep; 07-27-2011 at 05:21 AM.
peep is offline   Reply With Quote
Reply

Tags
added, fixes, replace, thread, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:59 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)