Old 01-22-2012, 05:28 PM   #256
zombies
Junior Member
 
Join Date: May 2007
Posts: 6
Default

Quote:
Originally Posted by Aviator View Post
Turns out the new modem/router has no NAT loopback function, so I resolved it by adding the hostmask and internal IP of the server in the Windows hosts file. Not pretty, but it works like a charm
What exactly do you mean by this? I'm having the same issue and I've just settled for having localhost as the address checked. However, I'm able to connect with an FTP client to the server using the external address.
zombies is offline   Reply With Quote
Old 01-24-2012, 01:27 PM   #257
Aviator
Junior Member
 
Join Date: Nov 2004
Posts: 8
Default

It is quite easy actually, i'm assuming you are using Windows OS ? In this case go to location of your hosts file, this usually is c:\windows\system32\drivers\etc\hosts. Now either open the hosts file with admin rights using notepad or any other text editor. You could also drag en drop the hosts file to your desktop and then open it with notepad or any other text editor.
Just add the following line:
localhost(lan ip) external host (wan ip)
examples:
192.168.1.4 myserver.serveftp.com
10.0.0.4 213.42.24.257
(you are now redirecting local traffic that is trying to connect to the wan ip/hostmask back to the localhost, eliminating the need for NAT loopback in your router)
Save the file and replace the hosts file with the edited one.
Do not forget to edfit the dZSbot config file, change
set bnc(LIST) "Site|ftptls://!checker: pass@localhost: port" into
set bnc(LIST) "Site|ftptls://!checker: pass@your.wan.ip.or.hostmask: port"
Rehash the bot and your all set !

Last edited by Aviator; 01-24-2012 at 01:36 PM. Reason: syntax error
Aviator is offline   Reply With Quote
Old 01-25-2012, 05:50 AM   #258
klash
Junior Member
 
Join Date: Feb 2011
Posts: 6
Default

Quote:
Originally Posted by o_dog View Post
imdb links?
http://www.imdb.com/title/tt1438176/

http://www.imdb.com/title/tt1634122/

as sample
klash is offline   Reply With Quote
Old 01-30-2012, 08:00 PM   #259
FireKiss
Junior Member
 
Join Date: Oct 2007
Posts: 6
Default

i have same problem with imdbgenre.
it announce movie's genre and {IMDb.com, Inc} tag.
what should i do to remove that last tag?

Last edited by FireKiss; 01-30-2012 at 08:09 PM.
FireKiss is offline   Reply With Quote
Old 01-30-2012, 08:16 PM   #260
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

right now you will have tolive with it. Don't have the time to debug it right now.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 01-30-2012, 08:47 PM   #261
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

in imdb.tcl exchange

if {[set matches [regexp -nocase -all -inline {<a href="/Sections/Genres/.+?/">(.+?)</a>} $data]] != ""} {
to:

if {[set matches [regexp -nocase -all -inline {<a href="/Sections/Genres/.+?/">([A-Za-z0-9]+)</a>} $data]] != ""} {
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 01-30-2012, 08:58 PM   #262
FireKiss
Junior Member
 
Join Date: Oct 2007
Posts: 6
Default

oh, good works. thanks alot, o_dog
FireKiss is offline   Reply With Quote
Old 02-03-2012, 07:52 AM   #263
inetz
Member
 
Join Date: Dec 2009
Posts: 43
Default

to get imdb to announce .. do i just edit the following line

{/xvid/} {TCL ../scripts/ioninja/plugins/imdb.itcl $args}

and set it to my dir .. like

{/incoming/xvid/} {TCL ../scripts/ioninja/plugins/imdb.itcl $args}

beucase i have done this, but nothing announces at all IMDB wise, when .nfo is uploaded to the dir. i may be missing something though.
inetz is offline   Reply With Quote
Old 02-05-2012, 05:24 PM   #264
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

check settings for proxy in config.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 02-13-2012, 05:26 PM   #265
inetz
Member
 
Join Date: Dec 2009
Posts: 43
Default

Quote:
Originally Posted by o_dog View Post
check settings for proxy in config.
thank you ! very simple fix... or lack of reading should i say.

IMDB works on .nfo now, should TV work in same way
inetz is offline   Reply With Quote
Old 02-15-2012, 05:18 PM   #266
thedepartedone
Member
 
Join Date: Apr 2009
Posts: 30
Default

@inetz .. yes, TV will work the same but in my case i have only been able to get the imdb feature to work ONLY when a .nfo file is loaded to the directory...

@odog ... i have 3 questions, perhaps you or someone else may be able to help....


first question i have pertaining to imdb plugin.... is there a way to get it to check for nfo first and if non is found (or no imdb link found in the file) then proceed to check by directory name???? i dont use sitebot/irc and i do have latest build for ioftpd, ioninja and nxtools....

second question i have involves the resort feature.... to my understanding, this feature was fixed in the latest build? however, when i try to resort my older mp3 folders to work with the SORTED BY feature, it does not add them or should i say resort them. it only sorts the NEWLY uploaded material and works for both MP3 and FLAC. am i overlooking some features?

third question also is about the RESORT/SORTED BY features.... if i was to move a bunch of folders that were sorted by the script perfectly to another location (EX: if moving the files from a smaller harddrive to a larger one for upgrade/space purposes), will the sorted links still work and be intact along with all info that normally comes up in CWD? or will i have to perform a command like site SYMCLEAN for it to check for broken links or is it something that is remembered by the folders/files and i wont have to do no work except for me transferring the material?

thanks in advance for your help...
thedepartedone is offline   Reply With Quote
Old 02-16-2012, 01:35 PM   #267
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

inetz: not your fault, it shouldn't eb enabled by default.

the resort function was probably not fixed in latest version for virtual raid dirs. Will be fixed when next version comes out but i'm swamped at the moment. if you want to resort it remove one dir at the time from virtual dir and resort it. The remove that one and resort the others one by one. Or wait for the next release.

The imdb plugin works without nfo, add it to "on complete" instead of "on nfo" and it will use nfo if avalible, otherwise the dirname.

No the dirs are not updated by default whne moving dirs around. You need to do a resort. site resort symlink SHOULD work for this since it only resorts based on onld symlinks and updates them.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 02-16-2012, 05:20 PM   #268
inetz
Member
 
Join Date: Dec 2009
Posts: 43
Default

ah some maybe if i move tv plugin to on complete?? might work.
inetz is offline   Reply With Quote
Old 02-18-2012, 07:29 PM   #269
fudgi
Junior Member
 
Join Date: Mar 2008
Posts: 19
Default

hi ,
hope you guys might know what could cause this issue.

i was running ioninja+eggdrop just fine, then i reinstalled windows 7 and tried to use my preconfigured ioftpd+ioninja+eggdrop but only ioftpd+ioninja would work, eggdrop would not..

then i setup eggdrop anew but with the same error.
i kind of think that eggdrop needs some kind of dependencies that r missing now in windows 7.

heres the error


[01:24] Tcl error in file 'prue.conf':
[01:24] couldn't open socket: invalid argument
while executing
"socket -async $ftp(host) $ftp(port)"
(procedure "Ftp::Connect" line 13)
invoked from within
"Ftp::Connect $handle"
(procedure "ng_FtpLoad" line 16)
invoked from within
"ng_FtpLoad"
(file "sitebot/dZSbot.tcl" line 318)
invoked from within
"source sitebot/dZSbot.tcl"
(file "prue.conf" line 176)
[01:24] * CONFIG FILE NOT LOADED (NOT FOUND, OR ERROR)


thx in advance
fudgi is offline   Reply With Quote
Old 02-20-2012, 04:59 PM   #270
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

you ahve a script called prunetcl loaded. this is failing. Has nothing to do with ioftpd
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Reply

Tags
added, fixes, replace, thread, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:22 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)