Go Back   FlashFXP Forums > > > >

Suggestions Got a new idea or addition which would benefit IOFTPD? Post it here!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-24-2003, 03:33 PM   #1
-=DoBBeR=-
Senior Member
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 298
Default high priority ports while in PASV BBB .se

BBB .se sites need to use high priority dataports to get good speeds towards some other parts of europe, is this something that could be implemented in ioftpd when using PASV? I think the ports are 23,24,80,443
-=DoBBeR=- is offline   Reply With Quote
Old 02-24-2003, 03:39 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Already there.. just specify ports you want to use for device, and seperate them with commas..

[HighPriority_Device]
Host = 0.0.0.0
Ports = 23,24,80,443

But this isnt really needed, if you run your server at port 24, 25, 81 or 444 and use ACTIVE mode.
darkone is offline   Reply With Quote
Old 02-24-2003, 03:49 PM   #3
-=DoBBeR=-
Senior Member
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 298
Default

kewl, will try it.
if I decide to put my server on active port 444, would that make pasv ports 23,24,80,443 unneeded?
-=DoBBeR=- is offline   Reply With Quote
Old 03-07-2003, 08:31 PM   #4
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Yep, that makes setting passive port range obsolete (as long as users are using ACTIVE [PORT] transfer mode)
darkone is offline   Reply With Quote
Old 03-15-2003, 01:12 AM   #5
tronq
Junior Member
 
Join Date: Mar 2003
Posts: 15
Default

I tried this... but I can only make it work if I set it to 444
not if I set it to say 5040
here is my settings:

[HighPriority_Device]
Host = 0.0.0.0
Ports = 80,443

snip...

[bbb-FTP_Service]
Type = FTP
Listen_Device = HighPriority_Device
Port = 5040
Description = xxx
MaxUsers = 25
Encryption = TLS
Allowed_Users = *
Req_Encrypted_Auth = !*
Req_Encrypted_Data = !*
Certificate = ..\etc\ioFTPD-rsa.pem
;Get_External_Ident = TRUE
;Data_Devices =
;Random_Devices =
tronq is offline   Reply With Quote
Old 03-17-2003, 11:37 AM   #6
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Make sure you're using passive mode when transfering files..
darkone is offline   Reply With Quote
Reply

Tags
.se, bbb, high, pasv, priority

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:49 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)