Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-05-2005, 06:51 PM   #1
Lunatik
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 40
Default Win 2003 SP1 & TCP_WAIT issue

I discovered that with Win 2003 SP1 for some reason the FTP Socket is getting stuck in a TIME_WAIT state.

Because of the new design microsoft did with the tcp/ip stack with sp1, if the state does not go to ESTABLISHED then windows will kick out the connection after 60 seconds.

As a temporary messure to get around the issue sending a NOOP command every so often will keep the connection up as it uses a new client port number, however it causes a problem with users not wanting to allow the noop command because of idling.
Lunatik is offline   Reply With Quote
Old 04-06-2005, 01:18 PM   #2
Grendel
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Grendel's Avatar
 
Join Date: Jul 2004
Posts: 187
Default

Hmm, very strange

I reinstalled my ftp-server completely new with 2003 SP1
and I can't notice any problems with my ioFTPD.

__________________
- FlashFXP v4.0 BETA (v3.7.9 Build 1401) registered
- Windows 7 x64
- McAfee Antivirus Enterprise 8.7i Patch 2 + Antispyware 8.7i
Grendel is offline   Reply With Quote
Old 04-07-2005, 12:27 AM   #3
Lunatik
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 40
Default

Make sure you have NOOP turned off. Also if you do a netstat from the command prompt you will notice that the ports in use are in TIME_WAIT. I have been using the same config since I was using Win2000 server and it hasn't been getting stuck in TIME_WAIT until SP1 was released with the new TCP/IP changes.

Details of these changes can be found here.
http://www.microsoft.com/technet/com...1204.mspx#EBAA
Lunatik is offline   Reply With Quote
Old 04-24-2005, 12:33 AM   #4
Lunatik
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 40
Default

After some testing, I found Win2K3 SP1 does something weird to port 21. If you run ioFTP on port 21 it monitors the traffic and disconnects the port if idle for 60 seconds. If you move ioFTPD to a different port say 9999 then these problems go away. I wonder if there is a way to disable whatever windows is doing on port 21.
Lunatik is offline   Reply With Quote
Reply

Tags
command, ftp, noop, sp1, state

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:43 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)