Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-26-2004, 10:16 PM   #1
efoplistiz
Guest
 
Posts: n/a
Default sitebot exclusion from implicit ssl

Hi,

im using the beta5-8-5r registered version and i have a problem excluding the sitebot or any user from implicit ssl. i tried the solution in the kb:

Require_Encrypted_Auth = !-sitebot *

but it doesnt work. the rest of the configuration is:

Require_Encrypted_Data = !* (whether this is on or off, the sitebot cant connect)
Certificate_Name = x.x.x.x (ip)
Explicit_Encryption = False
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 128

When i try from an ftp client to connect normally (without implicit ssl) it doenst connect, but when i use implicit it works normally (So it isnt a problem with the certificate or the sitebot account).

what am i doing wrong here ?

thanx for your help in advance
  Reply With Quote
Old 10-27-2004, 06:39 AM   #2
darko
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: May 2004
Posts: 74
Default

use a flag:

ioFTPD.ini:
Require_Encrypted_Auth = !S *

site CHANGE sitebot flags +S
darko is offline   Reply With Quote
Old 10-27-2004, 09:21 AM   #3
efoplistiz
Guest
 
Posts: n/a
Default

hi again

i tried to use a flag, so the bot now is 1S, and still it cannot login without ssl
  Reply With Quote
Old 10-27-2004, 03:08 PM   #4
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

The option Require_Encrypted_Auth only works for explicit SSL, obviously. Since in implicit mode, the SSL negotiation occurs when connecting, whereas explicit only negotiates after "AUTH SSL/TLS". Simply put, there is no way to exclude a user/group/etc. from implicit SSL since all connections must be secure.

You could easily create a second FTP service without implicit SSL and restrict it only to that user.

Code:
[FTP_Service]
Type                    = FTP
Device_Name             = Any
Port                    = 1234
Description             = My FTP Service
User_Limit              = 10
Allowed_Users           = *
Messages                = ..\text\ftp

### Encryption
Require_Encrypted_Auth  = !*
Require_Encrypted_Data  = !*
Certificate_Name        = 192.168.1.10
Explicit_Encryption     = True
Encryption_Protocol     = TLS
Min_Cipher_Strength     = 128
Max_Cipher_Strength	= 256

[FTP_Service_Bot]
Type                    = FTP
Device_Name             = Any
Port                    = 12345
Description             = My FTP Service
User_Limit              = 10
Allowed_Users           = -sitebot
Messages                = ..\text\ftp

[Network]
Active_Services            = FTP_Service FTP_Service_Bot ...
neoxed is offline   Reply With Quote
Old 10-27-2004, 03:36 PM   #5
efoplistiz
Guest
 
Posts: n/a
Default

i set it up and it works PERFECTLY

thank you very much for helping!
  Reply With Quote
Reply

Tags
connect, ftp, implicit, sitebot, ssl

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fxpiing in though a server with limitations zoranb General Discussion 3 05-18-2005 04:22 PM


All times are GMT -5. The time now is 07:40 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)