Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-24-2004, 06:01 PM   #1
Ridell
Junior Member
ioFTPD Registered User
 
Join Date: Oct 2003
Posts: 13
Question FXP from site and LIST ERROR

Hi,

First of all, I'm a registered user.
Second of all, I got some problems, hehe.
I am using a D-Link 624+ to share my broadband connection. I have installed latest ioFTPD on the 192.168.0.100 address.

[Any]
Host = 82.182.xxx.xxx
Ports = 35500-36500
Random = True
;Global_Inbound_Bandwidth = 10000
;Global_Outbound_Bandwidth = 10000
;Client_Inbound_Bandwidth = 100 [*registered version*]
;Client_Outbound_Bandwidth = 50 [*registered version*]
Bind = 192.168.0.100


Port of choise is 4012.
Now in the router I have made a trigger that whenever trafic is going on 4012 it will open up the 35500-36500 ports.

I'm using SSL but only for login encryption.
Require_Encrypted_Auth = !Q *
Require_Encrypted_Data = !*
Certificate_Name = xxxxx.xxxxx.com
xplicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 56
Max_Cipher_Strength = 384


A friend said to me that FXP is not possible at all if u are behind a firewall but before my users got this LIST ERROR when loging in they could check the both boxes in Alternative site to site method in FlashFXP and it would work.
Yesterday I also tried to manualy open up the 35500-36500 ports for both in and out trafic in the firewall but after that users got the LIST ERROR message.
Before that when they tried to FXP from the site the receiving site gave them this message:

Transfer Failed!
426-| - zero-byte file: Not allowed! |
426-`-----------------------------------========-------'
426 Connection closed: Connection timed out.


I have now put the server into the DMZ on the D-LINK and it works okey (I think). But I'm convinced that u are able to run the site fully functional behind a firewall/nat......or am I wrong?
Ridell is offline   Reply With Quote
Old 09-25-2004, 01:22 PM   #2
Ridell
Junior Member
ioFTPD Registered User
 
Join Date: Oct 2003
Posts: 13
Default

Tried to remove the trigger and simply just open the port 4012 and the portrange 35500-36500 for trafic both ways in the firewall. I also kept the portforward of 4012 to 192.168.0.100.

Still error.

Does anyone have a D-Link router/ioFPTD setting and managed to set it up successfully?
Please, I really want to use firewall in the router. Don't really like the idea of going DMZ with a software firewall alltho it works fine.
I want to take advantage of the things I have bought.

Please help......
Ridell is offline   Reply With Quote
Old 09-26-2004, 01:04 AM   #3
Phlegm
Junior Member
ioFTPD Registered User
 
Join Date: Aug 2002
Posts: 21
Default

add port 4011 for active transfers in your router.
Phlegm is offline   Reply With Quote
Old 09-26-2004, 04:04 AM   #4
Ridell
Junior Member
ioFTPD Registered User
 
Join Date: Oct 2003
Posts: 13
Default

It works now but I havent opened the 4011 port.

I removed the trigger completely.
Added 2 firewall rules, one for in trafic and one for out trafic using the 35500-36500 portrange on both.
Portforwarded 4012 public to 4012 local. I am almost certain I have tried that before but with unsuccessfull result, but then again, I might be wrong.

Anyway, it works now and Im happy.
Thanks for your help.
Ridell is offline   Reply With Quote
Reply

Tags
35500-36500, flashfxp, fxp, ports, site

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another way for private paths fobban Suggestions 2 03-18-2003 06:34 PM


All times are GMT -5. The time now is 07:33 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)