Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-13-2004, 01:23 PM   #1
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default ioftpd.exe taking 100% cpu

This started a few days ago and now it happens quite randomly (as far as i can se) up to 5 times a day. And that's not on one box only but 4 boxes has this same issue and it's getting really annoying
I have heard ideas about scripts causing this and such but i don't know where to start... don't even have much scripts, just iobanana and ioa. If anyone has any ideas what could be causing this or on where to start looking for errors then please let me know
Attached Images
File Type: jpg 100load.jpg (179.9 KB, 210 views)
djrob is offline   Reply With Quote
Old 09-13-2004, 01:51 PM   #2
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Have u tried site who, and kicking all users one by one (icluding the sitebot) ?
Mouton is offline   Reply With Quote
Old 09-13-2004, 04:28 PM   #3
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

No, but i'll try that. However, it seems to happen even when there's no users at all (except sitebot then) logged in
djrob is offline   Reply With Quote
Old 09-13-2004, 07:01 PM   #4
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

Goto www.sysinternals.com and download processexplorer. Start it and find out which part of ioftpd is taking the cpu time. Likely it is a script.
FTPServerTools is offline   Reply With Quote
Old 09-14-2004, 04:18 AM   #5
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Great suggestion. I'll do it right away, thanks
djrob is offline   Reply With Quote
Old 09-14-2004, 10:28 AM   #6
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

if processexplorer shows you the problem, please make a screenshot. would make a kb article with it.

ps: please don't use paint on the original screenshot! or at least, keep the unmodified version too!
Mouton is offline   Reply With Quote
Old 09-15-2004, 04:10 PM   #7
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Still not shure exactly what to look for but now it hanged again using 100%cpu and that i can see in both processs explorer and windows own task manager. It doesn't really point me in any direction regarding scripts and tcl as i can understand BUT i do see iobanana.exe running even though there is no activity what so ever on the server so that's kinda strange i guess...

djrob is offline   Reply With Quote
Old 09-16-2004, 03:16 AM   #8
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

Ok now right click on ioftpd and choose properties. THen you see another window with all the stuff io is using. Look specially at performance, performace graph but also (very important) at the threads. Likely there is one thread eating your cpu. If so try and kill the thread and see what happens. Be aware tho it might crash io so it is just to find out if it is the case. You may be able to find out why so much cpu is taking.
Also you can use filemon to see if io is constantly busy reading writing files (kick everyone out first of course).
FTPServerTools is offline   Reply With Quote
Old 09-17-2004, 10:46 AM   #9
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Ok, "finally" it hanged again...
Tried doing like suggested but as usual i'm not really shure on how to do it so i did some screenshots of it






The threads didn't have any names but i tried killing them one by one. After the first nothing happened but after the second it went back to normal. That thread was called thread300...
djrob is offline   Reply With Quote
Old 09-17-2004, 11:23 AM   #10
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

I assume this is the latest ioFTPD version so I'll need some time to find where teh thread is that was hanging. The address is there, I guess darkone has enough info to tell you exactly what is hanging. Since I dont have the source code it is harder for me to say to. Then you killed the second thread the one with ioFTPD.exe+0x325a0 did iobanana get killed as well? If so then it may very well be ioBanana hanging. I had hoped I would seee some more info but alas no luck....
FTPServerTools is offline   Reply With Quote
Old 09-17-2004, 12:57 PM   #11
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

might be a good idea to check ioFTPD.log and try to find exactly what command was done at 17:30:39... (I think the screenshot u posted is the thread that was causing the problem, yes?) You might have to calculate it in UTC. Not sure if io log timestamps use UTC or localtime.
Mouton is offline   Reply With Quote
Old 09-17-2004, 04:26 PM   #12
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Not much in logs i'm afraid. This is my private server and not much activity on this one (have the same problem on 2 other more active sites though)

09-17-2004 17:11:58 LOGIN: "FTP_Service" "djrob" "siteops" "tagline... ?"
09-17-2004 17:23:33 LOGIN: "Telnet_Service" "sitebot" "nukers" "Vote djrob for president"
09-17-2004 17:23:43 LOGOUT: "FTP_Service" "djrob" "siteops" "tagline... ?"
09-17-2004 23:08:16 LOGIN: "FTP_Service" "sitebot" "nukers" "Vote djrob for president"
09-17-2004 23:08:17 LOGIN: "FTP_Service" "sitebot" "nukers" "Vote djrob for president"
djrob is offline   Reply With Quote
Old 09-17-2004, 04:35 PM   #13
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

xferlog too... to see if a file was finished uploading at that time, or a download...
Mouton is offline   Reply With Quote
Old 09-18-2004, 04:47 AM   #14
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Checked xferlog now and there were some mp3's beeing uploaded at that time yesterday but as far as i can see (and hear) they are all complete. (They were uploaded by a friend of mine just for fun and had no sfv file even)
It hung again this morning and like the last time i had to kill 2 processes to end it. This pic is before killing anything:

djrob is offline   Reply With Quote
Old 09-19-2004, 01:07 PM   #15
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

SO if you can find which mp3's it were then reupload those mp3's and see if they cause the 100% if so then you know it is a script that can not handle those mp3's. In such case contact the author of the script with one of the mp3's that goes odd and then it can be solved...
FTPServerTools is offline   Reply With Quote
Reply

Tags
causing, ideas, scripts, start, taking

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Site to site question, wont connect Xbox4144 General Discussion 3 01-09-2005 10:38 AM
Random users disappearing in <=4.5.4 Mouton Bug Reports 0 03-12-2003 10:38 AM
Speed limit busternl Suggestions 1 12-22-2002 10:39 AM


All times are GMT -5. The time now is 10:56 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)