Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-23-2003, 04:58 PM   #1
TimRear
Junior Member
 
Join Date: Dec 2003
Posts: 21
Thumbs up [FINISHED] Login only from localhost

Hi there,
i installed the newest Version of ioFTPD and configured it like it is told in the documentation. Now i can connect to the ioFTPD-account only from the same machine using ip adress "127.0.0.1". When i want to connect from anoter machine or the same machine to the IP-Adress is given from the provider, i get no access. What can i do?

In the ini file i gave the following options:
Host = 0.0.0.0
Ports = 1024-2048
Random = True

Port = 9999






Connecting to XXX.2X3.198.XXX #01
Connected to XXX.2X3.198.XXX Port 9999
Connection failed

Many thanks for any help!
TimRear is offline   Reply With Quote
Old 12-23-2003, 04:59 PM   #2
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

http://www.ioftpd.com/kb/view.php?kbid=11
Harm is offline   Reply With Quote
Old 12-23-2003, 05:08 PM   #3
TimRear
Junior Member
 
Join Date: Dec 2003
Posts: 21
Default

thnx Harm, but
now i told the ini file the correct ip adress is given from the provider, but the same happen, i cant connect!
I dont´know whats the problem. May it be a cause, that the program is running on a windows 2000 server system with a running active directory?
TimRear is offline   Reply With Quote
Old 12-23-2003, 05:32 PM   #4
Orbital
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

I must configure Hosts.Rules (in /etc dir)

To allow all ip's to connect you can delete everything in there and just add "POLICY ACCEPT 1024" (without the "'s)

Also read http://www.ioftpd.com/kb/view.php?kbid=46 for further information

Cheers :banana:
Orbital is offline   Reply With Quote
Old 12-23-2003, 05:34 PM   #5
Orbital
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

Quote:
Originally posted by Orbital
I must configure Hosts.Rules (in /etc dir)

To allow all ip's to connect you can delete everything in there and just add "POLICY ACCEPT 1024" (without the "'s)

Also read http://www.ioftpd.com/kb/view.php?kbid=46 for further information

Cheers :banana:
sorry about this (but it seems I cant edit my own posts)

"I must configure Hosts.Rules (in /etc dir)" Should be "YOU" instead of "I"
Orbital is offline   Reply With Quote
Old 12-23-2003, 05:42 PM   #6
Orbital
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

Oh.. And you are sure you use the correct ports?

if I understand you correct from reading your .ini file it seems that you want users to connect to port 9999 while ioFTPD is listening to ports 1024-2048. Get your users to connect to a port IN the portrange.. another tip is to never use the default settings

And read the fINE manual wich harm put so much time and effort in

I have used ioFTP for 4days now and I already feel like a superhero thanks to the documentation and KnowledgeBase

Whohoo!
Orbital is offline   Reply With Quote
Old 12-23-2003, 05:43 PM   #7
TimRear
Junior Member
 
Join Date: Dec 2003
Posts: 21
Default

Hey Orbital,
many thanks for your Help. Now it Works.
Very simple if you know a bit of the program. I think i have to read much more documentations!!!

Would you like to marry me?
Thank you very much!
TimRear is offline   Reply With Quote
Old 12-23-2003, 05:46 PM   #8
Orbital
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

My pleasure m8...

Just do it the hard way.. trial and error.. You'll get there, I promise you.

And read read read...

oh.. and no.. I will NOT marry you...
Orbital is offline   Reply With Quote
Reply

Tags
9999, connect, machine, port, xxx.2x3.198.xxx

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Long filenames mullbank General Discussion 2 11-12-2004 03:02 PM
.ioFTPD files bug in 4.5.4 WarC Bug Reports 1 02-27-2003 04:31 AM


All times are GMT -5. The time now is 12:17 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)