Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-13-2003, 05:36 PM   #1
Dark Origin
Junior Member
 
Join Date: Aug 2003
Posts: 20
Question 421 Service not available. ON CONNECT ?

Hi all, me again

And with me comes a lot of interesting and wonderful problems.. This time I bring to you: a "421 Service not available, remote server has closed the connection." error.

Might sound as if Im a nutter, but this error doesn't come when Im trying to log in, and the server finds out that there is no slots available on the server. No , this error comes BEFORE I even get to know what kind of server it is..

Code:
ftp> open <server> <port>
Connected to <server>.
421 Service not available, remote server has closed connection


It all worked in the old version I had of ioFTPd, then I updated to the newest version and it of course didn't work.


To make everything more weird: The LAN connection I have works flawlessly!

my two entries look like this:
Code:
[Any]
Host				= <server outside IP>
Ports				= 8400-8500
Random				= True
Global_Inbound_Bandwidth	= 130
Global_Outbound_Bandwidth	= 20
Client_Inbound_Bandwidth	= 130          [*registered version*]
Client_Outbound_Bandwidth	= 20           [*registered version*]
Bind				= 172.16.10.41 # Internal IP

[NAT]
Host    = 172.16.10.41 # Internal IP
Ports   = 8200-8300
Random  = True
and further down:
Code:
[FTP_Service]
Type                    = FTP
Device_Name             = Any
Port                    = 8520
Description             = huh
User_Limit              = 10
Allowed_Users           = *
Messages                = ..\text\ftp

[FTP_Service_NAT]
Type                    = FTP
Device_Name             = NAT
Port                    = 21
Description             = huh
User_Limit              = 10
Allowed_Users           = *
Messages                = ..\text\ftp

Anyone have ANY idea ?
Thanks in advance.
Dark Origin is offline   Reply With Quote
Old 11-13-2003, 05:44 PM   #2
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

What's up with the double [Any] ?

Ioftpd reads the first array it can find in ini with name "Any". If it's empty it means your setting below will not be read.
Zer0Racer is offline   Reply With Quote
Old 11-13-2003, 05:47 PM   #3
Dark Origin
Junior Member
 
Join Date: Aug 2003
Posts: 20
Default

Quote:
Originally posted by Zer0Racer
What's up with the double [Any] ?

Ioftpd reads the first array it can find in ini with name "Any". If it's empty it means your setting below will not be read.
Sorry I made a mistake when editing the stuff above. Ill look it thru again, that second [ANY] isnt there in my ini file.
Dark Origin is offline   Reply With Quote
Old 11-13-2003, 10:38 PM   #4
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

ioftpd.com/documentation/02-install.php#6
Mouton is offline   Reply With Quote
Old 11-14-2003, 04:08 AM   #5
Dark Origin
Junior Member
 
Join Date: Aug 2003
Posts: 20
Default

Im sorry mouton, but could you be a little bit more specific ?

[EDIT]
WOW, I wrote that, and then I saw it (the number 6 right? hehe).
All these new things that comes with a new release..
I'm soooo smart !!


Well, I guess my problem this time wasn't so complex after all

[/EDIT]
Dark Origin is offline   Reply With Quote
Old 04-28-2006, 06:08 PM   #6
phryx
Junior Member
 
Join Date: May 2003
Posts: 5
Default

I am having a similar problem, i cannot connect from some sites but from others it works, locally is flawless, from my webserver in the us aswell, but some say it dosnt work at all... :/ all they get is, 421 Service not available, remote server has closed connection, and its quite annoying as i see nothing in my logs on my end.

If anyone has any advice on whats wrong it would be greatly appreciated.


PS. some of the people having trouble connecting to it is from the netherlands.
phryx is offline   Reply With Quote
Old 04-28-2006, 06:27 PM   #7
phryx
Junior Member
 
Join Date: May 2003
Posts: 5
Default

nm this, it sorted itself somehow.
phryx is offline   Reply With Quote
Reply

Tags
connection, error, ftp, server, service

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:10 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)