Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-02-2003, 09:44 AM   #1
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default Does ioF use port -1?

Hmm, I'm currenly running at port 81, since this actually seems to give me the best speeds (probaly due to the way my ISP is using QoS).

My problem is that quite often my webpage is not available...

I checked what was using the port (netstat -a) and noticed that I had some strange connections to http.
Futher investigation showed that these belonged to orther peepz connected to ioF.
Now I havent seen this problem before I installed ioF, and I was just wondering if this is a bug or something similar to port 21/20 "going" together.

Do I really have to run it at another port to avoid this problem or is there a setting to do this?

I'm running ioF5.2.12, ioB18d and ioA 0.81 mostly with default settings...

/Thomas
ThomasH is offline   Reply With Quote
Old 11-02-2003, 09:56 AM   #2
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

Yes - ioFTPD uses port -1
Pichento is offline   Reply With Quote
Old 11-02-2003, 10:11 AM   #3
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default

And is there a solution, besides using another port?

/Thomas
ThomasH is offline   Reply With Quote
Old 11-02-2003, 10:20 AM   #4
Hw0aRaNg
Junior Member
 
Join Date: Jan 2003
Posts: 15
Default

i guess you leech on bbb

it is the port 80 who is priviliged by bbb, and it's for that we use port 81. If data port is NOT 80 (81 - 1), the trick doesnt work.

try to use another trick port.

best regards
Hw0aRaNg is offline   Reply With Quote
Old 11-02-2003, 10:24 AM   #5
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default

BBB?

Nope, but I got results at 1400 kbps on a 10MBit runnning on port 81 instead of something higher...
Which is why I like this port so much...

But I'll see what I can do to fix it, perhaps using 444 instead...

/Thomas
ThomasH is offline   Reply With Quote
Old 11-02-2003, 12:21 PM   #6
alturismo
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Nov 2001
Posts: 265
Default

set your ioFTPD server data ports like this

22,23,80,443

may exlude 80 if theres also an http app running

and turn in your ffxp settings at your io server

alternative FXP UPLOAD on

PASV also for sure must work

then u can transfer from "bbb" or others on those high priority

ports to your ioFTPD server
alturismo is offline   Reply With Quote
Old 11-02-2003, 03:56 PM   #7
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default

I'm not completely sure how to do that.

Heres from my ioFTPD.ini:
Code:
[FTP-Listen]
Host = <external IP>
Client_Inbound_bandwidth = 0
Client_Outbound_bandwidth = 0
Bind = 10.0.0.130

[FTP-Data]
Host = <external IP>
Ports   = 20000-30000
Random  = True
Global_Inbound_bandwidth = 0
Global_Outbound_bandwidth = 0 
Bind = 10.0.0.130

[FTP_Service]
Type 		= FTP
Device_Name  	= FTP-Listen
Data_Devices 	= FTP-Data
Port  		= 81
.
.
Suggestions, please?

And thanx for the help everybody.

PASV is needed for most users to get though my firewall/router.

/Thomas
ThomasH is offline   Reply With Quote
Old 11-02-2003, 04:15 PM   #8
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Using port 81 for your ftp is fast because the port 80 (which is then used for file transfers)is prioritized by your ISP.

You can't have two services using the same incoming port and expect all to work. You either change your webserver port, or you change your ftp port.

As suggested above, using 444 should work, since your data transfers would then use port 443, which is the https port, and is often prioritized as 80 is.

So just change 81 for 444 and see what speed u get.
You won't be able to host https webpages then, but eh, not many use that.

By the way, PASV is not related to your server network configuration, but to the client network configuration.
It's needed if the client uses a gateway/router, since no server-to-client connection can be established.
The client has to use PASV, which allows it to initiate all connections itself, while the server only wait for connections and instructions to send data.
Mouton is offline   Reply With Quote
Old 11-02-2003, 05:53 PM   #9
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default

Quote:
Originally posted by Mouton

By the way, PASV is not related to your server network configuration, but to the client network configuration.
It's needed if the client uses a gateway/router, since no server-to-client connection can be established.
The client has to use PASV, which allows it to initiate all connections itself, while the server only wait for connections and instructions to send data.
Thanx for the info, I'll be trying out port 444 as soon as possible - I need to let some people in on the change first.

But regarding the above:
Somewhere I must have misunderstood something, since as far as I know and can see, its when using PASV for the connection, it is the server that is providing both the port and ip the communication is using...
When using non-passive my computer uses its own settings for the PORT and IP. (As setup in FlashFXP's prefrences/proxy-firewall tab under port range and bind sockets).

Please clarify if I have misunderstood something...

/Thomas
ThomasH is offline   Reply With Quote
Old 11-02-2003, 11:53 PM   #10
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

This should help:

http://slacksite.com/other/ftp.html

Google some more, you should find more about the diff.
Mouton is offline   Reply With Quote
Old 11-03-2003, 02:12 AM   #11
alturismo
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Nov 2001
Posts: 265
Default

lo, an sample what to change

sample, theres an server like "bbb" where u want to fxp to an

io server outside .se

io server settings
-----------------------------------------------------------------------------------
[FTP-Data]
Host = <external IP>
Ports = 22,23,80,443

[FTP_Service]
Type = FTP
Device_Name = FTP-Listen
Data_Devices = FTP-Data
Port = whatever port u want
-----------------------------------------------------------------------------------
bbb server settings doesnt care
-----------------------------------------------------------------------------------

now this io server uses "high priority data ports", wich would be

needed to get the speed

what u need to do also is, get the io server now to "advice" those

ports by setting in your ffxp settings,

alternative fxp upload PASV on

when u now transfer from bbb to your io, u ll see that the io

now gives the ports instead of the "sending" bbb server

like this

227 Entering Passive Mode (xx,xx,xx,xx,x,22)
227 Entering Passive Mode (xx,xx,xx,xx,x,23)
..

then u get ur full speed and can use ftp login port whatever u want

may that helps better
alturismo is offline   Reply With Quote
Old 11-03-2003, 07:49 AM   #12
ThomasH
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 30
Default

Interesting, I will be trying this out.
Thank you.

Just one question: Does this mean that only 4 persons can download/upload at the same time from me?

/Thomas
ThomasH is offline   Reply With Quote
Reply

Tags
iof, port, problem, running, similar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:08 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)