Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-08-2003, 12:53 PM   #1
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default Beta5...

Registered users may get it from member pages... I hope you like it ;p
darkone is offline   Reply With Quote
Old 09-08-2003, 01:27 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Please read the changelog.. seems like quite a few people have missed the part where it tells you to use convertor for passwd & group files.
darkone is offline   Reply With Quote
Old 09-08-2003, 01:34 PM   #3
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

http://www.ioftpd.com/passwdconv/
Zer0Racer is offline   Reply With Quote
Old 09-08-2003, 01:49 PM   #4
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

sweat d1..

nice work once again
Pichento is offline   Reply With Quote
Old 09-08-2003, 03:58 PM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

There seems to be some issue with ssl.. i'm working on a fix, but it might take until tomorrow to get it public
darkone is offline   Reply With Quote
Old 09-08-2003, 04:07 PM   #6
Optixxx
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2002
Posts: 26
Default

********************************************

easy....

1.edit /etc/group,copy to GroupIDtable, add ":STANDARD" each line
2.edit /etc/passwd,copy to UserIDtable, add ":STANDARD" each line
3.add ../modules
4.edit ioFPTD.ini -some lines
-start lines
-[events]
- modules-part
5./etc/ add host.rules,update .env
6.change exe lol

thats what i did...seems to run

cheers optixxx
Optixxx is offline   Reply With Quote
Old 09-08-2003, 04:59 PM   #7
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

yep

Min_Cipher_Strength = 168 <-- does NOT work.

128 bit works ok tho
Pichento is offline   Reply With Quote
Old 09-08-2003, 05:18 PM   #8
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

5.0.1
darkone is offline   Reply With Quote
Old 09-08-2003, 05:21 PM   #9
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

Connections_To_Ban = 5 #
Ban_Counter_Reset_Interval = 120 #

could you provide an explanation for those two?

Are missing from the ini
Pichento is offline   Reply With Quote
Old 09-08-2003, 05:22 PM   #10
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

5.0.1 still fails using 168 bit encryption
Pichento is offline   Reply With Quote
Old 09-08-2003, 05:35 PM   #11
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Quote:
Originally posted by Pichento
Connections_To_Ban = 5 #
Ban_Counter_Reset_Interval = 120 #

could you provide an explanation for those two?

Are missing from the ini
Connections_To_Ban = When counter (per ip) reaches this limit, user gets banned

Ban_Counter_Reset_Interval = Once there has been this many seconds since client's last connection, counter is reset
darkone is offline   Reply With Quote
Old 09-08-2003, 05:36 PM   #12
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

Ohh..

Site will die, (connection refused after some time) with 5.0.1

most connections are using SSL
Pichento is offline   Reply With Quote
Old 09-08-2003, 05:41 PM   #13
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

Ohh now i know why site seems dead.

Using a control connection bnc. that might explai it. but when it happens i connect locally and still jsut seems dead (no reply)
Pichento is offline   Reply With Quote
Old 09-08-2003, 05:46 PM   #14
Pichento
Senior Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 327
Default

Very strange...

Just seems to die (not accepting any connections). Users online are not affected.

It actually crashes..

Faulting application ioFTPD.exe, version 0.0.0.0, faulting module ioFTPD.exe, version 0.0.0.0, fault address 0x00035cc4.

OS: W2K3 Server (standard)

Investigated further:

Its uploading that crashes site. Using zipscript på caladan. Might be the reason, but shouldnt crash site?
Pichento is offline   Reply With Quote
Old 09-08-2003, 06:18 PM   #15
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Quote:
Originally posted by Pichento
5.0.1 still fails using 168 bit encryption
Yep my ssl code seems to be rather dodgy I didn't have patience to rewrite it from scratch, so I just ported old code to fit new core (& looks like i did bad job at certain parts)

I will spend time tomorrow rewriting most of it.. (I managed to get it fully functional, but I don't trust quality of that before I've rewritten it)
darkone is offline   Reply With Quote
Reply

Tags
beta5, hope, pages, registered, users

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)