Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 07-21-2014, 01:28 PM   #1
MONGi
Member
 
Join Date: May 2012
Posts: 71
Default Speed limiting wan/dns

Hello,

I would like connect to the FTP within the local network without ssl, so I had adjust follow things:

Quote:
Require_Encrypted_Auth = !-ioFTPD !-USER1 !-USER2 *
Require_Encrypted_Data = !-ioFTPD !-USER1 !-USER2 *
Ok, the connection works without ssl...but...if I limiting the bandwidth e.g. to :

Quote:
Global_Outbound_Bandwidth = 1000
..."all" downloads limited.
If a user connected from a dns-provider with ssl or a user connected from the wan without ssl, the limiting is always active.

I would like ignore the transfer speed limit for users from the wan-network (internal).

Is this possible to solve?

Thank you in advance.
__________________
Best regards,
Mongi

(ioFTPD-v7.7.3 + ioNiNJA-v1.0.Beta5 + nxTools-v1.2.1 + nxAutoNuke-v2.5.1 + jeza.ioFTPD.Tools)
MONGi is offline  
Old 07-30-2014, 12:39 AM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

What you want to do is create more than one service / device in the configuration file. Instead of just using FTP_Service with the 'Any' device, create a 2nd device called 'Local' and a 2nd service called FTP_Local and set Device_Name to Local and choose a different port= number. This gives you complete control over everything. Don't forward that new port in your router and only local connections can access it so you can disable SSL and not speed limit it. Everyone else will use the original port/service and be speed limited. The server is very flexible in this regard and you can do pretty much anything you want except you'll have to use separate ports for differently configured services. There is no way to use one set of rules for a client connecting locally versus remotely using the same server port number.

To finish up you'll have to also add the new service to the [Network] section under Active_Services so it would be "FTP_Service FTP_Local" now.
Yil is offline  
Old 07-30-2014, 02:09 PM   #3
MONGi
Member
 
Join Date: May 2012
Posts: 71
Default

Quote:
Originally Posted by Yil View Post
What you want to do is create more than one service / device in the configuration file. Instead of just using FTP_Service with the 'Any' device, create a 2nd device called 'Local' and a 2nd service called FTP_Local and set Device_Name to Local and choose a different port= number. This gives you complete control over everything. Don't forward that new port in your router and only local connections can access it so you can disable SSL and not speed limit it. Everyone else will use the original port/service and be speed limited. The server is very flexible in this regard and you can do pretty much anything you want except you'll have to use separate ports for differently configured services. There is no way to use one set of rules for a client connecting locally versus remotely using the same server port number.

To finish up you'll have to also add the new service to the [Network] section under Active_Services so it would be "FTP_Service FTP_Local" now.
Hi Yil.

Perfect! Everything works now as I had wished.

Thank you very much.

To a other time
__________________
Best regards,
Mongi

(ioFTPD-v7.7.3 + ioNiNJA-v1.0.Beta5 + nxTools-v1.2.1 + nxAutoNuke-v2.5.1 + jeza.ioFTPD.Tools)
MONGi is offline  
Closed Thread

Tags
ioftpd, limiting, ssl, user1, user2

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:09 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)