Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-04-2013, 02:30 PM   #1
Aviator
Junior Member
 
Join Date: Nov 2004
Posts: 8
Default Unable to map memory problem

Hi all, I need some help with the following error:

dZSbot error: Unhandled error, please report to developers
unable to map memory: access denied.
while executing
"ioftpd user get $msgWindow $user"
(procedure "get_tagline" line 2)
invoked from within
"get_tagline [lindex $line 1]"
(procedure "readlog" line 66)
invoked from within
"readlog"

I searched on the forum and most likely it's a problem I created myself by using the service installer to run ioFTPD as a service, and the eggdrop not . I followed all the suggestions given but to no avail. What am I missing here ?

I used the service installer de de-install it, so neither would be run as a service, and tried the other option, using FireDaemon to try and start both as services, but the error remains now manual start isn't working either..
Aviator is offline   Reply With Quote
Old 10-04-2013, 08:16 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Make sure ioftpd isn't already running, and start it manually and then start the bot manually. Let's just confirm that works first. If it doesn't then check that you have the default setting of "WindowName = ioFTPD::MessageWindow" in the ioFTPD.ini config file and that you haven't touched the similar setting in the bot. Sometimes a stray edit in the config file can mess things up...

My guess is that works fine though. I believe FireDaemon should work with the right settings, though it's been a long time since I've played with it. I remember using something like enable desktop integration, and configuring FireDaemon to run the services as a user instead of the local admin account. You might try that.

The other option I believe was provided by o_dog. There is a botcheck(?) command you can setup in ioNiNJA to start eggdrop. If you go that route you have ioFTPD started either manually or as a service, and then have a siteop issue that command once the server is up and ioFTPD starts the bot which means it's always run as the same user. I haven't tried that but it's worth a shot.
Yil is offline   Reply With Quote
Old 10-05-2013, 08:47 AM   #3
Aviator
Junior Member
 
Join Date: Nov 2004
Posts: 8
Default Fixed

Thanks for your help, but the problem turned out to be caused by ioFTPD being run as ADMIN and the eggdrop as USER, somehow one of the boxes under properties got checked or unchecked (maybe by the service installer ?). By running both as ADMIN the problem is no longer there
Aviator is offline   Reply With Quote
Reply

Tags
error, invoked, ioftpd, service, unable

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:27 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)