Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-31-2013, 02:08 AM   #1
wuspring
Junior Member
 
Join Date: Oct 2007
Posts: 2
Default how can i disable ident lookup and hostname lookup in ioFTPD 7+ version

This problem confusions me so many years.

When I login the ftp server on a new host at the first time. It will take me a few seconds(5-10) delay for welcome message.

It seems that wen the version at 6.3, I got a method to resolve this problem here.

But I forget it now.

I have tried to change the configurations below, but no effect...

[Network]
ident_timeout = 0
Ignore_Hostmask_Idents = true
Secure_Ip_1 = 0 3 0 *
Dynamic_DNS_Lookup = NEVER
wuspring is offline   Reply With Quote
Old 07-31-2013, 11:50 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

There are 2 things that happen by default as soon as an incoming connection is detected. The server attempts to reverse resolve the hostname, and it sends an ident request back to the client. The ident_timeout = 0 should prevent the server from asking for an ident request at all, and the Ignore_HostMask_Idents = true option should prevent the server from caring about ident differences in hostmasks since you are no longer asking for them. I think you got everything right!

Perhaps the problem isn't ident requests at all, but the reverse DNS lookup? If no response is received you'll likely see yourself as connected from an IP address rather than a hostname. Try a 'site swho' on yourself and you should see an IP line with your IP and a Host line with the reverse resolved hostname. If you don't have a hostname then the IP didn't reverse resolve. ioFTPD isn't doing anything fancy here, it's simply asking the OS to perform the lookup and using whatever the DNS resolver uses for timeouts so I don't know if I have any control over it. There is a Hostname_Cache_Duration feature so the server internally caches these results however. You can try making this a much larger value (say a few days) so things don't time out very often to see if that helps...
Yil is offline   Reply With Quote
Reply

Tags
forget, ftp, lookup, problem, version

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:57 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)