Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-03-2012, 04:26 PM   #1
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default ioFTPD and Synckback

Anyone here use or have used the sync program SyncbackPro? I cannot get it to work with ioFTPD, I think it is something to do with MDTM, but I have tried all the different settings it gives me, but every time I try to sync a folder or drive it tells me it hasn't been done.

The only option left which I do not really want to use is change local files and dates to match that on the server
ArtX is offline   Reply With Quote
Old 06-04-2012, 12:58 AM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

I haven't used that program, but I can give you a few things to double check permission wise...

1) Check the permissions under [VFS] to make sure you allow setting timestamps at all... The default is:
Code:
TimeStamp       = /* !*
TimeStampOwn    = /* !*
Which obviously doesn't let anybody change anything.

2) There is also an exception to the above which allows you to modify the timestamp of the last file you just uploaded even if prohibited by the above rule. This makes it easy to sync new things but not existing stuff. That option is Enable_TimeStamp_On_Last_Upload under [Ftp] which also defaults to false so by default the server rejects all MDTM set commands.

3) If things still don't work you could try to hide the fact that the server supports the MDTM command at all via the Feature_Suppression feature and/or changing the permissions on the command itself...

I don't think you can use MDTM to modify the timestamp of a directory itself (just the files in it) which may be an issue for you, but it sounds like the files aren't even correct at the moment...

Another program I've played with in the past that you might want to check out is SuperFlexibleFileSyncronizer which was pretty slick for syncing files/folders. It has a ton of options, as it's name suggests, so it's a bit complicated the first time you use it to get everything the way you want. It supports syncing over FTP connections.
Yil is offline   Reply With Quote
Old 06-04-2012, 03:02 AM   #3
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

Thanks Yil, I will test out your suggestions and get back to you

edit: after trying all the things you suggested I get

Features supported by FTP server:

MODE Z: No
MDTM: Yes
MFMT: No
MLST: No
SIZE: Yes
REST: Yes
XCRC: Yes

Passive connection: Yes
Can set file last modification date and time: No - (even though this is set to true)
Supports safe copies: Yes
Supports file hashing: Yes

Last edited by ArtX; 06-04-2012 at 04:51 AM.
ArtX is offline   Reply With Quote
Old 06-04-2012, 12:00 PM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

If you check the FEAT response you'll see:
Code:
MDTM
MDTM YYYYMMDDHHMMSS filename
which indicates the server supports both retrieving and setting of file times. The plain MDTM (which is perhaps all they are looking for) is an older RFC standard command to retrieve the file time. The second is a newer proposed extension RFC and they may not be using this.

They did check for the MFMT command which is another proposed extension to set the modification time of a file. ioFTPD currently doesn't support this so that's most likely why it thinks it can't be set.

Just to make sure it isn't a permission issue, use Flash or something to upload a file and enable the set timestamp on uploaded file feature in it and see if the server accepts the timestamp change. If it does then that software must only use MFMT and that isn't support so you probably can't sync the timestamps right now...

You could see if they support any other methods to change the timestamp like via one of the site commands that some servers use, that could always be easily scripted and added to the server.
Yil is offline   Reply With Quote
Old 06-04-2012, 02:52 PM   #5
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

have made all the files 777 but still getting issues, although after seeing some in the status window I think it may be something in the ioftpd.ini file

04/06/2012 20:50:36: MDTM 20120604195035 SBSE____.9F5
04/06/2012 20:50:36: 550 SBSE____.9F5: Permission denied (config file). ----- this bit here
04/06/2012 20:50:36: SITE UTIME 20120604195035 SBSE____.9F5
04/06/2012 20:50:36: 500 'SITE UTIME': Command not understood.
04/06/2012 20:50:36: SITE UTIME 201206041950 SBSE____.9F5
04/06/2012 20:50:36: 500 'SITE UTIME': Command not understood.

I am going to have a little play about and see if I cant hunt down this little issue

edit: checking the software, it gives me 4 options

MDTM syntax

default ---- no idea what this is
MDTM [time in GMT format] filename
MDTM yyyymmddhhmmss [+- minutes from Universal Time] filename
MDTM [local time stamp] filename

I have been going through the Syncback forum but have not found anything yet, If I cant get this sorted I may email them

edit 2:

When looking at the logs that Syncback makes i have found something strange

Drive Type FTP
FTP Server Type glftpd - 215 UNIX Type: L8
Format FTP

It's not glftpd though

If i tell syncback ioftpd does not support MDTM it will transfer, although it will use the time on that machine.

Last edited by ArtX; 06-04-2012 at 03:19 PM.
ArtX is offline   Reply With Quote
Old 06-04-2012, 09:17 PM   #6
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Quote:
04/06/2012 20:50:36: MDTM 20120604195035 SBSE____.9F5
04/06/2012 20:50:36: 550 SBSE____.9F5: Permission denied (config file). ----- this bit here
Yup that's clearly a disabled permission in the config file (the default).

Check the [VFS] section... You probably have the default
Code:
TimeStamp       = /* !*
TimeStampOwn    = /* !*
and you probably want something like
Code:
TimeStamp       = /* 1M
TimeStampOwn    = /* *
or something like that. Or consider leaving the TimeStampOwn disabled and just enable the override I mentioned before that only allows setting the last file just uploaded by a user which is sufficient for almost all normal users.
Yil is offline   Reply With Quote
Old 06-05-2012, 02:14 AM   #7
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

ah - I changed that setting after i posted but i put my name there instead of the flag - will try and report back

edit:

Code:
05/06/2012 08:27:26: MDTM 20120605072725 SBSE____.PNT
05/06/2012 08:27:26: 253 Date/time changed okay.
Code:
# nobody can overwrite a file, they must delete it and resend
Overwrite    = /* 1M
NoStats      = /* *

# nobody can modify the timestamp of files
TimeStamp       = /* 1M
TimeStampOwn    = /* *
- seems to work great now

Last edited by ArtX; 06-05-2012 at 02:29 AM.
ArtX is offline   Reply With Quote
Reply

Tags
drive, files, ioftpd, option, sync

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:57 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)