Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-31-2011, 10:07 AM   #1
kublai1
Junior Member
 
Join Date: Oct 2004
Posts: 9
Default WIN 7 Local FTP Slow

Hi All,

OS: Windows 7 Ultimate, 64bit
using ioftpd 7.7.3 stable and last ioninja script
client: FlashFXP, cuteftp, filezilla
hardware: ESATA dock with 7200rpm drive

My problem is when I FTP locally all i can get is 12MB max using various FTP clients. I have ioftpd and flashfxp setup on the same PC so I'm FTP'ing locally. I have googled and these are the things I found and tried:

Large Send Offload v2 (IPv4) - Disable
Large Send Offload v2 (IPv6) - Disable

Turn off RDP Compression

ioftpd.ini I changed buffer from 8k-64k and same thing in FlasFXP and also tried default setting for transfers

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip\Parameters set value to 1

Netsh interface tcp set global autotuning=disabled, normal

I have turned off firewall to do the test but still no results. When I do a drive copy from internal to Esata i get 97MB/S. I had the same thing setup in Windows XP and I get good results between 80MB - 90MB/s
kublai1 is offline   Reply With Quote
Old 10-31-2011, 10:12 AM   #2
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

100mbit lan, 1gbit lan?
ArtX is offline   Reply With Quote
Old 10-31-2011, 10:34 AM   #3
kublai1
Junior Member
 
Join Date: Oct 2004
Posts: 9
Default

Quote:
Originally Posted by Carpo View Post
100mbit lan, 1gbit lan?
It's 1gbit LAN. I have a WRT610N router running DD-WRT and using CAT6 cable from router to my PC. I do not have this problem under Windows XP with the exact same setup. I also switched from Auto negotiate to 1GBIT/FULL
kublai1 is offline   Reply With Quote
Old 10-31-2011, 06:15 PM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Any chance this is a 2gb machine running win7 in which case it's a win7 bloat problem?

Are you using the internal IP to connect in both cases? I.e. 192.168.x.y? or the loopback 127. address? Most routers are smart enough to route external IP addresses of forwarded ports to the internal destination but I've found that they have a performance penalty for doing so. Not to mention the huge benefits using the loopback interface has.

I get no performance issues locally testing Flash to ioFTPD on the same machine, or even faster ioFTPD to ioFTPD via FXP on the same machine during testing even with SSL enabled.
Yil is offline   Reply With Quote
Old 11-03-2011, 03:49 PM   #5
kublai1
Junior Member
 
Join Date: Oct 2004
Posts: 9
Default

Quote:
Originally Posted by Yil View Post
Any chance this is a 2gb machine running win7 in which case it's a win7 bloat problem?

Are you using the internal IP to connect in both cases? I.e. 192.168.x.y? or the loopback 127. address? Most routers are smart enough to route external IP addresses of forwarded ports to the internal destination but I've found that they have a performance penalty for doing so. Not to mention the huge benefits using the loopback interface has.

I get no performance issues locally testing Flash to ioFTPD on the same machine, or even faster ioFTPD to ioFTPD via FXP on the same machine during testing even with SSL enabled.
I have a i920 machine with triple channel 9gb ram.

I am using internal ip of 192.168.0.x and also forwarded that port/ip to my router. In ioftpd.ini I used the external IP for PASV ports.
kublai1 is offline   Reply With Quote
Old 11-03-2011, 08:39 PM   #6
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

First, in FlashFxp try connecting via 127.0.0.1 and check the "use site IP for PASV" option to see if that makes a difference. My guess is this should solve the problem because as I mentioned using the external IP and having the router/modem forward it can sometimes be slow.

If that doesn't fix it, make sure you're not using SSL and see what happens. Then try installing the free version of serv-u or whatever and see if that also has a performance problem locally. It's possible you've got some really slow anti-virus, etc so check the CPU meter to see if anything really busy on any of the cores.
Yil is offline   Reply With Quote
Old 11-03-2011, 11:46 PM   #7
colin watson
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2011
Posts: 1
Default

could be anti-virus,i had avg and it slowed me down,i changed to eset and i noticed a difference.
colin watson is offline   Reply With Quote
Reply

Tags
flashfxp, ftp, large, set, setup

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:36 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)