Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-14-2011, 03:47 AM   #1
tw3ek51m
Junior Member
 
Join Date: Sep 2011
Posts: 3
Default New Date Area?

yeah gday, bit of a noob question, but im running out of ideas to get nxtool's newdate working, keep getting:

[2] 200-.-[NewDate]--------------------------------------------------------------.
[2] 200-| The newdate area "Default" is not defined. |
[2] 200-'------------------------------------------------------------------------'

09-14-2011 17:59:52 - NewDateArea : unknown newdate area "Default"

anyone know the location or area to define this properly?

set newdate(Default) {
{MP3 {New MP3} {/MP3/_arch/2011/%w} {G:\Site\MP3\_arch\2011\%w} {G:\Site\MP3\_arch\mp3-week} True 0 0 0 777}
{MP3 {Close MP3} {/MP3/_arch/2011/%w} {G:\Site\MP3\_arch\2011\%w} {G:\Site\MP3\_arch\mp3-previous} False -1 0 0 555}
}
(weekly)
from the nxtools file. thanks in advance
tw3ek51m is offline   Reply With Quote
Old 09-14-2011, 09:30 AM   #2
SRH99
Member
 
Join Date: Mar 2010
Posts: 44
Default

Does G:\Site\MP3\_arch\2011\ exist in filesystem?
SRH99 is offline   Reply With Quote
Old 09-14-2011, 01:49 PM   #3
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Couple of things... In order for nxTools to be able to resolve paths to sections you need to make sure it has access to a user and the VFS file to use, these are defined via
Code:
set misc(MountUser)     "ioFTPD"
set misc(MountFile)     "../etc/default.vfs"
Next, because '\' in TCL quotes the following character most TCL scripts use '/' as the path separator in config files because that's what TCL itself uses and that's what is returned via the ioFTPD TCL extensions. Thus your paths like G:\Site\MP3\... needs to be G:/Site/MP3/...
Yil is offline   Reply With Quote
Old 09-16-2011, 10:17 AM   #4
tw3ek51m
Junior Member
 
Join Date: Sep 2011
Posts: 3
Default

thanks for your time, yes it exists in the filesystem,

I changed the details to what yours is:

Code:
set misc(MountUser)     "ioFTPD"
set misc(MountFile)     "../etc/default.vfs"
and also changed the slashes aswell to no avail. Still kindof lost, or perhaps a setting somewhere is wrong, is there a failsafe if 'default area' is defined in ioftpd.ini/default.vfs properly? or is this an nxtools problem.
tw3ek51m is offline   Reply With Quote
Old 09-20-2011, 08:25 AM   #5
tw3ek51m
Junior Member
 
Join Date: Sep 2011
Posts: 3
Default

hmm, seems my message before didnt go through..

anyway ive tried the above solutions, changed the user/vfs file to the one defined by above, and the slashes, does not seem to work, and yes the directory does exist.

Is this a nxtools related problem? or does setting the 'default area' is in the .vfs file or ioftpd.ini ?
tw3ek51m is offline   Reply With Quote
Reply

Tags
area, gsitemp3_arch2011%w, mp3, newdate, [2]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:45 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)