Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-17-2011, 12:41 PM   #1
creasy
Junior Member
 
Join Date: Jul 2011
Posts: 3
Default ioFTPD errors under Win 2003 x64

Hello!
I have tried to install ioFTPD v7.7.2 under Windows 2003 SP2 x64. When I start ioFTPD-Start.exe the server and the gui start up, but for some reason the default ioFTPD won't login. The console contains the following error: "wSock_Error() -> Connection is forcefully rejected (10061)". If I double click on ioFTPD under Sitename it will login fine. This is with the default out of the zip configs. Also if I right click on the G icon on the tray and select any option an error message pops up (Run-time error '76': Path not found) and the server crashes. Any ideas what could be wrong?
Any help is appreciated!
creasy is offline   Reply With Quote
Old 07-17-2011, 04:00 PM   #2
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

gui? ioFTPd does not have a gui...
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 07-18-2011, 12:41 AM   #3
creasy
Junior Member
 
Join Date: Jul 2011
Posts: 3
Default

Quote:
Originally Posted by o_dog View Post
gui? ioFTPd does not have a gui...
Let's quit trolling...
How about ioGui2?
creasy is offline   Reply With Quote
Old 07-18-2011, 11:25 AM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Since the server is working fine, the issue is a timing problem during startup. Basically ioGUI is trying to connect before the server is willing to accept new connections. There's a bunch of reasons for that, but the simplest fix is just to delay ioGUI starting... What you want to do is pass an argument to ioFTPD-Start.exe which is the delay before starting ioGUI. Just create a new windows shortcut to ioFTPD-Start.exe and then click right click on the shortcut and select properties. Change the target to look like "C:\ioFTPD\ioFTPD-Start.exe 40" which means wait 40 seconds... Adjust the delay as needed, heck even 120 for 2 minutes isn't a big deal. Just remember to start the server from the new shortcut!
Yil is offline   Reply With Quote
Old 07-19-2011, 07:52 AM   #5
creasy
Junior Member
 
Join Date: Jul 2011
Posts: 3
Default

Thanks for your reply Yil.
An other problem is that in ioGUI I have some dir listing error. Some of the directories have a weird dates. The m/d/y values are correct, but there's no time and ioGUI puts the year in front of the dir name, while under date there's only m/d left. If I login to the ftp with a client then all those dirs have a 00:00:00 time. Under windows they all have different and valid creation times, Serv-U ftp server also displays all the correct dates.
creasy is offline   Reply With Quote
Reply

Tags
error, ioftpd, login, server, start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:07 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)