Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-27-2010, 03:03 PM   #1
mambule
Junior Member
 
Join Date: Oct 2010
Posts: 5
Default Local FXP with ioFTPD

I want to FXP between 2 local machines, both running ioFTPD on Win7.
Ports are properly forwarded.

I'm stuck here:

501 PORT command failed: Transfer to specified network address is not allowed.

Any help is highly appreciated.

Regards
mambule is offline   Reply With Quote
Old 11-27-2010, 04:16 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

At the moment the Changelog is probably the best place to look for details. Here's a bit from the 7.5.0 release notes:

Code:
6) The default settings for the new safety feature preventing the PORT
   command from accessing private/local LAN IP addresses means you will need
   to use PASV connections for local transfers using a FTP client on the LAN.
   This is usually the default method so you probably won't notice.  However
   FXPing between 2 FTP servers across the local LAN (i.e. both 192.168.*)
   will no longer work with the default settings.  The server will also not
   be able to FXP to itself (although if people want this I can probably
   find a way to allow it).  To enable FXP between two local machines you
   can choose to either disable the new feature on one site, or you can
   just define a second Service that is only accessible to machines on the
   local LAN that has the feature disabled.  The second Service method is
   HIGHLY recommended because you can also do things like relax the encrypted
   data transfer requirement which will improve local transfer speeds.

9) New ioFTPD.ini option (Deny_Port_Host_<num> under [FTP_Service]).  Active
   mode data transfers require the server to create connections to a user
   specified IP/Port.  For security reasons the server should be prevented
   from initiating connections to the server box or any other machine behind
   your firewall if you have one.  By default the server will now block
   access to the following non-routable private IP ranges: 10.*, 172.16.*,
   192.168.*, and the loopback interface 127.*.  To disable this feature
   entirely just specify 0.0.0.0 as the host to block.  Alternatively, you
   may specify your own custom list of IP addresses/ranges to block.
I obviously like the 2nd service method as it's more flexible and you don't give up any safety. Basically you do something like this. Copy the [FTP_Service] section in the .ini file and rename the copy as [Local_Service] or whatever you want. Disable the Deny_Port_Host feature and, if set, the encrypted transfer requirements, and change the PORT to an IP that isn't forwarded in the router. Add the new service to the list of services to start automatically via
[Network]
Active_Services = FTP_Service Local_Service

Then locally connect to the new service/port instead of the other one and you should be good to go.
Yil is offline   Reply With Quote
Old 11-27-2010, 11:05 PM   #3
mambule
Junior Member
 
Join Date: Oct 2010
Posts: 5
Default

Nice. Quick & straight to the point. And moreover, it worked out just perfectly. The 501s are gone.
Many thx for that, Yil.

However, i'm now stuck at this:

426 Connection closed: Connection timed out.

I'm having a direct local connection, PC to PC, w/ SW firewall disabled. One of them is connected to another network, so i bound ioFTPD via Bind = direct_local_connection_static IP.
I too disabled Require_Encryption on both instances.
mambule is offline   Reply With Quote
Old 11-28-2010, 01:16 AM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Hmm, I don't think you want to use the BIND feature. That's only when you have a machine that has 2 network cards and you want to make ioFTPD only use the network on one of them. If you attempt to force BIND to use a network that doesn't match one of your local interfaces things won't work... Try not setting that.
Yil is offline   Reply With Quote
Old 11-28-2010, 05:59 AM   #5
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Hi Yil! Santa Yil coming with 6.0ver for x-mas?
Flow is offline   Reply With Quote
Old 11-28-2010, 12:20 PM   #6
mambule
Junior Member
 
Join Date: Oct 2010
Posts: 5
Default

That was indeed the issue. Everything is fine now. Many thx for helping me out. Awesome work, Yil.
mambule is offline   Reply With Quote
Reply

Tags
fxp, ioftpd, local, network, transfer

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:33 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)