Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-13-2010, 09:55 PM   #1
quade1337
Junior Member
 
Join Date: Jun 2006
Posts: 7
Default group permissions

I am having trouble setting the permissions for groups.

Everytime i try to upload a file its says permession denied <directory mode>.

this is how its set in my ioftpd.ini

Upload = /XViD/* !=leechers *
Upload = * *
MakeDir = /XViD/* !=leechers *
MakeDir = * *
RemoveDir = /XViD/* !=*
RemoveDir = * *
RemoveOwnDir = /XViD/* !=leechers *
RemoveOwnDir = * *
Rename = /XViD/* !=*
Rename = * *
RenameOwn = /XViD/* !=*
RenameOwn = * *
Overwrite = /XViD/* !=*
Overwrite = * *
Delete = /XViD/* !=*
Delete = * *
DeleteOwn = /XViD/* !=leechers *

basically i have 2 groups. leechers and uploaders. I want the uploaders to have write and read axx to all the directories and the leechers just read axx to all the directories.

And only uploaders can delete a directory they made.

Last edited by quade1337; 07-13-2010 at 10:12 PM.
quade1337 is offline   Reply With Quote
Old 07-14-2010, 12:52 AM   #2
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Try if /XViD/*/* !=leechers * works.
Zer0Racer is offline   Reply With Quote
Old 07-14-2010, 01:10 AM   #3
quade1337
Junior Member
 
Join Date: Jun 2006
Posts: 7
Default

i basically replaced /XViD/* !=leechers * with /XViD/*/* !=leechers * and it still didnt work.

does it have to do anything wit the user flags???

Last edited by quade1337; 07-14-2010 at 01:21 AM.
quade1337 is offline   Reply With Quote
Old 07-14-2010, 03:06 AM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

You're looking in the wrong place...

"permission denied <directory mode>" means it's the actual directory (rwx) permission stuff that is failing. You'll want to chmod/chown the dir to get things to work right... Luckily I can now say "site help chmod" for more details
Yil is offline   Reply With Quote
Old 07-14-2010, 03:24 AM   #5
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Looking at your example a bit closer and I see something else... I don't think the !=* syntax is valid since it doesn't wildcard expand on groupnames.

You can use the "!=leechers *" syntax to disallow anyone in the leechers group while everyone else can perform the action. Or just "!*" to mean don't allow anyone to do anything. Or "=uploaders !*" to allow uploaders to do something but no-one else. You get the idea. Check out "site help" and at the bottom it should list an option for help on permission-flags...

Alternatively you can just use a user-flag like "9" or something, give that to download only users, and use that instead of the group to disallow actions that way. That's sometimes easier to maintain and the perms are a little simpler to process that testing a user's group membership...
Yil is offline   Reply With Quote
Old 07-14-2010, 11:27 AM   #6
quade1337
Junior Member
 
Join Date: Jun 2006
Posts: 7
Default

how can i set the chmod for certain groups??????
quade1337 is offline   Reply With Quote
Old 07-14-2010, 02:04 PM   #7
quade1337
Junior Member
 
Join Date: Jun 2006
Posts: 7
Default

Finally got it
quade1337 is offline   Reply With Quote
Reply

Tags
/xvid/, =leechers, delete, upload, uploaders

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:05 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)