Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-08-2010, 04:58 PM   #1
BoNeZz
Member
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 39
Default Win7 and ioFTPD 5.8.5r problem

hi everybody

under win7 64bit, ioftpd 5.8.5 works but some script not works, like ioA

i disable UAC in win7 but not works anymore

"site pre section rls"
or
"site wipe folder"

[1] SITE WIPE MYFOLDER
[1] 550 Command failed.

someone can help me?

ps: not works any .bat for example:

cd \
cd \ioftpd\scripts\stop

kill eggdrop.exe

Last edited by BoNeZz; 06-08-2010 at 05:52 PM.
BoNeZz is offline   Reply With Quote
Old 06-08-2010, 06:22 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

ioZS doesn't work properly under any 64bit windows OS that I am aware of. I can confirm via procmon that on win7 x64 it fails to load all string parameters from the registry for some reason so it has no chance of doing the right thing... You'll have to choose a different zipscript. It's possible v1.x ioZS might still work as it loads settings from .ini files but I'd recommend a newer zipscript like ioNinja or FTPServerTool's stuff.

Of course running 5.8.5r at this point is crazy. Try 7.5.7 instead (get it from a link above in this forum). You'll have to upgrade to run newer versions of ioNinja anyway.
Yil is offline   Reply With Quote
Old 06-08-2010, 06:27 PM   #3
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Oops... I just realized you meant ioA and not ioZS... I know the v2 release of ioA/B should still work the same under v7+ ioFTPD releases. I don't know about the free 1.x ioA/B releases but even the v2 stuff needs a number of fixes for it to work reliably so I'd probably use nxTools as the sitescript instead...
Yil is offline   Reply With Quote
Old 06-09-2010, 12:49 PM   #4
BoNeZz
Member
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 39
Default

Quote:
Originally Posted by Yil View Post
Oops... I just realized you meant ioA and not ioZS... I know the v2 release of ioA/B should still work the same under v7+ ioFTPD releases. I don't know about the free 1.x ioA/B releases but even the v2 stuff needs a number of fixes for it to work reliably so I'd probably use nxTools as the sitescript instead...
thanks for the reply, but i have some problems with this new ioftpd.

first problem: ssl. i try to startup ioftpd, but when i launch in raw command, site makecert , i have this message ( 500 makecert: The object or property already exists (#2148081669). )
anyway ioftpd create a files .key .pdb and .pem

and when i try to up any files with ioftpd user, the transfert not work, ( up in local and ftp in local, win7 32bit, without antivirus, without firewall, all open, also router with traffic in blocked, i must try to dmz i think. tell me if im wrong )

at the moment i have these problems, if i overcome these problems, i try to install some script to pre, make sfv, make complete, etc, like iobanana but i think that not work, because is too old, so i hope to find in this forum other script that do same things.
BoNeZz is offline   Reply With Quote
Old 06-09-2010, 02:27 PM   #5
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

If you installed v7.5.x version and didn't disable auto cert generation it will now automatically create your SSL certificate right after startup and load it when it's ready. Therefore "site makecert" isn't really necessary unless you later change the HOST= or specify a certificate name to use and need to generate it.

"Transfer not work" isn't specific. The most common issue is specifying HOST=external-ip and you connect via a local non-routable IP like 192.168.x.x and you use PASV mode and your router doesn't forward the external-ip. First double check that you are actually forwarding the passive port range in your router (5421-5450 by default I think, along with the command port default of 5420 or whatever you changed it to). If that is set then you'll need to enable "use site-ip for PASV connections" or something similar in your FTP client. You'll want to avoid locally using PORT mode to take advantage of the new security features.

nxTools (site script) and ioNinja (zipscript - look under new scripts section) can both be found on the forum here. That's the popular combo these days.
Yil is offline   Reply With Quote
Old 06-15-2010, 12:04 PM   #6
BoNeZz
Member
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 39
Default

Quote:
Originally Posted by Yil View Post
If you installed v7.5.x version and didn't disable auto cert generation it will now automatically create your SSL certificate right after startup and load it when it's ready. Therefore "site makecert" isn't really necessary unless you later change the HOST= or specify a certificate name to use and need to generate it.

"Transfer not work" isn't specific. The most common issue is specifying HOST=external-ip and you connect via a local non-routable IP like 192.168.x.x and you use PASV mode and your router doesn't forward the external-ip. First double check that you are actually forwarding the passive port range in your router (5421-5450 by default I think, along with the command port default of 5420 or whatever you changed it to). If that is set then you'll need to enable "use site-ip for PASV connections" or something similar in your FTP client. You'll want to avoid locally using PORT mode to take advantage of the new security features.

nxTools (site script) and ioNinja (zipscript - look under new scripts section) can both be found on the forum here. That's the popular combo these days.
i installed ioftpd 7.5.7, but what version about nxtools i must installed on 7.5.7? can you write me post links of this or these versions?

i downloaded nxtools-tempfix-2008-09-29.rar but this .rar not contain all files of this script and is impossible to install, so i think that i need download another .rar and replace old files with nxtools-tempfix-2008-09-29.rar.

i hope can you help me.

thanks in advance
BoNeZz is offline   Reply With Quote
Old 06-15-2010, 02:14 PM   #7
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Try neoxed's scripts at: http://code.google.com/p/nxscripts/downloads/list

You can grab the 1.2.1 release of nxtools from there. You probably don't need to install the tempfix you downloaded before since I think that only checks free space during PRE events and you won't have them.

ioNinja can be gotten from: http://odog.tx-shells.net/
Yil is offline   Reply With Quote
Reply

Tags
ioftpd, site, win7, works, [1]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:09 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)