Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 3.00 average. Display Modes
Old 05-20-2010, 11:20 PM   #16
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

I successfully transferred 5K files totaling roughly 250GB using 10 FXP sessions back to itself without problems using SSL. I then did it again. I saw 1 interesting event but it had no side effects that I'm aware of and I changed the code to handle that case better now.

Everyone should upgrade to fix the bugs, and I removed the extra debug junk except for the new "rare" cases that I'm interested in.
Yil is offline   Reply With Quote
Old 05-21-2010, 02:39 AM   #17
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

Uploading: While crashed, and issuing PORT command, nothing is happening in logs. By enabling reverse transfer and send PASV, I see the following in log:

05-21-2010 09:36:36 WSAAsyncSelectWithTimeout socket re-use: 4472 - Flags: 0

Single line, but multiple failed transfers.
pion is offline   Reply With Quote
Old 05-21-2010, 12:04 PM   #18
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default FXP failed :o

Login on local server with SSL (TLS) enabled. DIRs list fine, smooth. Login to another site trying grabing a file for FXP test, then i get this;

[1] RETR pzs-ng_v1.0.X_r2563.tgz
[1] 425 Can't open data connection.
[2] ABOR
[2] 426 Connection closed: Your user class requires you to use secure connections.
[2] 226 ABOR command successful.
[2] DELE pzs-ng_v1.0.X_r2563.tgz
[2] 550 pzs-ng_v1.0.X_r2563.tgz: No such file or directory.

What'v missed?
Flow is offline   Reply With Quote
Old 05-21-2010, 12:23 PM   #19
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Flow: You enable the FXP SSL checkbox in your client for both sites? The "426 Connection closed: Your user class requires you to use secure connections." message indicates you were trying to upload/download a file without encryption turned on so it denied you.

That restriction is controlled by the 'Require_Encrypted_Data' under [FTP_Service].

Your client probably has 3 SSL settings btw... Login, Listings, and FXP...
Yil is offline   Reply With Quote
Old 05-21-2010, 12:36 PM   #20
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

pion: That's the interesting case I saw as well. It's a known possible race condition and it is handled correctly now. It also shouldn't affect anything as the 20 second connection timer (or the idle_timeout) will close the listening/connecting socket and everything should continue normally. Still, when did that appear? It sounds like just after things went bad which sorta makes sense...

It's looking like winsock stops delivering these async socket events notifications completely... I'll have to explore this some more... perhaps a build for you with extra debugging around this since you can obviously reproduce the issue.

I can also look into using the data connection async notification method to build another feature into the deadlock detector so it can catch that as well for you.... Or perhaps change the way this is done entirely.
Yil is offline   Reply With Quote
Old 05-22-2010, 04:33 AM   #21
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

I sent PORT command to io for hours in crashed state. The second I switched to reverse transfer and issued PASV, that line appeared

Last edited by pion; 05-22-2010 at 04:57 AM.
pion is offline   Reply With Quote
Old 05-23-2010, 01:57 PM   #22
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Hi Yil, uploaded 3 greek-to-me file for you. Hope it point out something for development.
Flow is offline   Reply With Quote
Old 05-24-2010, 09:59 AM   #23
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

(16:57:56) [io745] PWD
(16:57:56) [io745] 257 "/" is current directory.
(16:57:56) [io745] STAT -l
(16:58:09) [io745] List Complete: 504 bytes in 12,34 seconds (0,04KB/s)

This is with preload disabled.

The dir doesn't have a single 'actual' dirs, they're all just mountpoints from the vfs, which are emtpy dirs like FTP-ROOT-DIR and the like.

This slow dirlisting happends every time, for every dir.

Preloading enabled, with delay=true:

05-24-2010 17:27:37 PRELOAD: "begin" "..\etc\default.vfs"
05-24-2010 17:28:50 PRELOAD: "points=55" "..\etc\default.vfs"
05-24-2010 17:53:29 PRELOAD: "count=9383" "..\etc\default.vfs"
05-24-2010 17:54:17 SSL: "Found certificate" "name=abcd" "Service=FTP_Service" "(Certificate_name)"


Then when (finally) logging in:

(17:54:47) [io745] STAT -l
(17:58:07) [io745] Timeout, Connection closed


Please put some more sane timeouts on dirlisting stuff!

Last edited by pion; 05-24-2010 at 11:49 AM.
pion is offline   Reply With Quote
Old 05-24-2010, 11:45 AM   #24
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

it seems ntfs junctions is broken i last rel, dunno how long it's been that way but it can't handle ntfs junctions on network shares. No matter how you set it up it tries to manipulate the links in some way ending up with some crappy files instead of links. They show up as 0byte link files for some reason, my guess is that the manipulation you added thinks they're regular windows links.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 05-24-2010, 12:52 PM   #25
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

o_dog: Hmm. What 'NTFS_Reparse_Method' option are you using? If you switch to IGNORE that should be the old behavior and everything would work like it did pre v7. SHARE/SYMLINK are very different and I process the re-parse points internally to figure out the target dir, etc. It's possible I missed something simple when dealing with network shares, so I'll test that and get back to you. Try the IGNORE option though and see if that offers a temp fix.

pion: My hands are pretty much tied. It's the client (not the server) that times out the directory listings and there isn't really much that I can do about that. The simplest option includes sending some sort of bogus / generic data to keep the client happy but what that should be I'm not really sure... A later release with that saved-cache feature I thought about seems like the best option but that doesn't solve your short term problem... Of course speeding up cache processing in general wouldn't hurt either...
Yil is offline   Reply With Quote
Old 05-24-2010, 01:14 PM   #26
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

as i said it doesn't matter what option you use, when using symlink they show up as symlinks and point nowhere, if you use the other two they show up as 0byte files. Ignore doesn't seem to ignore it
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 05-24-2010, 01:19 PM   #27
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

Preloading taking 15 (!!) minutes is what I'm referring to
pion is offline   Reply With Quote
Old 05-24-2010, 01:50 PM   #28
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

Downloading io 7.5.2 zip file, running the ioftpd-start.exe out of the box fails:

Win7: (ioftpd.exe starts)
ioGui2
Component 'MSCOMCTL.OCX' or one of its dependencies not correctly registered: a file is missing or invalid

I might add that iogui is unable to connect to io on the first run also.
Maybe an idea to have ioGui start proper out of the box?

Last edited by pion; 05-24-2010 at 03:31 PM.
pion is offline   Reply With Quote
Old 05-24-2010, 04:24 PM   #29
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Hi Yil, the CRASH, MINIDUMP and TINYDUMP are generated when manually stopping the ioFTPD service in the contorlpanel. Just noticed that.
Flow is offline   Reply With Quote
Old 05-25-2010, 12:50 AM   #30
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

To run ioGUI on vista/win7 you need to register the .ocx files.

Open up a command prompt using the "Run as administrator" option as you'll need admin rights.

cd c:\ioftpd\ioGUI
regsvr32 MSCOMCTL.OCX
regsvr32 MSWINSCK.OCX

Then try to start the GUI again. If that doesn't work you might need to copy the .ocx files to c:\windows\system32, cd to that dir, and try to register them there...

It's been a while since I've had to do it, but I think that's right.

ioGUI only tries to connect once. It's kinda stupid that way. I didn't write it, but it's better than nothing for some things. I added a delay feature to ioFTPD-start if you pass it a number it will wait that many seconds before spawning the GUI in the hopes the server has started by that point. ioGUI is based on the original .NET release way back when and won't work with newer compilers so it's kind of a tricky build which is why nobody has bothered to modify it and we are still using the old version.
Yil is offline   Reply With Quote
Reply

Tags
command, fixed, link, openssl, server

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:44 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)