Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-11-2007, 06:15 AM   #1
The_All_Seeing_ioFTPD
Junior Member
 
Join Date: Aug 2007
Posts: 3
Default login problem/possible password/host error

08-11-2007 02:19:55 Host '*@mydns.net' did not match any of user 'ioFTPD' allowed hosts.

i get this on the master acct i switched info for in the etc/hosts and ioftpd.ini files

4:07:12 AM wSock_Connect()
4:07:13 AM 220 FTP Server ready.
4:07:13 AM > USER ioFTPD
4:07:13 AM 331 Password required for ioFTPD.
4:07:13 AM > PASS *****
4:07:13 AM 530 Login failed: Invalid password.

i switched the 127.0.0.1 in ioftpd.ini to:

[Any]
Host = mydns.net
Bind = mydns.net
# Limit port range for PASV connections. If you are behind a router you
# MUST forward/allow these ports for passive file transfers to work...
Ports = 60666
Random = False

im not on a router btw
also switched this..

name = ioFTPD
host = mydns.net <- what i switched in sites.ini
port = 60666
user = ioFTPD
pass = ive tried ioFTPD and other made up pw's nothing matters here either!
ident =
connectonstartup = 0
usesslproxy = 0

my hosts file
### This is the Hosts.Rules file for ioFTPD. It is used to control which
### ip addresses and hostnames have access to the server.
###
### This file is read from top to bottom, with the last matching rule
### being the one that applies to the connection. This means that more
### general rules will tend to be at the top of the file, with more
### specific rules matching later (lower).
###

## policy
##
## format:
## POLICY ACCEPT CONNECTIONS_PER_IP
## POLICY DENY
##
## The connections_per_ip argument here appears to only be necessary when
## the server is setup to allow anonymous users or you have multiple users
## sharing accounts. This is because you would normally limit a specific
## user to just 1 or 2 simultaneous connections in the individual user's
## account settings. However when you wish to do something like support
## 10 anon users but you don't want any one person hogging all of slots
## you can use connections_per_ip to prevent this.
##
## By default, we accept all incomming connections.
##
POLICY ACCEPT 4


## classes
##
## format:
## CLASS CLASS_NAME TOTAL_CONNECTIONS_PER_CLASS
##
## -1 for TOTAL_CONNECTIONS_PER_CLASS means unlimited.
##
##
CLASS USERS 25
CLASS ADMIN -1


## rules
##
## rules determine which ip addresses can connect to your server.
##
## rules can be specified by ip address ('I') or hostname ('H').
## both the ip address and hostname can be partial addresses, for
## instance the class C block of '192.168.1.' or any '.com' address.
##
## format:
## ACCEPT I|H IP|HOSTNAME CLASS_NAME CONNECTIONS_PER_IP
## DENY I|H IP|HOSTNAME LOG_STRING
##
ACCEPT | 127.0.0.1 ADMIN -1
ACCEPT I mydns.net ADMIN -1
ACCEPT I 192.168. ADMIN -1


reviewing all this,and tryin everything i could and reading the forums im at a loss what im doing wrong to get that error can someone enlighten me please to the solution,ive been on this for hours!
The_All_Seeing_ioFTPD is offline   Reply With Quote
Old 08-11-2007, 10:07 AM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

The ioFTPD master account can only login from 127.0.0.1 unless you change that. Assuming you ARE local and trying to talk to the server on the same machine one of two things are happening:

1) You are accessing it via mydns.net (assuming you shortened it to eliminate your actual hostname) and this resolved to your external IP. In this case you will connect but because you're not using 127.0.0.1 you WILL get the error you are seeing. For local connections use the 127 addr, and for remote add the mydns name to the ioFTPD account.

2) You edited the MS windows hosts file incorrectly. You can see all sorts of weird things if you goof this file up.
Yil is offline   Reply With Quote
Old 08-11-2007, 02:38 PM   #3
The_All_Seeing_ioFTPD
Junior Member
 
Join Date: Aug 2007
Posts: 3
Default

thanks Yil! I understand what you were saying,my second question then to fix things is i want to run my ftpd so others can login to it and i want to use a dns from a site like no-ip.com thats my external ip (not localhost) and actually have that setup as my main site/server,can i do that through just using the main ioFTPD default site setup or would i have to make another site on the left site were the pc icon with the x under it is and somehow add that to the hosts file and ioftpd.ini file? Im still a lil lost on that but i did follow what you were saying and just added *@mydns.net in the ip box and added it to hosts file and ioftpd.ini and that let me login so many thanks to that!! Just need this answer so i know how to config my server so i can run it off my local machine to let others login and use it like "real ftpd servers" are. Thanks again..

EDITk tried it with a friends after i setup his ip by im and he was able to login,coolness. But im still confused but ill just go with what i got for the min,my immediate problem was solved thanks again!

The All Seeing Eye

Last edited by The_All_Seeing_ioFTPD; 08-11-2007 at 05:06 PM.
The_All_Seeing_ioFTPD is offline   Reply With Quote
Old 08-12-2007, 12:35 PM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

You only need 1 server and 1 entry in ioGUI. If you have a properly setup server behind a NAT router/firewall the PASV command will report your external IP. This is fine for everybody but yourself. The easiest way to fix this is to enable the "use site IP for pasv" option in flashfxp,etc for your site. Now you and everyone else will be happy.
Yil is offline   Reply With Quote
Old 09-06-2007, 04:04 PM   #5
Pretone
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Aug 2004
Posts: 109
Default

controll the .vfs ...
Pretone is offline   Reply With Quote
Reply

Tags
40713, ftp, ioftpd, mydns.net, switched

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:07 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)