Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-28-2007, 01:47 PM   #1
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default Weird connection prob with new router

Hi there, i have changed my router to linksys WRT54G when i try to connect to my ftp from inside my router i get this in my error log - 07-28-2007 19:40:45 Rejected unmatched client 192.168.1.1 (). i have forwarded the correct ports and disabled Block Anonymous Internet Requests but i just cant login, it was fine with my old netgear router

thanks in advance guys
en3rmax is offline   Reply With Quote
Old 07-28-2007, 05:47 PM   #2
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default

just managed to connect from outside my router but it seems to not connect when i'm behind the router
en3rmax is offline   Reply With Quote
Old 07-28-2007, 06:18 PM   #3
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default

when i'm behind the router i can ping the servers dns

5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.0/1.4/3.3 ms
en3rmax is offline   Reply With Quote
Old 07-29-2007, 12:44 AM   #4
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Couple of things. The loopback address for connections on the same machine is 127.0.0.1 and it's important that you use that address for the initial login to ioFTPD because that's the only address that can connect. This should work, so check that ioGUI runs.

192.168.1.1 is usually the linksys router. I don't think I've ever seen connections coming from the router itself though. The linksys is a NAT firewall and it assigns internal IP addresses on demand and are usually 192.168.1.100+. If you are forwarding ports so people can talk to your FTP you've probably manually assigned an IP address to your machine. Double check it isn't 192.168.1.1

Depending on the model you can sorta talk to yourself using your external IP address since it will just forward the packet back to you, but mine drops packets left and right and results in corrupted files transfered this way all the time. When talking between machines internal to my router I use the local 192.168.1.* IP address (well, I add the host to the local hostfile and use the name) I assigned and check the option for the site in flash,etc to use the IP address of the site instead of the IP address of the PASV reply. This is important since a properly configured ioFTPD behind a NAT firewall should be reporting your EXTERNAL IP...

Here's two tidbits...
1) Use "ipconfig /all" to see information on configured network interfaces and find out what internal IP address you're using.

2) Use "tracert host/ip" to see the path to another computer. On a local network it should just go straight there as the router will play the role of a switch. If the packet actually goes to the router via 192.168.1.1 something isn't right. Double check that you have subnet masks (i.e. 255.255.255.0) and identical leading IP address (192.168.1.*).
Yil is offline   Reply With Quote
Old 07-29-2007, 04:36 AM   #5
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default

Thanks for the info Yil ur a star mate, i used the loopback ip that iogui uses and it connects fine :-)
en3rmax is offline   Reply With Quote
Reply

Tags
anonymous, block, disabled, ftp, router

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:34 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)