Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-27-2007, 11:02 AM   #1
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default Server starts, but cant login.

Im an old ioFTPD user since the days we had to pay for it (no problems with that though ) but i ditched it long time ago because of the lack of development. To be honest i´d given up all hope about ioFTPD. Therefore i was very pleased to see that Yil picked it up and obviously created a new and more functional version with for example the addition of working SSL FXP. Very nice, Yil, you owns!

So now i´ve picked up ioFTPD again and starts from the beginning. To my embarrasment i´ve forgotten all about setting it up and properly configure it, but the instructions are pretty well outlined and i thought i could make it running in a couple of hours. Sorry to say, that was not what happened.

I´m on a Vista Business installation and when starting the server after taking care of the initial configuration like fixing the .vfs and some entries in ioftpd.ini, the server starts just fine but im not able to login. Using FlashFXP the error message is simply: "Connection failed (Connection refused). I´m using the ioFTPD account initially and the login attempt is done locally from 192.168.1.xxx or 127.0.0.1 (tried them both). I´ve changed the default port 5420 to something else, the PASV ports also changed, default.vfs changed to reflect the physical root dir, cert file made, also added a new entry in Hosts.rules to try login from the Internet but no show. The server is actually running as i can see from the Task manager but when doing a netstat -ano from command line the PID (as reported in ioFTPD.log) is not there!!?? No error log whatsoever created, i just cant login.....also ioGUI2 throws error message "Component mswinsck.ocx or one of its dependencies not correctly registerad: a file is missing or invalid" if trying to start the server from the .lnk file provided in the package. The server itself starts just fine though. Feels like im kinda stumped atm, i must have missed something but i cant figure out what...
IggyPop is offline   Reply With Quote
Old 04-29-2007, 04:36 AM   #2
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Sorry for being so persistent, but does anybody have some ideas what i should do to fix the above problem? I am really eager to pick up ioFTPD again after the nice work done by Yil.
IggyPop is offline   Reply With Quote
Old 04-29-2007, 06:02 AM   #3
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

so just to be sure i understand you - you have removed the deny entries in the hosts file for 127.x and 192.x ?
ArtX is offline   Reply With Quote
Old 04-29-2007, 06:06 AM   #4
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Quote:
Originally Posted by Carpo View Post
so just to be sure i understand you - you have removed the deny entries in the hosts file for 127.x and 192.x ?
Hi carpo, thanks for answering. Yes, as far as i can see i have it all set up to work for localhost and the 192.168. range of internal IP.

Looks like this:

POLICY ACCEPT 2

ACCEPT I 127.0.0. ADMIN -1
ACCEPT I 192.168. ADMIN -1
IggyPop is offline   Reply With Quote
Old 04-29-2007, 11:53 AM   #5
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

###
### This is the Hosts.Rules file for ioFTPD. It is used to control which
### ip addresses and hostnames have access to the server.
###
### This file is read from top to bottom, with the last matching rule
### being the one that applies to the connection. This means that more
### general rules will tend to be at the top of the file, with more
### specific rules matching later (lower).
###

## policy
##
## format:
## POLICY ACCEPT CONNECTIONS_PER_IP
## POLICY DENY
##
## The connections_per_ip argument here appears to only be necessary when
## the server is setup to allow anonymous users or you have multiple users
## sharing accounts. This is because you would normally limit a specific
## user to just 1 or 2 simultaneous connections in the individual user's
## account settings. However when you wish to do something like support
## 10 anon users but you don't want any one person hogging all of slots
## you can use connections_per_ip to prevent this.
##
## By default, we accept all incomming connections.
##
POLICY ACCEPT 4


## classes
##
## format:
## CLASS CLASS_NAME TOTAL_CONNECTIONS_PER_CLASS
##
## -1 for TOTAL_CONNECTIONS_PER_CLASS means unlimited.
##
##
CLASS USERS 25
CLASS ADMIN -1


## rules
##
## rules determine which ip addresses can connect to your server.
##
## rules can be specified by ip address ('I') or hostname ('H').
## both the ip address and hostname can be partial addresses, for
## instance the class C block of '192.168.1.' or any '.com' address.
##
## format:
## ACCEPT I|H IP|HOSTNAME CLASS_NAME CONNECTIONS_PER_IP
## DENY I|H IP|HOSTNAME LOG_STRING
##
ACCEPT I 127.0.0. ADMIN -1
ACCEPT I 192.168. ADMIN -1

so yours is looking like that above yes?

if so check the firewall on xp/vista as this is anotther common thing that is over looked (even if you are using lan)
ArtX is offline   Reply With Quote
Old 05-03-2007, 01:20 PM   #6
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Thanks again Carpo, sorry for delayed answer, been on a short trip. Yes, this is the way the file looks like. I´ve also been checking the firewall, not using Vistas built-in, instead PC Tools Firewall Plus, and both disabled it and completely turned it off, but no show. This problem starts to look very strange imho
IggyPop is offline   Reply With Quote
Old 05-03-2007, 01:56 PM   #7
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Heya Iggy: I'm 80% sure your problem is a bad ioFTPD.ini file. The fact you can't see the port in a listen state via netstat is the key - that's a config file issue. As a proof of concept revert to the original ioFTPD.ini in the zip file and start the server and it should work fine...

Having proved it isn't firewalls/Vista/etc go back and re-apply the settings to the ioFTPD.ini by hand. Don't cut and paste. I've had invalid characters, wierd line endings, etc on occasion cause problems. Heck, some lines can't contain comments on the same line as the option so if you added any that might be the problem right there...
Yil is offline   Reply With Quote
Old 05-04-2007, 05:47 AM   #8
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Quote:
Originally Posted by Yil View Post
Heya Iggy: I'm 80% sure your problem is a bad ioFTPD.ini file. The fact you can't see the port in a listen state via netstat is the key - that's a config file issue. As a proof of concept revert to the original ioFTPD.ini in the zip file and start the server and it should work fine...

Having proved it isn't firewalls/Vista/etc go back and re-apply the settings to the ioFTPD.ini by hand. Don't cut and paste. I've had invalid characters, wierd line endings, etc on occasion cause problems. Heck, some lines can't contain comments on the same line as the option so if you added any that might be the problem right there...
Hi Yil. Let me first of all express my tremendous admiration for all the work you have put down on this, i silently bow my head.

I´ll follow your advices and check, be back later....
IggyPop is offline   Reply With Quote
Old 05-04-2007, 12:05 PM   #9
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

OK, smoking fresh info. New ioFTPD 6.1.2, extracted as per default settings to C:\, no changes made to any file at all, firewall shut down, lo and behold, it starts fine, it shows up in netstat -ano and i am able to login with default account. All well. Discard what i said earlier, it seems the firewall is the culprit somehow, turning it on gives some undesired effects so i think i have to start with tweaking that one before "production state" is achieved. Thanks a bunch Carpo and Yil, for your patience and help.
IggyPop is offline   Reply With Quote
Old 05-14-2007, 10:28 AM   #10
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Hi, its me again

Just a quick question, what is the correct syntax (in Hosts.rules) for allowing any IP address to connect to server?

Is ACCEPT I *.* ADMIN -1 correct, for instance?
And ACCEPT I *.* USERS 10 for users?
IggyPop is offline   Reply With Quote
Old 05-14-2007, 10:37 AM   #11
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

I just use POLICY ACCEPT -1

This basiclly allows unlimited amount of connections for any range of ip adresses.
hukker is offline   Reply With Quote
Old 05-14-2007, 01:52 PM   #12
IggyPop
Junior Member
 
Join Date: Apr 2007
Posts: 11
Default

Quote:
Originally Posted by hukker View Post
I just use POLICY ACCEPT -1

This basiclly allows unlimited amount of connections for any range of ip adresses.
Hmm, pretty neat solution, no added rule for IP access, right?
IggyPop is offline   Reply With Quote
Old 05-16-2007, 09:58 AM   #13
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

nope, my file only contains that one line, If I wanted to ban an ip or a range of ips or limit a range of IPs to a certain amount of connections I would add more rules to the host.rules file.

At the moment I just make sure my users have 3 logins max, and that I add there ips while adding the users, site change user logins 3 and site addip user *.*.*.*
hukker is offline   Reply With Quote
Old 05-16-2007, 10:45 AM   #14
e-buzzen
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 6
Default

Quote:
Originally Posted by hukker View Post
nope, my file only contains that one line, If I wanted to ban an ip or a range of ips or limit a range of IPs to a certain amount of connections I would add more rules to the host.rules file.

At the moment I just make sure my users have 3 logins max, and that I add there ips while adding the users, site change user logins 3 and site addip user *.*.*.*
Yes, got it, doing exactly the same here now, works like a charm

EDIT: It´s me, IggyPop, using my old original account that i just found the login information for ....been looking for it a loooooooooong time now....
e-buzzen is offline   Reply With Quote
Reply

Tags
flashfxp, fxp, login, server, starts

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:02 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)