Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-22-2006, 04:13 PM   #1
Ludicrous
Junior Member
ioFTPD Foundation User
 
Join Date: Aug 2006
Posts: 6
Unhappy ioftpd won't start...

ok, this is my first go at ioftpd. I downloaded the latest beta release (ioFTPD-beta5-8-4u)
I am using windows xp sp2.

i was fallowing the documentation, provided here: http://www.inicom.net/pages/en.ioftp...tation.php?s=2

i did everything it said to due, yet when i run the ioftpd.exe nothing happens. I don't see it in the running processes in taskmanager. it doesn't appear to be listenening when i due a netstat -a. No log files int the logs dir, and i can't connect via ftp to 127.0.0.1:9999. I figure i must be missing something but im not to sure what it is atm. any suggestions would be greatly appreciated.

here is my default.vfs

Code:
"C:\ftp\IOFTPD" /

here is my ioftpd.ini

Code:
##################### DEVICES ########################
##
#
# [Device Name]
# Host   = <Host/IP>         # External host. Address shown to clients. (0.0.0.0 = any local ip)
# Ports  = <Begin-End>       # Ports to use for data transfers. May contain comma seperated list of port ranges.
# Random = <True/False>      # Use ports in random order
# Bind   = <Host/IP>         # Internal host. If specified, connections are bound to this address instead of HOST.
#
# Global_Inbound_Bandwidth  = <kB/s>  # Limit overall inbound speeds
# Global_Outbound_Bandwidth = <kB/s>  # Limit overall outbound speeds
# Client_Inbound_Bandwidth  = <kB/s>  # Limit client inbound speeds
# Client_Outbound_Bandwidth = <kB/s>  # Limit client outbound speeds



[Any]
Host				= 0.0.0.0
Ports				= 1024-2048
Random				= True

################## END OF DEVICES ####################



##################### SERVICES #######################

[FTP_Service]
Type                    = FTP
Device_Name             = Any
Port                    = 9999
Description             = My FTP Service
User_Limit              = 10
Allowed_Users           = *
Messages                = C:\Documents and Settings\Administrator\Desktop\ioFTPD-beta5-8-4u\ioftpd\text\ftp

### Encryption ###
#
Require_Encrypted_Auth  = !*
Require_Encrypted_Data  = !*
#Certificate_Name        = 192.168.1.10
Explicit_Encryption     = True
Encryption_Protocol     = SSL3
Min_Cipher_Strength     = 128
Max_Cipher_Strength	= 256

################## END OF SERVICES ###################

greetz

Last edited by Ludicrous; 08-22-2006 at 04:34 PM.
Ludicrous is offline   Reply With Quote
Old 08-23-2006, 06:08 AM   #2
lek666
Junior Member
 
Join Date: Aug 2006
Posts: 1
Arrow

I had this problem...drove me mad!!!

then I found something in the KB that says the exe is case sensitive..so make sure it's ioFTPD.exe (not all upper or lower case)

worked for me

lek
lek666 is offline   Reply With Quote
Old 08-23-2006, 03:53 PM   #3
Ludicrous
Junior Member
ioFTPD Foundation User
 
Join Date: Aug 2006
Posts: 6
Default

i assume you are talking about the one in.

...\ioFTPD-beta5-8-4u\ioftpd\system\

and i renamed that like you said, and no go. anyother ideas?
Ludicrous is offline   Reply With Quote
Old 08-31-2006, 01:29 AM   #4
Ludicrous
Junior Member
ioFTPD Foundation User
 
Join Date: Aug 2006
Posts: 6
Default

you can close this i fixed it myself, <sarcasm> thank god for the support here and irc.
Ludicrous is offline   Reply With Quote
Old 01-10-2007, 01:09 PM   #5
NEO_S2
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2007
Posts: 3
Default

Oh man... Why didn't you write the solution here. You know, other people might get the same problem. Like me now.


Quote:
Originally Posted by Ludicrous
you can close this i fixed it myself, <sarcasm> thank god for the support here and irc.
NEO_S2 is offline   Reply With Quote
Old 01-10-2007, 01:24 PM   #6
NEO_S2
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2007
Posts: 3
Smile

The guys at #ioftpd helped med out, thanks again.

and the problem was that I have missed the Host.Rules editing entry in the docs. So after editing /etc/Hosts.Rules it works.

Quote:
Originally Posted by NEO_S2
Oh man... Why didn't you write the solution here. You know, other people might get the same problem. Like me now.
NEO_S2 is offline   Reply With Quote
Reply

Tags
ftp, host, limit, ports, speeds

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:21 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)