Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-08-2006, 10:15 PM   #1
deco
Junior Member
 
Join Date: May 2005
Posts: 7
Default Subdirs Permissions

Hi m8´s !

I have a problem that I cant fix for now ...
The problem is to upload files to a dir or make new folders. I have in root dir sections like /folder1, /folder2, etc.,
Comon user can make dirs and up files inside your own folder( /folder1/myFolder/...) , but this user cannot make dirs or up files in other own´s folder ( /folder1/otherOwnFolder/CD1). This way this user cannot race another user making CD2 or just upping files to CD1.. the message is "permission denied".
What´s wrong ?
deco is offline   Reply With Quote
Old 01-08-2006, 11:27 PM   #2
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

[VFS]
###
# Default attributes for files & directories
#
# Required Parameters: <filemode> <owner uid>:<owner gid>
#

Default_Directory_Attributes = 777 0:0
Default_File_Attributes = 777 0:0
Old_Directory = 777 0:0
Old_File = 777 0:0
New_Directory = 777 0:0
New_File = 777 0:0
EwarWoo is offline   Reply With Quote
Old 01-09-2006, 07:25 AM   #3
deco
Junior Member
 
Join Date: May 2005
Posts: 7
Default

Not work m8 ...

I found error, but I dont know how to fix it ..

The problem is with CHMOD 777 permissions. I set this permission on /folder1 , but this permission dont apply to subdirectories... like /folder/CD1. if I set permissions CHMOD on /folder1/CD1 it works ... Others user with normal flag can up for it ..

The questions is: How can I set this to subfolders automatically ?
deco is offline   Reply With Quote
Old 01-09-2006, 02:57 PM   #4
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

The above lines dont solve your current problem they just stop it recurring.
Meanwhile you're gunna have to just chmod, or delete the .ioftpd files.
EwarWoo is offline   Reply With Quote
Old 01-09-2006, 07:58 PM   #5
deco
Junior Member
 
Join Date: May 2005
Posts: 7
Default

yeah, deleting .ioftpd files solve this problem. I think this error occured because in my ioFTPD.ini was set as follow:
[VFS]
###
# Default attributes for files & directories
#
# Required Parameters: <filemode> <owner uid>:<owner gid>
#

Default_Directory_Attributes = 755 0:0
Default_File_Attributes = 644 0:0

and now I set with this:

Default_Directory_Attributes = 777 0:0
Default_File_Attributes = 666 0:0

This way new dirs work !

Tks for support EwarWoo !
deco is offline   Reply With Quote
Reply

Tags
files, folder, make, upload, user

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:16 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)