Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-26-2005, 01:14 PM   #1
Diveflo
Junior Member
 
Join Date: Oct 2005
Posts: 6
Default SSL and ioFTPD

Hi,

i did these steps (like often posted in these board):

1.) Killed ioFTPD
2.) Created certificate with makecrt etc.
3.) Checked with certmgr that localhost is located in my certificates and trusted root certificates.
4.) Starting ioFTPD

It is NOT installed as a service. I tried it at different drives (c:\, d:\, g:\). Local it works without Problems .

Thanks 4 Help!
Sorry for my english...I'm from Germany, I tried it in the International Board but nobody posted a working solutiong.

dive
Diveflo is offline   Reply With Quote
Old 10-26-2005, 01:27 PM   #2
alturismo
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Nov 2001
Posts: 265
Default

do u have an regged version of ioFTPD ?

due SSL only works for regged versions ...

if so, may update your board profile

then may post the SSL part from your config here to check settings
alturismo is offline   Reply With Quote
Old 10-26-2005, 01:28 PM   #3
Diveflo
Junior Member
 
Join Date: Oct 2005
Posts: 6
Default

Yes i got registered Version. Local it works .

### Encryption ###
#
Require_Encrypted_Auth = !*
Require_Encrypted_Data = !*
Certificate_Name = localhost
Explicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 256

Thanks

/edit:

I tried other FTP Servers, they work with SSL on the Server.
Diveflo is offline   Reply With Quote
Old 11-02-2005, 07:27 PM   #4
Webkikr
Junior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 13
Default

Quote:
Originally Posted by Diveflo
Hi,

i did these steps (like often posted in these board):

1.) Killed ioFTPD
2.) Created certificate with makecrt etc.
3.) Checked with certmgr that localhost is located in my certificates and trusted root certificates.
4.) Starting ioFTPD

It is NOT installed as a service. I tried it at different drives (c:\, d:\, g:\). Local it works without Problems .

Thanks 4 Help!
Sorry for my english...I'm from Germany, I tried it in the International Board but nobody posted a working solutiong.

dive
Where did you get the makecert.exe from?

I am trying to find it to allow SSL connections to my server, and it is not on the downloads page.
Webkikr is offline   Reply With Quote
Old 11-02-2005, 10:18 PM   #5
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by Webkikr
Where did you get the makecert.exe from?

I am trying to find it to allow SSL connections to my server, and it is not on the downloads page.
makecert.exe is available on the interweb at large. try googling for it.
_panic_ is offline   Reply With Quote
Old 11-03-2005, 01:35 AM   #6
dink-puller
Member
ioFTPD Foundation User
 
dink-puller's Avatar
 
Join Date: Sep 2004
Posts: 58
Default

Quote:
Originally Posted by Diveflo
Hi,

i did these steps (like often posted in these board):

1.) Killed ioFTPD
2.) Created certificate with makecrt etc.
3.) Checked with certmgr that localhost is located in my certificates and trusted root certificates.
4.) Starting ioFTPD

It is NOT installed as a service. I tried it at different drives (c:\, d:\, g:\). Local it works without Problems .

Thanks 4 Help!
Sorry for my english...I'm from Germany, I tried it in the International Board but nobody posted a working solutiong.

dive
Just having been through the mill on this one myself, I can say you might have a problem with Step 3. First read the how-to in ioFTPD/Help/. Then make sure to add the -pe option to your makecert command line to make the certificate exportable. If you are successful in making and exporting it, makecert.exe will return "succeeded", and it will appear in the "personal" tab of your certificate store, not in "trusted root certificates", and "personal" is where ioFTPD looks for it. Also make sure that the same windows user that runs ioFTPD is the one making and exporting the certificate, otherwise, ioFTPD will look in the wrong user's certificate store. Full makecert commandline will be something like this:

makecert -r -pe -n "CN=yourserver.hostname.here" -b 01/01/2000 -e 01/01/2036 -eku 1.3.6.1.5.5.7.3.1 -ss my -sr CurrentUser -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 ioftpd.cer

Hope that helps. I had trouble finding enough documentation for this, but I finally worked it out using the kb and the how-to included with ioftpd. Of course it all went out the window when I installed io as a service, because surprise surprise, the certificates no longer work and you have to make them as explained in the kb. If you do that, don't bother using exec.bat, it didn't work for me, but putting EXEC C:\Windows\System32\CMD.EXE /c in the custom commands section did work.
dink-puller is offline   Reply With Quote
Old 11-03-2005, 02:31 AM   #7
Diveflo
Junior Member
 
Join Date: Oct 2005
Posts: 6
Default

I fixed the problem. You have to start ioFTPD with the same account that created the certificate. I started ioFTPD not with Remote Desktop...when I start it with RD it works fine .


Thanks!


divE
Diveflo is offline   Reply With Quote
Reply

Tags
board, certificates, ioftpd, problems, works

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:52 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)