Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-14-2005, 05:32 PM   #1
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default Entering Passive Mode (Wrong IP)

I have a problem with some ftp users that try to fxp.

Main problem is explained by this line in logs:

227 Entering Passive Mode (10,8,0,62,5,228)

Ftp client takes this IP to make transfer, but this is a VPN ip, not pc real IP.
I need to know if there is a way to force ftp client, whatever it is, to use the pc real ip, maybe with an advanced configuration.

If anyone is so kind to post such a solution in a clear way, I would be thankful.
oldhouse is offline   Reply With Quote
Old 10-14-2005, 07:41 PM   #2
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Edit your ioFTPD.ini, Host = 0.0.0.0 should be replaced by Host = your_external_ip
Mouton is offline   Reply With Quote
Old 10-15-2005, 02:46 AM   #3
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

I can't do that, cause external ip is different from real pc ip, since it's behind nat, and nat ip is not reachable from external addresses, and that's why i have to use a vpn.
Weird thing is that it happens only on some users.
oldhouse is offline   Reply With Quote
Old 10-15-2005, 03:49 AM   #4
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

Try:
Bind = real pc ip

Mainly used for when behind a router, but may make a diff.
EwarWoo is offline   Reply With Quote
Old 10-15-2005, 04:51 AM   #5
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

I tried that too, but then no one will be able to reach server
oldhouse is offline   Reply With Quote
Old 10-15-2005, 06:41 AM   #6
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Host is not used at all when connections are established.
ie Host = 0.0.0.0 or Host = real pc ip doesn't matter until the ftp client sends a PASV command.
Only Bind = xyz is used to determine on which IP it listens for connections. And Bind = 0.0.0.0 should be kept as it is. You only need to change Host = xxxx to what IP you want PASV to return.

This error stops some users because other users forced their FTP client to send the PASV command to the *other* ftp server they are fxping to. Thats means only the other server needs to support pasv, and not yours.
If some users are behind a gateway, they need to enable PASV to be able to download, which will cause this error for them too.
Mouton is offline   Reply With Quote
Old 10-17-2005, 05:00 PM   #7
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

Thx very much mouton.
It was my fault setting Host to the right ip, but leaving bind with ; in fron of it.
Now it works fine.
Thx again
oldhouse is offline   Reply With Quote
Reply

Tags
client, ftp, fxp, passive, real

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:57 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)