Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-16-2005, 04:01 PM   #1
Gallier
Junior Member
ioFTPD Foundation User
 
Join Date: Aug 2005
Posts: 2
Exclamation Problems with adding new users

Hi,

I have a big problem to add new user in my ioFTPF.
First I loggt in as root. (with Flaggs GM). -> working fine
The IO told me that it has added this new user "testuser" into my group "leecher" .

Quote:
SITE GADDUSER leecher testuser testen @0.0.0.0
200 GADDUSER Command successful.
SITE UINFO testuser
200-.--------------------------------[User Info]----------------------------------.
200-| |
200-| Login: testuser Group: leecher |
200-| Unfo : Vote ioFTPD for president Flags: 3 |
200-| |
200-| Credits: 0MB WkUp: 0KB |
200-| Ratio : 1:3 WkDn: 0KB |
200-| |
200-| Ip1. @0.0.0.0 Ip2. |
200-| Ip3. Ip4. |
200-| Ip5. Ip6. |
200-| Ip7. Ip8. |
200-| |
200-'-----------------------------------------------------------------------------'
200 UINFO Command successful.
When I try to connect with my new account IO tell me that the login is incorrect.
I used the PW witch I told IO 1 min. before ...

Quote:
Connecting to xxx.xxx.xxx.xxx
Connected to xxx.xxx.xxx.xxx Port xxxxx
220 FTP Server ready.
USER testuser
530 Login incorrect.
Connection failed
Delaying for 120 seconds before reconnect attempt #1
The error log tell me that the host is not allowed ...
I have changed the accepted hosts in my list to
ACCEPT I 0.0.0.0 NORDIC 1 <- maybe there ist the problem but I don't know how to fix this problem ...
My Policy is ACCEPT 2
What is the right rule to accept users from any location ?

PLEASE HELP
Gallier is offline   Reply With Quote
Old 08-17-2005, 12:06 AM   #2
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

There are several reasons why:

A) 0.0.0.0 is not a routable address. The client connecting will never have 0.0.0.0 as its address.
B) You did not specify an ident in the hostmask: <ident>@<hostname/IP>.

To allow the user to connect from any host, use *@*.
neoxed is offline   Reply With Quote
Old 04-03-2006, 09:42 AM   #3
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by neoxed
There are several reasons why:

A) 0.0.0.0 is not a routable address. The client connecting will never have 0.0.0.0 as its address.
B) You did not specify an ident in the hostmask: <ident>@<hostname/IP>.

To allow the user to connect from any host, use *@*.
Well same problem here.

I also added a test user and have same problem host used is *@*
Pass is correct checked it many times

:update:
Could it be my host.rules file is incorrect?
I think i miss a CLASS entry, atm i only see ADMIN in it.

Quote:
# Default policy
#
# POLICY ACCEPT CONNECTIONS_PER_IP
# POLICY DENY
#
POLICY ACCEPT 2
## PLEASE REMOVE LINE BELOW

# Classes
#
# CLASS CLASS_NAME TOTAL_CONNECTIONS_PER_CLASS
CLASS NORDIC 25
CLASS ADMIN -1

# Rules
#
# ACCEPT I|H IP|HOSTNAME CLASS_NAME CONNECTIONS_PER_IP
# DENY I|H IP|HOSTNAME LOG_STRING
#

ACCEPT I 192.168.1. ADMIN -1
ACCEPT I 127.0.0. ADMIN -1
whocarez2k5 is offline   Reply With Quote
Old 04-03-2006, 07:59 PM   #4
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Angry

No response?

I really need some help!!

I tryed almost every thing i can think of but it just won't work
It worked for a few settings after io crashed and started again.
But the second time i just didn't work any more.

I have io FTPD-5-8-7r setup as service, SSL enabled.
Installed some small extra stuff found on scripts section and that's it!

I removed the last 2 lines found in Host.rules file (thought that was the problem)

ACCEPT I 192.168.1. ADMIN -1
ACCEPT I 127.0.0. ADMIN -1

But still nothing!!!!!!!!!!!!!

wtf is that with this ioFTPD, why wouldn't it just listen to me and perform what i want?

:update:
atm only M users can logon and the rest not!
whocarez2k5 is offline   Reply With Quote
Old 04-03-2006, 10:56 PM   #5
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

Try disabling the scripts, crash on commands with the last 2 versions is a known issue:
http://www.inicom.net/forum/showthread.php?t=15862

Try doing a search next time mr angry smiley
EwarWoo is offline   Reply With Quote
Old 04-04-2006, 05:29 AM   #6
Lormen
Member
ioFTPD Foundation User
 
Join Date: Oct 2004
Posts: 34
Default

best way of doing this:
my host.rules just says:
POLICY ACCEPT 4

all this does is all any one ip to connect a maximum of 4 times, no other blocking

on gadduser:

site gadduser testuser iorules leecher *@*

so thats site gadduser <group> <user> <password> <ident@ip> (*@* is any ident and any ip (probably not a great idea))

once this is done try it, if that works u can add more deny's/allows to your hosts file.
Lormen is offline   Reply With Quote
Old 04-04-2006, 05:45 AM   #7
LordM
Senior Member
ioFTPD Foundation User
 
LordM's Avatar
 
Join Date: Jul 2005
Location: Germany
Posts: 138
Default

And don't forget to restart ioFTPD after changing something in Host.Rules. But, maybe it is a vfs problem. Did you check etc\default.vfs ?
__________________
I'm using:

ioFTPD 7.7.2
ioNiNJA BETA Stable v0.8.9.6
LordM is offline   Reply With Quote
Old 04-04-2006, 06:35 AM   #8
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Talking

Quote:
Originally Posted by EwarWoo
Try disabling the scripts, crash on commands with the last 2 versions is a known issue:
http://www.inicom.net/forum/showthread.php?t=15862

Try doing a search next time mr angry smiley
I did search, i know that there are some issues with latest 2 versions, but i'm not talking about site commands
I just added user and i was unable to connect with him.
Changed Host.Rules still didn't work.
Restarted io again , still nothing.
And sudenly i was beable to connect with new/test user, but io crashed first!
I didn't changed anything i just tryed to connect.

Ok perfect i thought
But 1 hour later, nothing and wath i did or changed nothing worked!
And yes i restarted and rehashed so many times i lost count!

Quote:
Originally Posted by Lormen
best way of doing this:
my host.rules just says:
POLICY ACCEPT 4

all this does is all any one ip to connect a maximum of 4 times, no other blocking

on gadduser:

site gadduser testuser iorules leecher *@*

so thats site gadduser <group> <user> <password> <ident@ip> (*@* is any ident and any ip (probably not a great idea))

once this is done try it, if that works u can add more deny's/allows to your hosts file.
Ok i hope i get it, POLICY ACCEPT 4 means any /ident/ip can connect 4 times.
So actualy there are nly 4 connections possible?
I thought that was a setting in ioftpd.ini?
Deny's and Accepts i was planning after everything is working stable

Quote:
Originally Posted by LordM
And don't forget to restart ioFTPD after changing something in Host.Rules. But, maybe it is a vfs problem. Did you check etc\default.vfs ?
Read up
My default and admin.vfs are all the same and contain only 1 line to root so can't be any problem

b.t.w: my version have made only 2 crashes 1, with logon with new user, dunno why he did it but it happend, and 1 time when i did nothing i think it was a system failure or something. BUT NEVER CRASHED ON A SITE CMD like explained in topic.
I must say i haven't many scripts running maybe that's the case why it crashes?

Ow for you EwarWoo some more happy smilies
whocarez2k5 is offline   Reply With Quote
Old 04-04-2006, 07:08 AM   #9
LordM
Senior Member
ioFTPD Foundation User
 
LordM's Avatar
 
Join Date: Jul 2005
Location: Germany
Posts: 138
Default

try downgrading to 5.8.5r
__________________
I'm using:

ioFTPD 7.7.2
ioNiNJA BETA Stable v0.8.9.6
LordM is offline   Reply With Quote
Old 04-05-2006, 04:53 AM   #10
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by LordM
try downgrading to 5.8.5r
Don't think that is need, i have no error's on any cmd atm.
The problem is more that i have to fine tune the settings i guess
whocarez2k5 is offline   Reply With Quote
Reply

Tags
200-|, ftp, leecher, testuser, user

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)