Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-26-2004, 05:07 PM   #1
maX1mus_2
Member
 
Join Date: May 2004
Posts: 43
Default SSL bug/problem "locked" dir

This is a "new" problem according to SSL
I´ve been using SSL without any problems until just recently.
It started with that i couldn´t access a dir (MP3)
Quote:
[L] 426 Connection closed: Ett internt fel har uppstått.
([L] 426 Connection closed: an internal error has occured.)

It took me some while to find out, this folder is accessable if i turn SSL off.
It´s very strange this problem, it started some days ago.
And when i moved the newest files in that dir to another location, i could access both dirs, with SSL on as long as the new files werent in the same folder.

very anoying problem indeed.
Anyone that can solve my problem would be highly apreciated.
Running with SSL off until further notice :/
maX1mus_2 is offline   Reply With Quote
Old 03-13-2005, 05:38 PM   #2
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default

I got this error when trying to download with SSL.
I also noticed that if I have lots of dirs mapped to one dir it looks empty when I use ssl. Without SSL it works fine.

I just baught ioftpd because I wanted SSL (and support the good work).
I hope the SSL thing will be fixed really soon.

/W
windrider is offline   Reply With Quote
Old 03-13-2005, 11:46 PM   #3
maX1mus_2
Member
 
Join Date: May 2004
Posts: 43
Default

Quote:
I got this error when trying to download with SSL.
In your SSL-Options when connecting to a site, UNcheck "secure filetransfers"
ioFTPD "only" supports Secure filelisting afaik.
Quote:
I also noticed that if I have lots of dirs mapped to one dir it looks empty when I use ssl. Without SSL it works fine.
This is exactly what my problem is too.
With errormesage as in my first post, very frustrating.
However you can use SSL but you will also have to remove "Secure filelisting" if you want to be able to see the dirs.
Is this a known bug/problem.. ??
maX1mus_2 is offline   Reply With Quote
Old 03-16-2005, 10:33 AM   #4
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

ioFTPD supports SSL data transfer, be it files listings or file transfers. I use it daily without problems.

You could try using STAT to list dirs.
Also try to delete .ioFTPD* files inside the dir that doesn't list with SSL.
Mouton is offline   Reply With Quote
Old 03-16-2005, 10:40 AM   #5
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default still problem while downloading

your solution might work for the file listing.
BUT file trans? upload works (atleast I tried site 2 site) but download dosn't work.

I use
Windows XP with SP2
NIS2005. Same problem with the firewall turned of.

/W
windrider is offline   Reply With Quote
Old 03-16-2005, 10:56 AM   #6
maX1mus_2
Member
 
Join Date: May 2004
Posts: 43
Default

windrider, have you tried what i told you?

Mouton, It works excellent here too, untill i get to many dirs or if it´s too many files, i dont know
I tried delete all .ioftpd no difference
Also before that i tried NeoXed´s great script that removes 4kb+ .ioftpd
i had a few but didnt help either.

I dont know how this works, but im suspecting that maby it cache the dir-listing, ?
And it gets too big or something.
Just a thought.

maX1mus_2 is offline   Reply With Quote
Old 03-16-2005, 12:02 PM   #7
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default

Max, yeah it works. But the whole point with SSL is to have the information encrypted isn't it? I don't want someone to be able to sniff what's going on.. not that it's secret, just that I am uncomftable with uncrypted traffic =)

but thanks for the solution Max!
Maybe dark1 can fix encrypted trafic as well? :-)

Cheers,
Windy
windrider is offline   Reply With Quote
Old 03-16-2005, 12:18 PM   #8
maX1mus_2
Member
 
Join Date: May 2004
Posts: 43
Default

Afaik ioFTPD today does not support SSL on transfers,
that is io > io
if the transfer is initiated by glFTPD i think it works.
I read somewhere ioFTPD will/might/hopefully supports it in next version.
maX1mus_2 is offline   Reply With Quote
Old 03-16-2005, 12:27 PM   #9
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

SSL transfers works: downloading, uploading, FXPing using SSL to or from anything but io.
SSL FXP from io to io indeed doesn't work as io can't initiate SSL connections.
And yes, next io version can FXP using SSL to another io.
Mouton is offline   Reply With Quote
Old 03-16-2005, 01:38 PM   #10
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default

io to io
does that also include io <-> client ?

as a register user, will I get notified by email about the new version?

Cheers,
Windy
windrider is offline   Reply With Quote
Old 03-16-2005, 02:28 PM   #11
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Quote:
Originally posted by windrider
io to io
does that also include io <-> client ?
No. io to client = downloads or uploads = works fine with SSL.

Quote:
Originally posted by windrider
as a register user, will I get notified by email about the new version?
Maybe. It was never done in the past, but since the next version has been in the works for quite a while, iniCom might decide it would be a good idea to email all users (who have a valid email address in their profile!)
Mouton is offline   Reply With Quote
Old 03-16-2005, 03:21 PM   #12
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default

Quote:
Originally posted by Mouton
[B]No. io to client = downloads or uploads = works fine with SSL.
Do you mean io to client works fine now?
That dosn't work for me. When I have SSL on "Secure File Transfars (upload and download)" with FlashFXP.

I get:

[L] Connected. Negotiating SSL session..
[L] 150 Opening BINARY mode data connection for blablafile.
[L] 426 Connection closed: Ett internt fel har uppstått.
[L] Transfer Failed!

(internal error has accured).
Without SSL on transfars it works.

/Windy
windrider is offline   Reply With Quote
Old 03-16-2005, 03:32 PM   #13
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Code:
[15:30:15] [L] TYPE I
[15:30:15] [L] 200 Type set to I.
[15:30:15] [L] PASV
[15:30:16] [L] 227 Entering Passive Mode (216,239,92,78,6,125)
[15:30:16] [L] Opening data connection IP: 216.239.92.78 PORT: 1661
[15:30:16] [L] RETR ntdetect.com
[15:30:16] [L] Connected. Negotiating SSL session..
[15:30:16] [L] 150 Opening BINARY mode data connection for ntdetect.com.
[15:30:17] [L] SSL negotiation successful...
[15:30:17] [L] SSL encrypted session using cipher RC4-MD5 (128 bits)
[15:30:19] [L] 226-test script
[15:30:19] [L] 226 Transfer complete.
FFXP settings: Auth SSL
Secure File Listing
Secure File Transfers (Upload/Download)

ioFTPD.ini settings:
Code:
[15:31:51] [L] 200-008: ### Encryption ###
[15:31:51] [L] 200-009: #
[15:31:51] [L] 200-010: Require_Encrypted_Auth  = !*
[15:31:51] [L] 200-011: Require_Encrypted_Data  = !*
[15:31:51] [L] 200-012: Certificate_Name        = Mouton-ioFTPD-sha1
[15:31:51] [L] 200-013: Explicit_Encryption     = True
[15:31:51] [L] 200-014: Encryption_Protocol     = SSL3
[15:31:51] [L] 200-015: Min_Cipher_Strength     = 128
[15:31:51] [L] 200-016: Max_Cipher_Strength     = 168
Mouton is offline   Reply With Quote
Old 03-20-2005, 12:54 PM   #14
windrider
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 6
Default

it works now,
when I lowered the encryption to 168 and changed from SSL to SSL3.

Thx
W
windrider is offline   Reply With Quote
Old 04-22-2005, 05:45 AM   #15
PNC
Junior Member
 
PNC's Avatar
 
Join Date: Nov 2004
Posts: 14
Default

Hi I have to same problem here...
I had used the same settings as mounton, but non or secure users can connect on the server.

So, I removed the " !" before the "*" at the "Require_Encrypted_Auth " line and at the "Require_Encrypted_Data . Now can only secure users connect on the server.. So this problem is solved. But the other problem that I have is when a user try upload a file , the directory (which has been uploaded) stays empty.Even so say on flash fxp or ftprush, that file or data has been transfer and completed. And that using SSL or TLS. Without the SSL or TLS connection it works fine without anyproblem.
Till now I have no scripts or third part installed or config on the server, due I want the SSL connection to work fine.I want a secure connection , a secure file listing and a secure data transfer( in other words downloading and uploading).
I know that still you can't do FXP SSL to SSL transfer.

ioFTPD is a wonderfull and a powerfull project, so guys keep working on the good job. I hope that soon the new release of ioFTPD will be released in this year or sooner.


This is my settings:
--------------------------------------------------------------------------------
### Encryption ###
#
Require_Encrypted_Auth = *
Require_Encrypted_Data = *
Certificate_Name = pnc-cert-ssh1
Explicit_Encryption = True
Encryption_Protocol = SSL2
Min_Cipher_Strength = 128
Max_Cipher_Strength = 256
--------------------------------------------------------------------------------

saludos
PNC is offline   Reply With Quote
Reply

Tags
closed, dir, problem, ssl, started

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:01 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)