Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-07-2004, 10:14 AM   #1
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default bug in httpd/php submitted POST data

Code:
<html>
<head>
<title>Create new account</title>
</head>
<body>

<?

print_r($_POST);

?>
    <hr>
    <form name="adduser" method="post" action="bug.php">
        <table>
            <tr> 
                <td>Username: </td>
                <td><input name="username" type="text" maxlength="32"></td>
            </tr>
            <tr> 
                <td>Password:</td>
                <td><input name="password" type="password" maxlength="32"></td>
            </tr>
            <tr> 
                <td>Tagline:</td>
                <td><input name="tagline" type="text" maxlength="96"></td>
            </tr>
            <tr>
                <td colspan="2">&nbsp;</td>
            </tr>
    		<tr align="center">
    		    <td colspan="2"><input name="Submit" type="submit" value="Create account"></td>
            </tr>
        </table>
    </form>                

</body>
</html>
-> gives $_POST arrays like this:
Array ( [/png,image/jpeg,image/gif;q] => 0.2,*/*;q=0.1 )
Array ( [0,en;q] => 0.9 )

On opera 7.23 and firefox 0.8; IE6 seems to work fine.
ADDiCT is offline   Reply With Quote
Old 04-07-2004, 10:32 AM   #2
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

Hmm, after restarting both 'broken' browsers they seem to show it correctly again.
Didn't touch the php file, nor restart ioFTPD.
I'll let u know if happens again.

Edit: ok, it's happening again (all the time)
ADDiCT is offline   Reply With Quote
Reply

Tags
0.9, 7.23, array, opera, post, data, submitted, httpd/php, bug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM


All times are GMT -5. The time now is 06:21 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)