Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-05-2004, 07:17 PM   #1
CustomElement
Junior Member
 
Join Date: Jan 2004
Posts: 24
Default wierd error

I've been using ioftpd for a while now and love it.. today I found my first bug(?)... everything was running fine, then all of a sudden my system started to freeze up.. when it finally came back to life, I noticed ioftpd was dead.. upon restarting it I get the following error....

The instruction at "0x77f83905" referenced memory at "0x00000000". The memory could not be "written"
Click on OK to terminate the program

anyone have any idea's?

I'm using ioftpd 5.3.9 on win xp with all service packes and patches
CustomElement is offline   Reply With Quote
Old 02-06-2004, 05:05 AM   #2
wooolF[RM]
Senior Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 411
Default

same happend here... found out after 2 days debuggin' that it was ioBanana's fautl (yeh yeh, go on flame me, say I have configged it wrong etc...)
wooolF[RM] is offline   Reply With Quote
Old 02-06-2004, 06:07 AM   #3
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default Re: wierd error

Quote:
Originally posted by CustomElement
I'm using ioftpd 5.3.9 on win xp with all service packes and patches
Before you report a bug, try upgrading to the latest ioFTPD version and test if it still occurs.

And if your using any scripts, you should list them.
neoxed is offline   Reply With Quote
Old 02-06-2004, 06:10 AM   #4
toki
Senior Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 221
Default

and u should try using ur ioftpd without any scripts for a while to find out whether its io or script problem.
toki is offline   Reply With Quote
Old 02-09-2004, 02:47 PM   #5
CustomElement
Junior Member
 
Join Date: Jan 2004
Posts: 24
Default

Okay.. I did a fresh install, of nothing but the basic latest ioFTPD, no scripts, nothing..

1. Logged in using ioFTPD/ioFTPD
2. site passwd (newpass)
3. disconnected and restarted ioFTPD from scratch (kill process & relaunch)
4. Logged in using new password for ioFTPD
5. site deluser darkone
6. disconnected and restarted ioFTPD from scratch (kill process & relaunch)
7. Logged in using new password for ioFTPD
8. site grpdel lSpeed
9. disconnected and restarted ioFTPD from scratch (kill process & relaunch)


And that's when it gives me the error.. everytime.. tried it 4 times.. tried it by had the way I described here and with using ioGUI.. always gives me the same error..

The instruction at "0x77f83905" referenced memory at "0x00000000". The memory could not be "written"
Click on OK to terminate the program


any suggestions? or can anyone duplicate this error?
CustomElement is offline   Reply With Quote
Old 02-09-2004, 03:37 PM   #6
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Windows 2003
Did exactly that, using 5.6.3u package...
No crash.
Mouton is offline   Reply With Quote
Old 02-09-2004, 04:10 PM   #7
CustomElement
Junior Member
 
Join Date: Jan 2004
Posts: 24
Default

it looks like it wasn't an error directly linked to removing that group, but rather that when i removed that group it left an empty line at the end of the GroupIDTable file. When I removed that empty line, it ran fine, I tried in several GrouIDTable files, from several different installations on my machine, and each time it looks like that was the problem. How/Why this empty line was added, I'm not sure, but it appears this was the problem.
CustomElement is offline   Reply With Quote
Old 03-29-2004, 10:18 AM   #8
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Most assuredly related to ioFTPD shutdown...
Will wait for dark0n3 to fix the shutdown issue to close this.
Mouton is offline   Reply With Quote
Old 02-17-2005, 07:23 PM   #9
batwinky
Junior Member
 
Join Date: Jan 2004
Posts: 1
Default

i just got this problem have tried anything but nothing works

Edit: nm, had a windows problem so had to format the computer and now it works
batwinky is offline   Reply With Quote
Reply

Tags
0x77f83905, instruction, ioftpd, memory, win

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:19 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)