Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-10-2003, 03:44 PM   #1
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default [Fixed] Hosts.Rules not allowing hostnames

Code:
POLICY DENY

CLASS TEST 5

ACCEPT I 216.239. TEST 5
ACCEPT H ip216-239- TEST 5
ACCEPT H .net	TEST 5
My IP: 216.239.x.x
My hostname (reported by error.log): ip216-239-x-x.vif.net

I can connect with this Hosts.Rules, but if I remove the "ACCEPT I 216.239. TEST 5" line, I can't connect, even though the two other H lines should allow me to.

Anyone else could confirm that hostnames doesn't work in Hosts.Rules ?
Mouton is offline   Reply With Quote
Old 11-10-2003, 03:52 PM   #2
tozz
Junior Member
ioFTPD Registered User
 
Join Date: Aug 2003
Posts: 4
Default

Confirmed here

POLICY DENY

CLASS USERS 10

Works.
ACCEPT H subhost.host.tld USERS 2

Does not work.
ACCEPT H .host.tld USERS 2

Should mention I use 5.2.15r with no additional scripts exept for ioZS
tozz is offline   Reply With Quote
Old 11-10-2003, 03:54 PM   #3
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

I can confirm that they don't work with DENY either.

I used the following settings to test it:
Code:
POLICY	ACCEPT	2
DENY	H .nl	"Test"
A few minutes later, someone from .nl logs in.

11-10-2003 21:46:19 LOGIN: "ioB_Service" "xx" "donators" "Vote ioFTPD for president" "xx@xx.gelen1.lb.home.nl"
Harm is offline   Reply With Quote
Old 11-10-2003, 04:59 PM   #4
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

You need to restart daemon once you change that file... + hostnames are matched from the end of hostname, while ips are matched from the beginning:

I 192.168. = 192.168.*.*
H .home.net = *.home.net
darkone is offline   Reply With Quote
Old 11-10-2003, 05:08 PM   #5
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

I did restart the daemon after the modifications and before the user's login.
Harm is offline   Reply With Quote
Old 11-10-2003, 06:40 PM   #6
tozz
Junior Member
ioFTPD Registered User
 
Join Date: Aug 2003
Posts: 4
Default

I restarted every time I did a modification and I've tried with both .host.tld and *.host.tld and neither of them works.
tozz is offline   Reply With Quote
Old 11-10-2003, 06:41 PM   #7
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Quote:
Originally posted by darkone
You need to restart daemon once you change that file... + hostnames are matched from the end of hostname, while ips are matched from the beginning:
"ACCEPT H .net TEST 5" would work if that's so. It doesn't.
Mouton is offline   Reply With Quote
Old 11-15-2003, 04:33 AM   #8
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Fixed
darkone is offline   Reply With Quote
Reply

Tags
accept, connect, hostnames, hosts.rules, test

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:11 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)