Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-30-2003, 09:46 AM   #1
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default APPE not working

Here's 4 resume tests, with both APPE and REST/STOR, using SSL and not SSL.

SSL/REST/STOR (works):
[09:36:20] [L] TYPE I
[09:36:20] [L] 200 Type set to I.
[09:36:22] [L] PROT P
[09:36:22] [L] 200 Protection set to: Private.
[09:36:22] [L] PASV
[09:36:22] [L] 227 Entering Passive Mode (127,0,0,1,4,4)
[09:36:22] [L] REST 34816
[09:36:22] [L] 350 Restarting at 34816. Send STORE or RETRIEVE to initiate transfer.
[09:36:22] [L] STOR file1.test
[09:36:22] [L] Connected. Negotiating SSL/TLS session..
[09:36:22] [L] SSL/TLS negotiation successful...
[09:36:22] [L] TLSv1/SSLv3 encrypted session using cipher RC4-MD5 (128 bits)
[09:36:22] [L] 150 Opening BINARY mode data connection for file1.test.

SSL/APPE (cause Connection lost):
[09:42:08] [L] TYPE I
[09:42:08] [L] 200 Type set to I.
[09:42:11] [L] PASV
[09:42:11] [L] 227 Entering Passive Mode (127,0,0,1,4,7)
[09:42:11] [L] APPE file1.test
[09:42:11] [L] Connected. Negotiating SSL/TLS session..
[09:42:11] Resumed: file1.test 127.43 MB in 12:50:08 (2.82 KBps)
[09:42:11] [L] TYPE A
[09:42:11] [L] 425 Can't build data connection: Seek offset exceeds end of file.
[09:42:11] [L] STAT -la
[09:42:11] [L] Connection lost: Localhost

Non-SSL/REST/STOR (works):
[09:43:23] [L] TYPE I
[09:43:23] [L] 200 Type set to I.
[09:43:25] [L] PASV
[09:43:25] [L] 227 Entering Passive Mode (127,0,0,1,4,8)
[09:43:25] [L] REST 34816
[09:43:25] [L] 350 Restarting at 34816. Send STORE or RETRIEVE to initiate transfer.
[09:43:25] [L] STOR file1.test
[09:43:26] [L] 150 Opening BINARY mode data connection for file1.test.

Non-SSL/APPE (fails):
[09:44:08] [L] TYPE I
[09:44:08] [L] 200 Type set to I.
[09:44:10] [L] PASV
[09:44:10] [L] 227 Entering Passive Mode (127,0,0,1,4,9)
[09:44:10] [L] APPE file1.test
[09:44:10] [L] 425 Can't build data connection: Seek offset exceeds end of file.
[09:44:10] Transfer Failed!
[09:44:10] [L] TYPE A
[09:44:10] [L] 200 Type set to A.
[09:44:10] [L] STAT -la
[09:44:10] [L] List Complete: 236 bytes in 0.10 (0.23 KBps)
[09:44:10] Transfer queue completed

Non-SSL APPE doesn't close connection, but doesn't work either.

ioFTPD 5.2.10r
FlashFXP v2.2 build 933 [BETA RELEASE]
WinSock 2.0 -- OpenSSL 0.9.7c 30 Sep 2003
Mouton is offline   Reply With Quote
Old 10-30-2003, 12:53 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

who uses appe anyways really, i'll see if i can fix this in next version
darkone is offline   Reply With Quote
Old 10-31-2003, 07:01 PM   #3
ZAiNT
Disabled
 
Join Date: Apr 2003
Posts: 21
Default

what exactly is appe?
ZAiNT is offline   Reply With Quote
Old 10-31-2003, 07:09 PM   #4
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

instead of sending REST [offset] and then STOR file.name, u can directly append data to the file with APPE
(alternative way of resuming transfer)
ADDiCT is offline   Reply With Quote
Reply

Tags
flashfxp, type, [093622], [094410], [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:42 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)