Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-27-2003, 08:08 AM   #1
Psychosis
Member
ioFTPD Foundation User
 
Join Date: May 2003
Posts: 45
Default Still have ghosting prob with 5.1.3

Win2k3 and still have the ghosting prob....no scripts at all running, just plain jane ioftpd. Check this out.

Just tried 5.1.3 and same thing.

SITE WHO
200- ___________ ________
200- _______\_ _/__\ /________
200- ø \ / | | | _ /
200- ruz | /\ | | | |
200-+---------------ø----|______________\___|_____|_______|------------------------+
200-| psyadmin / SiTEOPs | idle 00:00:15 | %: |
200-| SiTEOP | since 00:00:18 | p: / |
200-+------------------------------------------------------------------------------+
200-| test2 / xxxxxxx | idle 00:00:07 | %: |
200-| NOT SET | since 00:00:08 | p: / |
200-+------------------------------------------------------------------------------+
200-| Up: 0 / 0.0kbs | Dn: 0 / 0.0kbs | Total: 0 / 0.0kbs |
200-+---------------------------------------------------------------------[ioFTPD]-+
200 Command successful.
SITE KICK test2
200 Killed 1 connection.
SITE WHO
200- ___________ ________
200- _______\_ _/__\ /________
200- ø \ / | | | _ /
200- ruz | /\ | | | |
200-+---------------ø----|______________\___|_____|_______|------------------------+
200-| psyadmin / SiTEOPs | idle 00:00:06 | %: |
200-| SiTEOP | since 00:00:42 | p: / |
200-+------------------------------------------------------------------------------+
200-| test2 / xxxxxxx | idle 00:00:31 | %: |
200-| NOT SET | since 00:00:32 | p: / |
200-+------------------------------------------------------------------------------+
200-| Up: 0 / 0.0kbs | Dn: 0 / 0.0kbs | Total: 0 / 0.0kbs |
200-+---------------------------------------------------------------------[ioFTPD]-+
200 Command successful.


Then after my psyadmin account idled out i reconnected with psyadmin and look what I see.

SITE WHO
200- ___________ ________
200- _______\_ _/__\ /________
200- ° \ / | | | _ /
200- ruz | /\ | | | |
200-+---------------°----|______________\___|_____|_______|------------------------+
200-| psyadmin / SiTEOPs | idle 00:03:29 | %: |
200-| SiTEOP | since 00:04:11 | p: / |
200-+------------------------------------------------------------------------------+
200-| test2 / xxxxxxx | idle 00:04:00 | %: |
200-| NOT SET | since 00:04:01 | p: / |
200-+------------------------------------------------------------------------------+
200-| psyadmin / SiTEOPs | idle 00:00:04 | %: |
200-| SiTEOP | since 00:00:06 | p: / |
200-+------------------------------------------------------------------------------+
200-| Up: 0 / 0.0kbs | Dn: 0 / 0.0kbs | Total: 0 / 0.0kbs |
200-+---------------------------------------------------------------------[ioFTPD]-+
200 Command successful.

I also wnet back and used none of my users/groups and used the default ioftpd users/groups and still got ghosts. This was pulled after one instance of ioFTPD user idled out.

SITE WHO
200- ___________ ________
200- _______\_ _/__\ /________
200- ° \ / | | | _ /
200- ruz | /\ | | | |
200-+---------------°----|______________\___|_____|_______|------------------------+
200-| ioFTPD / ioftpd | idle 00:02:32 | %: |
200-| Speed of light | since 00:02:34 | p: / |
200-+------------------------------------------------------------------------------+
200-| ioFTPD / ioftpd | idle 00:00:04 | %: |
200-| Speed of light | since 00:00:06 | p: / |
200-+------------------------------------------------------------------------------+
200-| Up: 0 / 0.0kbs | Dn: 0 / 0.0kbs | Total: 0 / 0.0kbs |
200-+---------------------------------------------------------------------[ioFTPD]-+
200 Command successful.

Any more ideas D1??

BTW specs on pc is:
Abit BP6 dual cpu intel 440BX
2 x celeron 550MHz
256MB ram
2 x 160gig WD SE drives
Psychosis is offline   Reply With Quote
Old 09-27-2003, 09:39 AM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

It's issue with your system, not in io.. For some reason, some windows installations don't cancel pending io from socket when its' closed. There's absolutely nothing I can do about it. (try reinstalling windows)
darkone is offline   Reply With Quote
Old 09-27-2003, 09:44 AM   #3
Psychosis
Member
ioFTPD Foundation User
 
Join Date: May 2003
Posts: 45
Default

I reinstalled windows 2003 once already and issue was still there. I also killed every process(other apps) that was running except for io and it still did it. I am just wondering if there might be any tricks or workarounds that might solve it..i guess im stuck with 4.9.4r if i wanna keep windows 2003. thnx anyway D1.
Psychosis is offline   Reply With Quote
Old 09-30-2003, 03:44 PM   #4
Alpinex
Junior Member
 
Join Date: Apr 2003
Posts: 15
Default

I'm also having the same issue, on 2 computers both running io. (XP) It seems to ghost almost every connection. Is there nothing that can be done?
Alpinex is offline   Reply With Quote
Old 09-30-2003, 10:06 PM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Not until I manage to reproduce it.. or get remote desktop access to box on which it occurs
darkone is offline   Reply With Quote
Old 10-01-2003, 02:50 AM   #6
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

Try checking your tcpip registry settings. You might try a speeder like speed2k.exe . Some settings in the tcpip stack are different under win2k3 compared to winxp. Or backup your registry from xp specially check tings like HKLM\System\CurrentControlSet\Services\TcpIp
On the web are great tutorials about all settings in there.
FTPServerTools is offline   Reply With Quote
Old 10-02-2003, 02:27 AM   #7
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Bleep, anyone? This isn't going to be fixed, unless I can work on computer that suffers from this. I will start working on some other stuff this weekend - which means that it will remain unfixed for next couple of weeks (or longer)
darkone is offline   Reply With Quote
Old 10-02-2003, 01:45 PM   #8
Alpinex
Junior Member
 
Join Date: Apr 2003
Posts: 15
Default

I think I should be able to give you remote on a computer that is experiencing this problem. I will send you a pm through the forum a little later today.
Alpinex is offline   Reply With Quote
Old 10-02-2003, 07:22 PM   #9
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

As I suspected, there is no reason to blame ioFTPD Actual reason for ghosting lies elsewhere...

Grab this tool, and make sure that you have ONLY following items on the KEEP list: mswsock.dll, winrnr.dll, rsvpsp.dll. Everything else must/should go.

I spent 4hours to debug this, as I assumed that it's ioftpd's fault, and found out that mcafee is to blame (this problem may apply to other virus scanners, firewalls/network applications) I wonder how widely used commerical programs can be that dodgy... go sue them
darkone is offline   Reply With Quote
Old 10-02-2003, 08:16 PM   #10
Psychosis
Member
ioFTPD Foundation User
 
Join Date: May 2003
Posts: 45
Default

HOLY SHIT!!!! YOU ARE THE MAN DARKONE!!!!

I never really said it was ioftpd's fault for sure. I always had my doubts. I figured it was prolly a win2k3 thing or something outside of ioftpd but i never knew how to go about looking for the prob.

I can now switch to beta5.1.

THANK YOU THANK YOU THANK YOU!!!

IOFTPD ROCKS!!!!!
Psychosis is offline   Reply With Quote
Old 10-03-2003, 04:03 AM   #11
Alpinex
Junior Member
 
Join Date: Apr 2003
Posts: 15
Default

Just wanted to say thanks again for figuring this one out for us
Alpinex is offline   Reply With Quote
Old 01-15-2004, 07:42 AM   #12
bugiam
Junior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2003
Posts: 5
Default

will this fix work with ghost dirs?
bugiam is offline   Reply With Quote
Old 01-16-2004, 01:46 PM   #13
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Ghost dirs are due to scripts not flushing the dir cache when they should.
Either contact the script author to fix it or use tuff flushdircache itcl thingy.
Mouton is offline   Reply With Quote
Old 01-16-2004, 03:51 PM   #14
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Quote:
Originally posted by darkone
I spent 4hours to debug this, as I assumed that it's ioftpd's fault, and found out that mcafee is to blame (this problem may apply to other virus scanners, firewalls/network applications) I wonder how widely used commerical programs can be that dodgy... go sue them
Other programs that could cause problems with ghosts are Netlimiter and Panda Antivirus. I know at least a handful of cases.
Zer0Racer is offline   Reply With Quote
Old 07-11-2004, 08:30 PM   #15
AMDmannen
Junior Member
 
Join Date: Nov 2003
Posts: 4
Talking

I had the same problem here on my 2k3 box.
The problem was NOD32 and the IMON scanner, reinstalling NOD solved the problem.

Many thx darkone, i was going nuts over this and too get io working with pasv mode, but that now seems solved.
:banana: :banana: :banana:
AMDmannen is offline   Reply With Quote
Reply

Tags
0.0kbs, 200-, 200-|, idle, ioftpd

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Change credits Goose Bug Reports 3 11-26-2002 07:39 AM


All times are GMT -5. The time now is 12:29 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)