Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-03-2003, 10:33 PM   #1
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default Crashing, can't figure out why..

ioftpd version: Beta 4.6.1

operating system: windows xp (service pack1 installed)

services affected: all (ftp, telnet, http)

how-to reproduce bug: unknown


IOFTPD crashes and I get a windows error.. I'm not sure what is causing it.. here is what is written to the event log:

Faulting application ioftpd.exe, version 0.0.0.0, faulting module tcl84.dll, version 8.4.2.1, fault address 0x000964cb.

any suggestions ?

I have disabled my zipscript and my sitebot (dzsbot, zipscript-c) and also commented out the zipscript lines in my ioftpd.ini and it had no effect.

service_update is disabled, I am on static IP. I am sort of new to ioFTPD so if more info is needed from logs or something just tell me where to find it and I'll post it
Superblue is offline   Reply With Quote
Old 05-03-2003, 10:41 PM   #2
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

added note.. ioftpd was working great until like a week ago.. nothing has been changed except for add/del users..
Superblue is offline   Reply With Quote
Old 05-03-2003, 11:07 PM   #3
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default Re: Crashing, can't figure out why..

Quote:
Originally posted by Superblue
ioftpd version: Beta 4.6.1

operating system: windows xp (service pack1 installed)

services affected: all (ftp, telnet, http)

how-to reproduce bug: unknown


IOFTPD crashes and I get a windows error.. I'm not sure what is causing it.. here is what is written to the event log:

Faulting application ioftpd.exe, version 0.0.0.0, faulting module tcl84.dll, version 8.4.2.1, fault address 0x000964cb.

any suggestions ?

I have disabled my zipscript and my sitebot (dzsbot, zipscript-c) and also commented out the zipscript lines in my ioftpd.ini and it had no effect.

service_update is disabled, I am on static IP. I am sort of new to ioFTPD so if more info is needed from logs or something just tell me where to find it and I'll post it
Which .iTCL scripts you have installed?
darkone is offline   Reply With Quote
Old 05-03-2003, 11:55 PM   #4
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

args.itcl, premkd.itcl, showfile.itcl, newdir.itcl, banfile.itcl, newdirlog.itcl

other scripts:
ioA 0.7.4 (running)
iotrial (running)
dupedir (not running)
Superblue is offline   Reply With Quote
Old 05-04-2003, 03:49 AM   #5
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

Put as much loggin on as you can.
Start DrWtsn32.exe fill in dump symbol table, dump all thread contexts, append to existing log file, visual notification, create crash dump file and set nyumber of instructions to at least 50.
If it crashes again then it is possible to find which routine causes the crsh and the cause can be found easier again.
And already check if you have a log file from dr watson with the last crash in there.
FTPServerTools is offline   Reply With Quote
Old 05-05-2003, 08:21 AM   #6
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

Here is the crash dump from last week.. it hasn't crashed since I changed the drwtsn config .. go figure..

http://josh.swoca.net/misc/crash.txt
Superblue is offline   Reply With Quote
Old 05-05-2003, 03:42 PM   #7
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

well, I'm making reverse progress.. now instead of crashing, it just closes all by itself. Seems to happen whenever someone tries to up a file..
Superblue is offline   Reply With Quote
Old 05-06-2003, 12:27 AM   #8
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

If possible, rar/zip your ioftpd directory (including ioftpd.exe/scripts etc) & email to darkone@ioftpd.com
darkone is offline   Reply With Quote
Old 05-06-2003, 03:36 AM   #9
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

This looks like an error in a timer routine if I am not mistaken. I bet dark0n3 can use this crashdump...
FTPServerTools is offline   Reply With Quote
Old 05-06-2003, 07:52 AM   #10
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

Too large to email, sent you a PM where you can get it off the web.
Superblue is offline   Reply With Quote
Old 05-06-2003, 09:57 AM   #11
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

i installed everything from scratch.. ioftpd 4.6.2u, ioA, and newdir is all I re-installed to it though, copied vfs, user and groups from old directory, edited new ioftpd.ini by hand, I'm still having the magic shutdown issue..
Superblue is offline   Reply With Quote
Old 05-07-2003, 02:24 AM   #12
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Tried your config with .exe that came with the package & debug version of the latest build.. both seemed to function perfectly :\ (No errors what-so-ever) I will do more intensive test runs later today, but atm. it looks like there might be something wrong with your windows installation (very old/dodgy versions of some runtime dlls perhaps)
darkone is offline   Reply With Quote
Old 05-07-2003, 10:59 AM   #13
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

I got this one figured out. The zipscript was creating invalid symlinks and if you followed one the server would just shutdown/close/crash or whatever.. I still don't know what caused that divide by zero.. it only happened once.. I'll keep working on it..
Superblue is offline   Reply With Quote
Old 05-07-2003, 11:45 AM   #14
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Were those symlinks invalid or so? (Sounds odd that it caused server to crash...)
darkone is offline   Reply With Quote
Old 05-07-2003, 12:16 PM   #15
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default

i dunno what I did LOL.. i can send you my config file for zipscript-c if you want to look at it. I am now using iozs and it works fine..
Superblue is offline   Reply With Quote
Reply

Tags
faulting, ftp, ioftpd, version, zipscript

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:13 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)