Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-11-2003, 03:16 PM   #1
ratnic
Junior Member
 
Join Date: Jan 2003
Posts: 6
Default Problems with http

Here is my line in the cfg:

Http = DEVICE Any PORT 10000 MAXUSERS 100 PERMISSION "H =HTTP" SSL "..\etc\ioFTPD-rsa.pem"

ftp is on port 21.

I can't connect to: https://localhost:10000/ but http://localhost:10000/ work, here is the output:

220 ioFTPD [www: http://www.ioftpd.com] - [version: beta 4] server ready.
500 'GET / HTTP/1.1': Command not understood
500 'Accept: */*': Command not understood
500 'Accept-Language: en': Command not understood
500 'Accept-Encoding: gzip, deflate': Command not understood
500 'User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)': Command not understood
500 'Host: localhost:10000': Command not understood
500 'Connection: Keep-Alive': Command not understood
500 '': Command not understood



operating system: Windows XP pro (english) sp1 and all hotfixes.
ratnic is offline   Reply With Quote
Old 01-11-2003, 06:02 PM   #2
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Hmm.. are you connecting to http(s) etc. with a ftp client? Cause it looks that way. You are supposed to use your internet browser.. like Internet Explorer. SSL doesn't work properly without your own generated SSL certificate so you could try to disable SSL by removing it from the service string:
Http = DEVICE Any PORT 10000 MAXUSERS 100 PERMISSION "H =HTTP"

And make sure the account you want to log in with has the H flag (or whatever flag you want to use, which is configured also in the service string PERMISSION "M" for connecting with ONLY master accounts). You can set flag with the command: site change <username> flags +H
Note: H is not the same as h.

And right now (ioFTPD 4.0.2) the HTTP Admin is not finished. Things that work right now is login, browsing and downloading files.

Hope this helps
/Zer0Racer
Zer0Racer is offline   Reply With Quote
Old 01-11-2003, 10:55 PM   #3
ratnic
Junior Member
 
Join Date: Jan 2003
Posts: 6
Default

No I'm not using a ftp program to connect.. and yes I do know that it looks like that.

Already tried to remove ssl from the Http line, still same problem. Thing is that it has worked since 3.x.x and when I switched to latest 4.0.x it broke.

And if the problem would be that no user got H access then the page would load anyway....

Here's full conf:

[Services]
Ftp = DEVICE Any PORT 21 MAXUSERS 20 TLS "c:\program files\ioFTPD\etc\ioFTPD-rsa.pem" SDEVICES Internal
Ftp = DEVICE Any PORT 21 MAXUSERS 20 SDEVICES Internal
Ftp = DEVICE Nat PORT 21 MAXUSERS 20 TLS "c:\program files\ioFTPD\etc\ioFTPD-rsa.pem"
Ftp = DEVICE Nat PORT 21 MAXUSERS 20
Ftp = DEVICE Nat PORT 24195 MAXUSERS 20
Ftp = DEVICE Nat PORT 24195 MAXUSERS 20 TLS "c:\program files\ioFTPD\etc\ioFTPD-rsa.pem"

Http = DEVICE Any PORT 10000 MAXUSERS 100 PERMISSION "H =HTTP"
ratnic is offline   Reply With Quote
Old 01-20-2003, 09:57 PM   #4
ratnic
Junior Member
 
Join Date: Jan 2003
Posts: 6
Default

Little update: using 4.0.4 now and I got it to work. First it didn't but when I changed:

Listen_Device = Any
to
Listen_Device = Local

it started working. Now I tried the Telnet support, same thing here that I'm forwarded to the ftp service instead of the telnet. Didn't work to change from Any to local here.

Could this have something to do with the ports option for the devices? Local = 20000-25000 and Any = 1024-2048 by default config. What does the device do if the ports line is missing, using all ports or not function at all?
ratnic is offline   Reply With Quote
Old 01-20-2003, 10:07 PM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

If ports line is missing, it uses 1024 -> 65535 .. or was it 1024->2048.. anyways, these port lines have nothing to do with what port service is bound to (these ports are used for ftp transfers only)
darkone is offline   Reply With Quote
Reply

Tags
500, command, ftp, understood, windows

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:23 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)