Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-09-2003, 07:44 AM   #1
InVisage
Junior Member
 
Join Date: Jan 2003
Posts: 17
Default SSL problem with 4.0.1

If I enabled SSL in the .ini file clients cannot log in. It says ' Connect to blahblahblah on port blah' but doesnt get past that point

However if I enable TLS everything is fine....unless someone tries to establish Implicit SSL etc and they cannot log in.

Any thoughts on this?
InVisage is offline   Reply With Quote
Old 01-09-2003, 07:49 AM   #2
InVisage
Junior Member
 
Join Date: Jan 2003
Posts: 17
Default

Just to add some more info.

I just tried on v 3.9.1 and the same bug exists.

If you try and connect using Implicit SSL it will not connect. Then if you cancel the connect and try TLS it crashes the server.
InVisage is offline   Reply With Quote
Old 01-09-2003, 10:10 AM   #3
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Connected to 192.168.1.10 Port 9999
Negotiating SSL/TLS session...
SSL/TLS negotiation successful...
SSL/TLS connection using cipher DES-CBC3-SHA (168 bits)
220 ioFTPD [www: http://www.ioftpd.com] - [version: beta 4] server ready.
USER ioFTPD



Works here as supposed to.. are you sure that your .pem file is correct? Paste your config line for ftp service here, if this answer didn't help you
darkone is offline   Reply With Quote
Old 01-13-2003, 06:12 AM   #4
InVisage
Junior Member
 
Join Date: Jan 2003
Posts: 17
Default

This is my ftp line:
Ftp = DEVICE Any PORT 888 MAXUSERS 20 TLS "..\etc\FTPD.pem"

But I have also tried it with just SSL "blah" and with both
InVisage is offline   Reply With Quote
Old 01-27-2003, 06:43 AM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Did you get it working?
darkone is offline   Reply With Quote
Old 01-28-2003, 09:49 AM   #6
InVisage
Junior Member
 
Join Date: Jan 2003
Posts: 17
Default

I removed my certificate and it stopped doing it.

I havent had a chance to recreate the certificate yet though.

Thanks for the help tho, i'll let you know when i try it again
InVisage is offline   Reply With Quote
Reply

Tags
enable, fine, log, ssl, thoughts

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FXP transfers with windows firewall(sp2) LeNgHoSt General Discussion 13 11-21-2004 03:21 AM


All times are GMT -5. The time now is 10:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)