Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-04-2002, 12:51 PM   #1
phobiq
Guest
 
Posts: n/a
Default Serious bug!?

I downloaded and set up the new ioFTPD beta today and it seems like 'normal' users cant see their directories... Only users with the 'V' flag can...

ioFTPD.exe also stops responding when using "SITE NUKE etc" (ioA 0.4.1 script).
  Reply With Quote
Old 11-04-2002, 01:36 PM   #2
chuddy
Member
 
Join Date: Oct 2002
Posts: 31
Default

I have the same problem : i'm unable to see root dirs on my site, i only succeed in by copy a .ioftpd file from another dir to the root then dirs were visible.

Other people experiment that ?
chuddy is offline   Reply With Quote
Old 11-04-2002, 01:58 PM   #3
phobiq
Guest
 
Posts: n/a
Default

That doesn't seem to work for me
  Reply With Quote
Old 11-04-2002, 09:03 PM   #4
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Myabe I've broken something in permission system.. that's how it sounds atleast.
darkone is offline   Reply With Quote
Old 11-04-2002, 09:05 PM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Just what I thought.. =/ Get the 3.5.1
darkone is offline   Reply With Quote
Old 11-05-2002, 12:26 AM   #6
kinetix
Junior Member
 
Join Date: Nov 2002
Posts: 4
Default

thanks for the fast update
kinetix is offline   Reply With Quote
Old 11-05-2002, 04:00 AM   #7
chuddy
Member
 
Join Date: Oct 2002
Posts: 31
Thumbs up

Nice work Darkone !
chuddy is offline   Reply With Quote
Old 11-05-2002, 07:58 AM   #8
kinetix
Junior Member
 
Join Date: Nov 2002
Posts: 4
Default

i still need to add the v flag for new users to list the root.

i deleted the default users, i think it worked before i did that. not sure anymore.. i need some sleep
kinetix is offline   Reply With Quote
Old 11-05-2002, 09:37 AM   #9
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Make sure you closed the old daemon Atleast account 'darkone' works for me now (btw password is 'dungeon')
darkone is offline   Reply With Quote
Old 11-05-2002, 11:19 AM   #10
chuddy
Member
 
Join Date: Oct 2002
Posts: 31
Default

Beta 3.5.1 is just fine for me.
chuddy is offline   Reply With Quote
Old 11-05-2002, 12:12 PM   #11
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

chuddy, tell me how you got it to work!

i tried a clean 3.5.1.. logged in with ioFTPD.. listing works.
logged in with the darkone account.. listing doesn't work.
Zer0Racer is offline   Reply With Quote
Old 11-05-2002, 12:28 PM   #12
chuddy
Member
 
Join Date: Oct 2002
Posts: 31
Default

arghh mea culpa, it works for me but not in usual conditions :
i had an old .ioftpd file at the root of my system.
I didn't pay attention


It's not a regular way but if you want your normal users have list on root you must make a .ioftpd file on it.
How to make it ?
Make a dir with your normal user at root, inside this directory a .ioftpd file will be created then copy it on the root, refresh listing with your normal user and now you can see the list. I assume it's not a normal way and it may cause other incidences (only Darkone know it cause .ioftpd file has a strange format).

I haven't better way, waiting for a strong fix.
chuddy is offline   Reply With Quote
Old 11-05-2002, 01:09 PM   #13
phobiq
Guest
 
Posts: n/a
Default

I made a frech install too... Can'st list the dirs with users without the +v flag
  Reply With Quote
Old 11-05-2002, 01:35 PM   #14
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

tnx chuddy.. replacing the .ioFTPD file in root did the trick
i just took one .ioFTPD file from a normal dir without specific permissions.
Zer0Racer is offline   Reply With Quote
Old 11-05-2002, 02:20 PM   #15
phobiq
Guest
 
Posts: n/a
Default

It works fine if you change the old_directory line (in ioFTPD.ini) to

old_directory = 777 0:0
  Reply With Quote
Reply

Tags
flag, ioftpd.exe, responding, stops, users

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compare Folder Content -- SUBDIRS too? dgrrr General Discussion 1 04-04-2005 08:28 PM


All times are GMT -5. The time now is 12:59 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)