Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-17-2005, 04:14 PM   #16
GILLIS902
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2005
Posts: 3
Default

i have this same problem, site crashes on every command.

Sys: Windows XP, SP2, English
GILLIS902 is offline   Reply With Quote
Old 11-18-2005, 10:57 AM   #17
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by GILLIS902
i have this same problem, site crashes on every command.

Sys: Windows XP, SP2, English
it might be related, it might not be related at all, but it looks like i've got a minor configuration problem on the build host i used to compile ioftpd 5.8.6r. i'm going to both move which build host i use for releases, as well as try to recreate this problem on an XP, SP2, english release of windows.

/me crosses fingers
_panic_ is offline   Reply With Quote
Old 11-18-2005, 11:28 AM   #18
JoC
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 76
Default

If you need me to test some alpha/beta builds or whatever just let me know. Since I got the problem I can say right away if it is fixed.
JoC is offline   Reply With Quote
Old 11-23-2005, 04:05 AM   #19
Elladan
Junior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 21
Default

Quote:
Originally Posted by JoC
Turns out it isnt just site commands that causes io to crash. I can login but when i tried to go to the MP3 dir io crashed.

Code:
[R] CWD MP3
[R] Connection lost: JoC
... same here..

perhaps because some Script Issue? (I use current ioBanana & ioA)

Windows XP SP2, German, io as Service

deleting .ioftpd files didn't help.. no log entry... only a crash

5.8.5r works fine
Elladan is offline   Reply With Quote
Old 11-23-2005, 05:29 AM   #20
JoC
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 76
Default

Quote:
Originally Posted by Elladan
... same here..

perhaps because some Script Issue? (I use current ioBanana & ioA)
Probebly not, I installed a clean install and got the same with the default commands.
So guess we will have to live with 5.8.5 for the time being. :9
JoC is offline   Reply With Quote
Old 11-23-2005, 05:35 AM   #21
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

Exactly we have to stick to 5.8.5 until this issue is fixed.
On my pc too io crashed with a clean install.
oldhouse is offline   Reply With Quote
Old 11-23-2005, 03:47 PM   #22
FTPServerTools
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 543
Default

Now it would be good if you guys noted down the error address and see if they are the same. This way it is a lot eaier to track the bug.
FTPServerTools is offline   Reply With Quote
Old 11-23-2005, 03:53 PM   #23
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

as ive posted in the 5.8.6r bug thread, $args is being lost (on certain DELE file.txt) this could also be happening with other scripts/events

be nice if the scripters here took the time to debug and see if thats the case
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-23-2005, 04:33 PM   #24
JoC
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 76
Default

Seems like site users and site groups works but all other commands internal or custom fails.
ioFTPD.exe crashed at offset 0002c092
JoC is offline   Reply With Quote
Old 11-24-2005, 08:26 AM   #25
esmandil
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2004
Posts: 107
Default

Quote:
Originally Posted by Tuff:

as ive posted in the 5.8.6r bug thread, $args is being lost (on certain DELE file.txt) this could also be happening with other scripts/events

be nice if the scripters here took the time to debug and see if thats the case
I don't think this is caused by missing $args (it could be related, though) -- on my machine ioFTPD crashes for a simple TCL script like this:
PHP Code:
iputs "abcd" 
called with "site esmTest" when I have "esmTest = TCL ..\scripts\esmTest.itcl" in ioftpd.ini

On the other hand, an equally simple esmTest2.bat:
PHP Code:
@echo "abcd" 
works just fine

When io crashes, the exact error message is:
Quote:
The exception Illegal Instruction
An attempt was made to execute an illegal instruction.
(0xc000001d) occurred in the application at location 0x0042c092
FTPServerTools:
Quote:
Now it would be good if you guys noted down the error address and see if they are the same. This way it is a lot eaier to track the bug.
Good guess here It does indeed seem that both me and JoC experience the crash occuring in the same place... _panic_, does this tell you anything?
esmandil is offline   Reply With Quote
Old 11-24-2005, 09:54 AM   #26
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by esmandil
I don't think this is caused by missing $args (it could be related, though) -- on my machine ioFTPD crashes for a simple TCL script like this:
PHP Code:
iputs "abcd" 
called with "site esmTest" when I have "esmTest = TCL ..\scripts\esmTest.itcl" in ioftpd.ini

On the other hand, an equally simple esmTest2.bat:
PHP Code:
@echo "abcd" 
works just fine

When io crashes, the exact error message is:

FTPServerTools:

Good guess here It does indeed seem that both me and JoC experience the crash occuring in the same place... _panic_, does this tell you anything?
it does tell me that esmTest.itcl is a much easier way to recreate this problem!

this is very neat actually, since i should be able to add something like this to the regression framework, figure out what code is lurking at 0x0002c092 and zap what is likely a dangling pointer there.

thanks much, i'll get rolling on this!
_panic_ is offline   Reply With Quote
Old 11-24-2005, 11:52 AM   #27
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

esm, add the global args ; iputs "$args" to check IF $args is being lost, would be much easier to rule it out after testing it, than simply ignoring it and guessing it aint the problem cause it aint there
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-29-2005, 08:57 AM   #28
esmandil
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2004
Posts: 107
Default

Quote:
Originally Posted by tuff
esm, add the global args ; iputs "$args" to check IF $args is being lost, would be much easier to rule it out after testing it, than simply ignoring it and guessing it aint the problem cause it aint there
I would happily try the < global args ; iputs "$args" > script... but it crashes just like the other one ::shrug:: No idea how can I test if args are set up correctly.

The best I can do is try to access those from *.bat file:

PHP Code:
@echo 1: %1 2: %2 3: %3 4: %4 5: %5
@echo x: %FLAGS% %PWD% %USER
called as "site esmtest3bat aa bb cc" seems to work just fine:

PHP Code:
200-1aa 2bb 3cc 4:  5:
200-x1MTH ioFTPD 
esmandil is offline   Reply With Quote
Old 12-23-2005, 02:34 AM   #29
Elladan
Junior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 21
Default

... anything changed here in .7r?
Elladan is offline   Reply With Quote
Old 12-23-2005, 02:36 AM   #30
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

there is a readme in the customer portal/download section
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Reply

Tags
5.8.6, comp, running, site, swho

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:20 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)