Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-13-2005, 09:44 AM   #1
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default 5.8.6r bug

a few people have mentioned a problem with 5.8.6r and deleteing files

i can confirm this, although it seems to be pretty random and not easily recreatable

when you try to delete a file, youll get a no such file or invalid dir error

when it happens again, ill post the exact error

*** NOTE! DO NOT POST CRASH REPORTS FOR 5.8.6r HERE THEY WILL BE DELETED!
*** CONFIGURE 5.8.6r WITH A CLEAN INI, THIS HAS BEEN CONFIRMED TO HELP
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-13-2005, 09:49 AM   #2
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

having the error message after the 550 response would be helpful, next time you see it.

i wonder if this is related to this flashfxp thread discussing an odd behaviour with the creation of directories.

in response to a MKD request, ioftpd returns a relative path, when imho it should return an absolute path instead. it could be getting itself confused about the PWD of the user, setting it only to that relative path.
_panic_ is offline   Reply With Quote
Old 11-13-2005, 09:51 AM   #3
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

panic, yeah ive spoke to bigstar about this, and its fixed in the next ffxp beta. i wonder if this is another ffxp/ioftpd only bug

edit: other user with the same problem is also using ffxp, although an older version
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-13-2005, 02:29 PM   #4
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

panic, happened again

DELE 01.mp3
550 01.mp3: No such file or directory.
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-13-2005, 08:27 PM   #5
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by tuff
panic, happened again

DELE 01.mp3
550 01.mp3: No such file or directory.
i'm going to suspect this is related to a PWD bug of some sort. don't suppose you know what commands you ran before this happened?
_panic_ is offline   Reply With Quote
Old 11-14-2005, 01:31 AM   #6
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

it seems to happen more often on resumed files, so REST and STOR, but thats just a guess
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-15-2005, 04:56 AM   #7
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

same problem here too
zpr is offline   Reply With Quote
Old 11-15-2005, 09:57 PM   #8
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by zpr
same problem here too
if you can provide a session script of the commands you run leading up to this problem, that would help greatly in me debugging it.

of course, demonstrating something with test data is better still, as i can use that as a test case.
_panic_ is offline   Reply With Quote
Old 11-20-2005, 08:36 AM   #9
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

ok, ive done a little more testing

when you dele a file, outputting $args (iputs ">> $args") works fine

although, when you attempt to delete one of these "locked" files, nothing is outputted for $args

it seems that $args, which we need to parse etc, is lost somewhere

it also seems that $pwd $path etc are also non existant

ie.

a good file deleted

DELE test.nfo
250 DELE command successful.
>> DELE test.nfo

a "locked?" file deleted

DELE test2.nfo
550 test2.nfo: No such file or directory.

so $args is being lost somewhere

btw panic, this is simply using the

[FTP_Post-Command_Events]
dele = TCL c:\ioFTPD\DELETEST.itcl

ini settings
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 11-21-2005, 03:23 PM   #10
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by tuff
ok, ive done a little more testing

when you dele a file, outputting $args (iputs ">> $args") works fine

although, when you attempt to delete one of these "locked" files, nothing is outputted for $args

it seems that $args, which we need to parse etc, is lost somewhere

it also seems that $pwd $path etc are also non existant

ie.

a good file deleted

DELE test.nfo
250 DELE command successful.
>> DELE test.nfo

a "locked?" file deleted

DELE test2.nfo
550 test2.nfo: No such file or directory.

so $args is being lost somewhere

btw panic, this is simply using the

[FTP_Post-Command_Events]
dele = TCL c:\ioFTPD\DELETEST.itcl

ini settings
that's a fairly good hint at what is happening. or at least where to look. tell me, is the file actually deleted, or it just exists but isn't removed *and* we get this error. i'm trying to narrow down where in the delete code path these variables are trashed.
_panic_ is offline   Reply With Quote
Old 11-21-2005, 03:32 PM   #11
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

the file isnt deleted panic, as $args is missing, it cant be parsed/used to "file delete -force -- $filename" etc in itcl

the file can be deleted in explorer though, so there isnt some process hogging the file
__________________
#iotools #ioftpd (both on efnet)
tuff is offline   Reply With Quote
Old 01-22-2006, 05:50 AM   #12
adfsliu
Junior Member
 
Join Date: Jan 2006
Posts: 1
Default

this bug is still in v5.8.7r

when deleteing somes files, it shows invalid filename or no such file, then i go to check the harddisk directory, the files are still exist.

but i find a way to delete them in ioftpd (i use ultrafxp 1.07 freeware).
sample: if abc.exe in \home, abc.exe can't been deleted. just modi directory name (\home -> \home1), after that u can delete abc.exe normally.


i am improving my english.
adfsliu is offline   Reply With Quote
Reply

Tags
5.8.6r, error, file, note, post

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:47 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)