Go Back   FlashFXP Forums > > >

Suggestions Post suggestions for upcoming versions

 
 
Thread Tools Display Modes
Old 08-06-2004, 01:32 AM   #1
alfer_2
Junior Member
 
Join Date: Aug 2004
Posts: 2
Default send noop during xfer

Hey guys,

Great job on v3.0, i love it. I think the most useful feature for me so far is the option to send noop's during xfers. It eliminates the problem of losing the control connection when behind a router and uploading large files at slow speeds. However, as a side effect it seems to break some fxp (site to site) transfers. As a result, my suggestion is to add options similar to the file exist rules to enable a user to select under what circumstances noop during transfer should be used, ie for downloads, uploads, or fxp xfers. Thanks, and keep up the good work!

aLfer
alfer_2 is offline  
Old 08-06-2004, 02:10 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

If this option works well with FTP transfers it should work just as well for site to site transfers.

Perhaps there's a bug or something that's causing it to fail with the site to site transfers, could you please provide a copy of the ftp session log.
bigstar is offline  
Old 08-06-2004, 02:20 AM   #3
alfer_2
Junior Member
 
Join Date: Aug 2004
Posts: 2
Default

bigstar, sure:

[R] PORT xxx,xxx,xx,xxx,xxx,xxx
[R] 200 Port command successful.
[R] STOR xxxxx.xxx
[R] 150 Opening data connection for xxxxx.xxx.
[L] RETR xxxxx.xxx
[L] 150 Opening BINARY mode data connection for xxxxx.xx (xxxxxxxx bytes).
[R] 200 NOOP command successful.
[R] 200 NOOP command successful.
[L] 226- [Ul: 0.0MB] [Dl: 3.6MB] [Speed: 193.95K/s] [Free: 78975MB]
[L] 226 [Section: DEFAULT] [Credits: 11.1MB] [Ratio: Unlimited]
[L] 500 'OOP': Command not understood.
[R] 200 NOOP command successful.
[L] 200 NOOP command successful.
[R] 200 NOOP command successful.
[L] 200 NOOP command successful.


At this point the file is complete, however the 200 NOOP successful commands just keep coming and notification is not received from either server that the xfer is complete. This is from glftpd>bpftp server i believe. Havent had a chance to check any others..

aLfer
alfer_2 is offline  
Old 08-06-2004, 03:09 AM   #4
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

noop doesn't work with bpftpd , so turn it off in the bpftpd site options.
MidKnight is offline  
Old 08-26-2004, 07:37 AM   #5
XiX
Junior Member
 
Join Date: Aug 2004
Posts: 4
Default

Hi there,

I have the same prob as alfer, but I fxp from a glftpd server to an ioftpd server and because of the large files and the slower connection I need these noops during the transfer to avoid a deconnection after the transfer has finished.

Here is the log of a successful transfer and of a non-successfull transfer:

[R] CPSV
[R] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx,xxx)
[L] PORT xxx,xxx,xxx,xxx,xxx,xxx
[L] 200 PORT command successful.
[L] STOR xxxxxxx.xxx
[L] 150 Opening BINARY mode data connection for xxxxxxxx.xxx.
[R] RETR xxxxxxx.xxx
[R] 150 Opening BINARY mode data connection for xxxxxxx.xxx (50000000 bytes).
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[R] 226- [Ul: xxxxx.xMB] [Dl: xxxxxx.xMB] [Speed: 93.11K/s] [Free: xxxxxMB]
[R] 226 [Section: DEFAULT] [Credits: 14.6MB] [Ratio: Unlimited]
[R] 200 NOOP command successful.
...
[L] 226-Elapsed Time: 0.023 sec
[L] 226 Transfer complete.
Transferred: xxxxxxxx.xxx 47,68 MB in 8 minutes 45 seconds (93,0 KB/s)

---------------------------------------------------------------------------------


[R] CPSV
[R] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx,xxx)
[L] PORT xxx,xxx,xxx,xxx,xxx,xxx
[L] 200 PORT command successful.
[L] STOR xxxxxxxxxx.xxx
[L] 150 Opening BINARY mode data connection for xxxxxxxxxx.xxx.
[R] RETR xxxxxxxxxx.xxx
[R] 150 Opening BINARY mode data connection for xxxxxxxxxx.xxx (50000000 bytes).
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[L] 200 NOOP command successful.
[R] 226- [Ul: xxxxx.xMB] [Dl: xxxxxx.xMB] [Speed: 88.58K/s] [Free: xxxxxxMB]
[R] 226 [Section: DEFAULT] [Credits: 14.6MB] [Ratio: Unlimited]
[R] 500 'OOP': Command not understood. <-- here is the problem: there is a "OOP" command instead of the "NOOP" command!
...
[L] 226-Elapsed Time: 0.022 sec
[L] 226 Transfer complete.
[L] Transfer Failed!

In the Queue window the file is shown as failed but on the ioftpd box the file is there and without any crc-errors. This problem happens approx. every 3rd file.

I'm not sure if this is a bug, but it seems that the NOOP command which is applied every xxx sec. fails sometimes since only a "OOP" command is sent.

Anyway Flash is a powerful program which I love to use!

XiX
XiX is offline  
Old 08-26-2004, 07:40 AM   #6
XiX
Junior Member
 
Join Date: Aug 2004
Posts: 4
Default

Sorry this was postet 2 times

XiX
XiX is offline  
Old 08-26-2004, 10:11 AM   #7
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

I can see that the glftpd server doesn't reply to the NOOP commands you've sent during the transfer.
You probably get "500 'OOP': Command not understood" when one of the NOOP commands is sent while glftpd sends the transfer complete message.
Harm is offline  
Old 08-27-2004, 04:44 AM   #8
XiX
Junior Member
 
Join Date: Aug 2004
Posts: 4
Default

But always when this happens, the file is shown as "not or not complete" transffered in the Queue Window. So I always have to check if all files were transfered correct and if i I don't have a zipscript on the target server I cannot be sure that the file is complete.

Maybe someone has a solution for this

THX XiX
XiX is offline  
Old 08-27-2004, 06:49 AM   #9
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

With glftpd sometimes you will see a 'OOP' error instead noop successful. glftpd doesn't allow commands to be sent during a file transfer (you don't see the reply until the transfer completes) and I suspect 'OOP' occurs based on the timing of when the NOOP was sent.

Until I can improve the "send noop during transfer" logic to better to handle these type of errors your only solution really is to disable this option on problem ftp servers.

Some progress has been made to improve this feature but it's still not 100% perfect.
bigstar is offline  
Old 08-27-2004, 07:03 AM   #10
XiX
Junior Member
 
Join Date: Aug 2004
Posts: 4
Default

O.k. thx for the info and for this nice app!

Best regards

XiX
XiX is offline  
 

Tags
fxp, noop, send, site, xfers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Deleted Profile On Flash rouil General Discussion 0 04-02-2005 09:03 PM


All times are GMT -5. The time now is 03:53 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)