Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 03-04-2004, 12:24 PM   #1
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default Can Not See Files on the FTP

Well I think this is a very unique problem and I hope to get some help. I am using FlashFXP v2.2 build 973 [BETA RELEASE] on Windows XP PRO.

Here is the problem: I can connect to the FTP via port 21 without a single problem, uploading and downloading, but there is an address on port 20 (same IP) that I can connect but CAN NOT sees the files. I did play with the settings and added port 20 to my firewall but no luck. I would appreciate any ideas on both sides (FTP & my computer).
tal3152 is offline  
Old 03-04-2004, 01:33 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

please include a copy of your ftp session status window.
bigstar is offline  
Old 03-04-2004, 03:01 PM   #3
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default Can Not See Files on the FTP

Here is a zip file with printed screens
Attached Files
File Type: zip ftprotano.zip (212.1 KB, 69 views)
tal3152 is offline  
Old 03-04-2004, 04:53 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,826
Default

you are having this problem becuase you are using STAT command instead of LIST.
seems like either that server doesn't like STAT command or FlashFXP can't parse results provided by the server...
disable STAT command and see if that fixes your problem.

however that ftpd is Serv-U FTP Server v5.0 so it should be supported...
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-04-2004, 10:35 PM   #5
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default

OK I took off the option Use 'stat -l' to use list directory
But now I am getting List Error.
There is no change on the address with port 21.

Enclosed you will find the new printed screen.
Attached Thumbnails
Can Not See Files on the FTP-pl-ftp-jpg  
tal3152 is offline  
Old 03-05-2004, 12:54 AM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,826
Default

it seems like your router is performing NAT in the ftp session.
both of your screenshots show that your flashfxp is sending PORT command with the wrong ip..your internal one instead of internet one.
when connection is on port 21, your router changes your internal ip to internet ip.
when connection is on port other than 21, your router doesn't do that.
enable PASV mode on your port 20 site.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-05-2004, 01:30 AM   #7
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default

First I would like to thank you for your quick responds.
I did activate the Passive Mode and now I am getting the following errors:
[R] Data Socket Error: Connection failed
[R] List Error
Attached Thumbnails
Can Not See Files on the FTP-pl-ftp-jpg  
tal3152 is offline  
Old 03-05-2004, 01:48 AM   #8
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,826
Default

well it seems like ftp server is misconfigured too..

since you are using beta 973, here is what you'll have to..

first thing is please enter your FlashFXP ID into your messageboard profile.
2nd is upgrade to build 975.
then you will need to go into configuration/administration for your linksys router and forward some port range to your computer. any ports between 1024 and 65535 is good..30-50 ports is a safe number.
then go to FlashFXP properties, Connection tab, check all 3 boxes in "Data Connectino" section, enter same port range you forwarded in your router and pick iplookup entry on the 2nd option.

once this is done, go back to site manager and disable PASV option you enabled earlier.

there is no need to post screen of your flashfxp. copy/paste of status log is equaly sufficient.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-05-2004, 02:18 AM   #9
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default

I don't have linksys router, my connection to the DSL is via a 3 COM Gateway (build in firewall). No Wireless.
I did the changes but I am still getting
[R] List Error

I'll ask the FTP server guy to check his ports configuration.
tal3152 is offline  
Old 03-05-2004, 06:01 AM   #10
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,826
Default

sorry, for some reason i thought you mentioned you have linksys router

[R] List Error is not enough to see what's going on..we need to see PORT/PASV command and what happenes after that..
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-05-2004, 09:51 AM   #11
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default

Sorry, for not posting the rest of the logs, as I said I made the changes you recommended but it did not work. I sent e-mail to the server guy but have not got responds.
BTW I am using the Active Ports application that show clearly that the connection with the server has been established.
Here are the logs after the changes.

[R] CLNT FlashFXP 2.2.973
[R] 200 Noted.
[R] CWD /
[R] 250 Directory changed to /
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PORT 192,168,1,1,4,3
[R] 200 PORT Command successful.
[R] LIST -al
[R] 150 Opening ASCII mode data connection for /bin/ls.
[R] 426 Data connection closed, transfer aborted.
[R] List Error
[R] NOOP
[R] 200 Command okay.

Update: I was able to connect to the FTP PORT 20 via SmartFTP
tal3152 is offline  
Old 03-05-2004, 12:42 PM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Options > Preferences > Connection Tab > Force Active Mode to use this IP

Check that and select "http://iplookup.flashfxp.com"
bigstar is offline  
Old 03-07-2004, 02:43 PM   #13
slo_mike
Junior Member
 
Join Date: Feb 2003
Posts: 24
Default

it could also be that the FTP server isn't properly setup for passive mode or is behind a router.

I've setup Serv-U so many times I can practically do it in my sleep. Tell the ftp owner to try the following settings in Serv-U:

Go under Settings then click on the Advanced tab and under there he'll see a passive port range. If there is anything in there, tell him to clear it out. That way Serv-u will use any available ports for passive mode.

Then have him go under Domains then click on the Settings there, click on the Advanced tab. Enable 'Allow passive mode data transfers, use IP'

Where you would normally enter the internet IP of the server, instead leave that blank as well, if you enter an IP in there it can screw up the passive mode listings especially if the server has a dynamic ip.

Most tutorials don't tell you this, but i've never had a problem doing it this way and works quite well too if you're configuring a server behind a router as well.

sj
slo_mike is offline  
Old 03-09-2004, 08:16 PM   #14
tal3152
Junior Member
 
Join Date: Mar 2004
Posts: 9
Default FlashFXP 2.2 976 BETA

OK guys I have done so far everything you asked me, I also downloaded the new BETA version (2.2 976) but I am still getting the same error (List Error).

I don’t really wish to step on anyone toes but since I downloaded SmartFTP I have no problems.
tal3152 is offline  
Old 03-10-2004, 04:54 AM   #15
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,826
Default

tal3152, can you paste status log as it appears after you made those changes..
and also can you paste status log from smartftp to see what it's doing differently..
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
 

Tags
connect, files, ftp, port, problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting to own/in house conradval Custom Commands 0 03-30-2004 05:20 PM


All times are GMT -5. The time now is 11:31 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)