Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 02-06-2004, 11:51 PM   #1
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Smile Editing annoyance

Hello,


I have this problem with FXP when editing php and html.

When I edit it while in FXP (without downloading) sometimes it like "formats" the html/php.


It is a super annoyance!

What it does is turns this:

<html>
<head>

<title>MY Homepage</title>
</head>

<Body>

BlahBlah

<br><br>

Blaaa

</body>
</html>


Into:

<html><head><title>MY Homepage</title></head><Body>BlahBlah<br><br>Blaaa</body></html>



Ie. everything gets puched together.

This makes hell for future editing of HTML and worse, it messes up any php


Any suggestions?

Thank you for your time,
Steen.
steen is offline  
Old 02-06-2004, 11:58 PM   #2
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Forgot to say

I am on Win XP editing with Notepad.



FXP: 2.1 build 924
Thanks again!
steen is offline  
Old 02-07-2004, 12:03 AM   #3
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

are those files being uploaded as binary or ascii?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-07-2004, 03:20 AM   #4
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Thanks for the reply.


It is always on Auto.


I dont choose one or the other or else I wll forget to change it for the dif file types
steen is offline  
Old 02-07-2004, 04:04 AM   #5
Shark
Senior Member
FlashFXP Beta Tester
 
Shark's Avatar
 
Join Date: Oct 2001
Posts: 606
Default

Can you paste the log, so we can work it out then..
Shark is offline  
Old 02-07-2004, 08:02 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

If you're seeing this problem with notepad then mostly the file is being downloaded in binary mode. You might have better results using the internal editor. ultimately you really need to transfer text files in ascii mode, most often if they're sent in binary mode php, cgi, etc have trouble reading the files and you get unexpected results from your web server.
bigstar is offline  
Old 02-07-2004, 03:04 PM   #7
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Quote:
Originally posted by bigstar
If you're seeing this problem with notepad then mostly the file is being downloaded in binary mode. You might have better results using the internal editor. ultimately you really need to transfer text files in ascii mode, most often if they're sent in binary mode php, cgi, etc have trouble reading the files and you get unexpected results from your web server.
Thank you.

One quick Q.


How do I set them all to the internal editor?

I like that one better, but I cannot find the program in my computer. The only .exe program in the FXP directory is flashfxp itself


Thank you.
steen is offline  
Old 02-08-2004, 10:25 AM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

in FlashFXP > Options > File Associations

Add the file masks and select "Internal Editor" as the editor.


Did you ever verify if the files were being uploaded in ascii or binary mode? it's very important that you find out.
bigstar is offline  
Old 02-08-2004, 05:57 PM   #9
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Quote:
Originally posted by bigstar
in FlashFXP > Options > File Associations

Add the file masks and select "Internal Editor" as the editor.


Did you ever verify if the files were being uploaded in ascii or binary mode? it's very important that you find out.
How do I check which mode files are being Xfered in?

Are you talking about uploads or downloads?



Thx.
steen is offline  
Old 02-08-2004, 09:03 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The transfer mode is displayed in the status window, if you're unsure then paste your status log and we can tell you.
bigstar is offline  
Old 02-08-2004, 09:13 PM   #11
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

I forgot to note a few things, sorry.


First off, when I make file association changes now and before, it uses the windows settings not the FXP settings

That is why all my html and php opens in Notepad

Secondly, I dont think its the Xfer mode myself.

What is happeing (it only happens maybe every 6th time and more often when I change the window size ) is it gets all squished together excactly when I click "save"


I finish editing in notepad, click the X and it asks me to save, I click save and at that moment, I see it all get squished together.


Thanks again!
steen is offline  
Old 02-09-2004, 09:15 AM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I still think the files are being sent in the wrong transfer mode. Perhaps by doing that the file format is slightly corrupted and that's what you get this unsual behavior with notepad.

Check the file association pattern, they should be *.php and *.html
bigstar is offline  
Old 02-09-2004, 06:02 PM   #13
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Quote:
Originally posted by bigstar
I still think the files are being sent in the wrong transfer mode. Perhaps by doing that the file format is slightly corrupted and that's what you get this unsual behavior with notepad.

Check the file association pattern, they should be *.php and *.html
Does this look right?
Attached Thumbnails
Editing annoyance-ps-jpg  
steen is offline  
Old 02-09-2004, 10:16 PM   #14
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Nope i'm afraid not, you need to add *. in front of each file extension.

*.html
*.htm
*.php
bigstar is offline  
Old 02-10-2004, 01:34 AM   #15
steen
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

Quote:
Originally posted by bigstar
Nope i'm afraid not, you need to add *. in front of each file extension.

*.html
*.htm
*.php
Thank you,
it works!


I hope this will end my crunching problem
steen is offline  
 

Tags
annoyance, editing, fxp, html, php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Route to Host Don General Discussion 1 08-22-2004 10:07 PM
change vfsfile -> crash cez Bug Reports 1 01-05-2003 07:20 PM
No UTF8 or Unicode Support! Tahattmeruh Software 1 12-02-2002 06:45 PM


All times are GMT -5. The time now is 08:34 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)