Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 10-24-2003, 01:13 PM   #1
seanr
Member
FlashFXP Registered User
 
Join Date: Jun 2002
Posts: 37
Default Directory list timeout?

On one of my servers (www.glassbaron.com), I have a directory with 1392 files in it (images). The server is unix but does not report the FTP server software or version.

What's happening is that it will occassionally crap out trying to list the directory and get disconnected, like the list command is timing out or something. Once it does it, sometimes it'll get the listing by going through the server list to reconnect (but never by selecting 'reconnect'), and a couple times I had to completely exit FlashFXP before it would list that directory (even though it was listing other directories on the site). Any idea why it's crapping out like that?

Also, I noticed that FlashFXP is not displaying any kind of transfer status during the list transfer. It just says "Listing Directory." It'd be really usefull to know whether it's actually transfering data at that point and how much it's getting before it dies.

I'm using build 924.
seanr is offline  
Old 10-24-2003, 01:15 PM   #2
seanr
Member
FlashFXP Registered User
 
Join Date: Jun 2002
Posts: 37
Default

BTW, when it does successfully work, it takes just about the same amount of time (15 sec., as near as I can tell) as it does before it disconnects when it fails.
seanr is offline  
Old 10-24-2003, 01:27 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I suspect no data is being transfered and something goes wrong, during a listing that status changes to "Listing Directory, XXXXX bytes" where XXX is the number of bytes transferred.

Are you using Passive or Active Mode?
bigstar is offline  
Old 10-24-2003, 01:31 PM   #4
seanr
Member
FlashFXP Registered User
 
Join Date: Jun 2002
Posts: 37
Default

Yeah, you're right, I just now noticed it does show the bytes transfered once it actually starts.

I'm using passive mode. Active mode won't work on this machine because of a firewall.

How long is FlashFXP willing to wait for the server to start transfering the list? I'd swear the thing is timing out.
seanr is offline  
 

Tags
directory, list, listing, server, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:09 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)