Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 09-25-2003, 07:50 AM   #1
Kibe
Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Feb 2002
Posts: 75
Default FXP problem with large files

Hey guys, I hope you can give me some idea about this problem.

It only happens when I transfers large files, for instance 50 mb, through some not so fast servers, so it takes about 40 minutes to finish each file. I suspect that FlashFXP is not receiving the reply from the destination server indicating that file was received.

Is it possible that Winroute is closing this connection because it was idle for a long time? Is that possible this can be fixed in a future build?

I'm using:

- FlashFXP 2.1, build 924, Registered
- WIndows XP Pro SP1
- Running behind a NAT, WInroute Pro 4.2.5
- Network ADSL

This is a sample of what status window reports:

List (cached)
List Complete.
TYPE I
200 Type set to I.
PASV
227 Entering Passive Mode (xxx,xxx,xxx,xxx,10,240)
PORT xxx,xxx,xxx,xxx,10,240
200 PORT Command successful.
STOR xxxxxxxxx.rar
150 Opening BINARY mode data connection for xxxxxxxxx.rar.
RETR xxxxxxxxx.rar
150 Opening BINARY mode data connection for xxxxxxxxx.rar (50000000 bytes).
226 Transfer complete.
421 Connection timed out - closing.
Transfer Failed!
Kibe is offline  
Old 09-25-2003, 12:46 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,845
Default

preference, Proxy/Firewall/Ident tab, enable "Send NOOP during transfer".
if that doesn't help, look into settings for WinRoute to increase idle connection timeout value.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 09-26-2003, 12:01 AM   #3
Kibe
Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Feb 2002
Posts: 75
Default

Thanks for your reply MxxCon!

I've already tryed to enable noop during transfers, but it wouldn't help. Reading your suggestion, I realized that the answer would probably be in Winroute.

I'm gonna try this setting now and check what happens:

Settings/Advanced/Misc. Options/Advanced Options
NAT Table Default timeout for TCP protocol 90 minutes (default was 40)

I'll report as soon as I notice any change.
Kibe is offline  
Old 09-27-2003, 06:53 PM   #4
Kibe
Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Feb 2002
Posts: 75
Default

Just to let you know, my problem is solved.

If someone have the same issue, just change those setting I mentioned above, ok?

Kibe is offline  
Old 09-27-2003, 08:38 PM   #5
NathanO
Senior Member
FlashFXP Registered User
 
NathanO's Avatar
 
Join Date: May 2002
Posts: 126
Default

If anyone knows how to solve this problem with a D-Link DI-707P router I'd like to know

It has no option for timeout values
NathanO is offline  
Old 10-04-2003, 12:11 AM   #6
NathanO
Senior Member
FlashFXP Registered User
 
NathanO's Avatar
 
Join Date: May 2002
Posts: 126
Default

Solved it by using the 'Bind sockets to this address' and setting it to my WAN IP and ticking 'Site uses IP Masq/NAT/Non-Routable IP' in SiteList for the site that was timing out.
NathanO is offline  
 

Tags
complete, connection, mode, winroute, xxxxxxxxx.rar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"login incorrect." a bug? jahknee Bug Reports 10 01-29-2003 02:33 PM


All times are GMT -5. The time now is 11:23 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)