Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 04-21-2003, 03:52 PM   #1
cenzo
Junior Member
 
Join Date: Apr 2003
Posts: 4
Default Error

I have a ftp server setup and no users have trouble uploding or downloading.

When one of my users tries to use flashfxp he can upload part of the file and then gets this error:


426 Data connection closed, file transfer test.r38 aborted.


1/4th of the files go through fine.

3/4 get truncated. at random file sizes less then full.


I am behind a linksys router with the latest firmware. I have the server working fine all except for fxp and file sizes.

Any ideas?

thanks in advance
cenzo is offline  
Old 04-21-2003, 04:35 PM   #2
Raccoon
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2001
Posts: 136
Default

The user using FlashFXP to FXP a file from another site to your site, I take it?

Try and find out if the file fails after some set amount of time. Perhaps you have some Anti-Idle settings on your server that are causing the transfer to fail, because the Control Connection is being considered as "idle" when no Data Activity is coming from that user's same IP address. Some FTP servers use different methods of tracking a user's idle time, and By IP Address is one of those methods, even if they did initiate the FXP transfer.

- Raccoon
Raccoon is offline  
Old 04-21-2003, 05:10 PM   #3
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default Mr 426 is in the house!

Hey,

I'm the user who's trying to FXP to Cenzo's server, I get this error even from my work PC so I'm ruling out my PC as bring the problem (sorry Cenzo ). I'm using FlashFXP version 2.0 (Build 906). I FXP for Europe, and Cenzo's FTP is the only one I ever get this 426 error with, I use the same version of Flash at work.

All the source sites are other 3rd party offices which I have no control over the settings on. But I continually FXP from these servers to other sources running different kinds of servers, with no problem.

Have tried doing all possible combinations of the settings; PASV mode on/off, NAT/Non-Routable IP on/off, alternative upload.

I've not got much hair left and this isn't aiding the matter!
sHaRpEy is offline  
Old 04-21-2003, 06:39 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

without seeing complete status log and knowing sHaRpEy's network setup, it does seem like cenzo's router is closing the connection..
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 04-21-2003, 06:48 PM   #5
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Thumbs up

Okies sorry, I'm gathering some logs right now for ya....
sHaRpEy is offline  
Old 04-21-2003, 06:51 PM   #6
cenzo
Junior Member
 
Join Date: Apr 2003
Posts: 4
Default

We tried using a diff ftp server, serv-u instead of g6 but same problem.

Some files go fine, most stop at differing sizes.

I have a linksys befsr41 with the 1.44.2, Dec 13 2002 firmware.

I run a ftp server with no other users reporting problems.

Im not sure any of the other users are using fxp or not.

I use a dynamic dns service b/c of my changing ip address. Could that have something to do with it?

I play everquest behind the same router and dont lag or go Link Dead often.

I have ports 5000-6000 for the ftp server and have it set to use them. I have 420 as the main ftp port.

What info can I get for you to allow you to better help us?
Im eager to resolve this.
cenzo is offline  
Old 04-21-2003, 06:53 PM   #7
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default

Quote:
I have a linksys befsr41 with the most recent firmware
Don't just say you have the latest version! lol
sHaRpEy is offline  
Old 04-21-2003, 06:58 PM   #8
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Exclamation Info...........

150 Opening data connection for xxxxxx-xxx.xxx.
RETR xxxxxx-xxx.xxx
150 Opening BINARY mode data connection for xxxxxx-xxx.xxx(15000000 bytes).
426 Data connection closed, file transfer xxxxxx-xxx.xxx aborted.
Transfer Failed!
PASV
227 Entering Passive Mode (xxx,xxx,xxx,x,19,99)

This is what it does on EVERY file, and it seems to be at random stages, not after any given filesize.

At home I am directly connected to the internet with no outgoing filters on my firewall software, at work I'm behind CheckPoint Firewall-1 running on a Nokia unit.

Operating system here is Win2K SP3, at work is Win2K Server.

Cheers.
sHaRpEy is offline  
Old 04-22-2003, 06:54 AM   #9
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default

In addition, the last lot of files I tried to upload to Cenzo, all seem to have stopped uploading around the 2-2.5Mb mark if that's of any help?!
sHaRpEy is offline  
Old 04-22-2003, 07:07 AM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

enable time stamping, right click on the status window and select timestamp. check the time between when the transfer starts and when it fails..
bigstar is offline  
Old 04-22-2003, 07:15 AM   #11
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default

Will do....cheers.
sHaRpEy is offline  
Old 04-22-2003, 07:56 AM   #12
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default

[16:23:51] STOR tbs-px.r44
[16:23:51] 150 Opening data connection for tbs-px.r44.
[16:23:51] REST 5570560
[16:23:51] 350 Restarting at 5570560. Send STORE or RETRIEVE.
[16:23:51] RETR tbs-px.r44
[16:23:52] 150 Opening BINARY mode data connection for tbs-px.r44 (15000000 bytes).
[16:25:50] 426 Data connection closed, file transfer tbs-px.r44 aborted.
[16:25:50] Transfer Failed!

Here's an example
sHaRpEy is offline  
Old 04-22-2003, 12:50 PM   #13
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

do all of the transfers fail roughly 2 minutes after they start?
bigstar is offline  
Old 04-22-2003, 01:14 PM   #14
sHaRpEy
Junior Member
 
Join Date: Apr 2003
Posts: 13
Default

Well obviously that's gonna depend on the speed both ends, but it seem to be around the 2Mb mark after more observation, speeds are normally around the 40-50k/sec mark on average.
sHaRpEy is offline  
Old 04-22-2003, 02:02 PM   #15
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Well if the time between each failiure was uniform that would point more towards a router/firewall closing the connection after a givin amount of time has passed. A router/firewall can only manage so many connections at any givin time dropping connections to make room for new ones.

With my linksys router if I run The All-Seeing Eye (game scanner) after a minute of scanning for activate game servers all my other activate connections get dropped by the router.
bigstar is offline  
 

Tags
error, file, server, sizes, users

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uploading to several servers alftore General Discussion 6 05-25-2005 08:33 AM


All times are GMT -5. The time now is 11:25 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)