Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 12-18-2002, 09:55 AM   #1
trplh0512
Junior Member
 
Join Date: Nov 2002
Posts: 2
Question passive .vs. non-passive

is there a way to make flashfxp default to a non-passive mode when logging into ftp servers? so many people now are using routers that do not support passive mode ftp. any help would be appreciated.

-=[trplh0512]=-
trplh0512 is offline  
Old 12-18-2002, 10:15 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Options > Preferences > Proxy Tab

Uncheck "Use Passive mode"

All sites using the global default will become active mode.
bigstar is offline  
Old 12-18-2002, 04:05 PM   #3
trplh0512
Junior Member
 
Join Date: Nov 2002
Posts: 2
Default

thanks a bunch!

-=[trplh0512]=-
trplh0512 is offline  
Old 03-26-2004, 08:34 AM   #4
Psi
Junior Member
 
Join Date: Apr 2002
Posts: 11
Default

Quote:
Originally posted by bigstar
Options > Preferences > Proxy Tab

Uncheck "Use Passive mode"

All sites using the global default will become active mode.

Unfortunately, I disabled both Passive options in Site Manager and Proxy section and it still forces Passive mode. I use 2.1 - 924.
My ISP requires disabling Passive while using Proxy.


Microsoft wsock32.dll, ver2.2, 32bit of Apr 22 1999, at 20:29:32.
Connecting to chs via Proxy (192.168.2.254:8080)
220
331 Password required for chs.
PASS (hidden)
230 User chs logged in.
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
CWD /kazania/Po_co_ja_tutaj_tak_naprawde_jestem?_cz.3/
250 CWD command successful.
PWD
257 "/kazania/Po_co_ja_tutaj_tak_naprawde_jestem?_cz.3" is current directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (217,153,183,83,7,169).
LIST


Please help me to disable the Passive mode effectively
Psi is offline  
Old 03-26-2004, 11:17 AM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Oh, I wasn't aware that you were using a proxy. Which proxy type are you using? Some proxy types require passive mode. Off hand I know socks & http proxy do.
bigstar is offline  
Old 03-26-2004, 11:22 AM   #6
Psi
Junior Member
 
Join Date: Apr 2002
Posts: 11
Default

Quote:
Originally posted by bigstar
Oh, I wasn't aware that you were using a proxy. Which proxy type are you using? Some proxy types require passive mode. Off hand I know socks & http proxy do.
This is http proxy, but here only the active mode is allowed.

Psi
Psi is offline  
Old 03-26-2004, 12:06 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

using a http proxy it's impossible to do active mode connections, the data connection would by-pass the proxy.
bigstar is offline  
 

Tags
mode, non-passive, passive, routers, support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
cant browse a directory MiSiL General Discussion 5 03-11-2005 07:44 AM


All times are GMT -5. The time now is 06:29 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)